Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1
    Junior Member
    Join Date
    Aug 2021
    Posts
    4

    Picoreplayer + Rotel USB

    Hey guys,

    Been searching all over these forums to try to figure out what is happening here.

    Have a raspberrypi 3B+ with Picoreplayer installed and hooked up to a Rotel a14 amp via USB.
    Works and sounds great, only problem is when i turn off the amp, then turn it back on I get no output.

    It's like Squeezelite doesn't recognise the output but I've looked at the diagnostics and when turned back on, I do see that it recognises the amp in the output log.

    When actually playing, the Rotel display shows "FREQ: 44.1KHz" and when turning amp back on while Squeezelite is still on, the amp never displays this.
    Only when I reboot Squeezelite does it show this and starts normal playback.


    I've tried these solutions to no avail:

    Ľ Changing the output to "front:CARD=R20,DEV=0" as I've seen that has helped some people.
    Ľ Entering 44100 in the Max sample rate field
    Ľ Autostart-squeezelite-from-usb-dac in the picoreplayer documentation


    If nothing else, is someone able to post how I would make Squeezelite restart once it detects the USB output?
    I don't have experience in linux but know how to SSH and can follow instructions.

    Thank you all.
    Last edited by Baejie; 2021-08-02 at 04:51.

  2. #2
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    8,004
    Quote Originally Posted by Baejie View Post
    Hey guys,

    Been searching all over these forums to try to figure out what is happening here.

    Have a raspberrypi 3B+ with Picoreplayer installed and hooked up to a Rotel a14 amp via USB.
    Works and sounds great, only problem is when i turn off the amp, then turn it back on I get no output.

    It's like Squeezelite doesn't recognise the output but I've looked at the diagnostics and when turned back on, I do see that it recognises the amp in the output log.

    When actually playing, the Rotel display shows "FREQ: 44.1KHz" and when turning amp back on while Squeezelite is still on, the amp never displays this.
    Only when I reboot Squeezelite does it show this and starts normal playback.


    I've tried these solutions to no avail:

    Ľ Changing the output to "front:CARD=R20,DEV=0" as I've seen that has helped some people.
    Ľ Entering 44100 in the Max sample rate field
    Ľ Autostart-squeezelite-from-usb-dac in the picoreplayer documentation


    If nothing else, it someone about to post how I would make Squeezelite restart once it detects the USB output?
    I don't have experience in linux but know how to SSH and can follow instructions.

    Thank you all.
    What happened when you tried this? As far as I know it should work.
    https://docs.picoreplayer.org/projec...-from-usb-dac/

    Sent from my Pixel 3a using Tapatalk

  3. #3
    Junior Member
    Join Date
    Aug 2021
    Posts
    4
    Quote Originally Posted by slartibartfast View Post
    What happened when you tried this? As far as I know it should work.
    https://docs.picoreplayer.org/projec...-from-usb-dac/

    Sent from my Pixel 3a using Tapatalk
    Unfortunatley it doesn't work because squeezelite is fine and running.
    I think this solution is when squeezlite doesn't start because it can't detect the output?

  4. #4
    Senior Member
    Join Date
    Jan 2011
    Location
    Staffordshire. UK
    Posts
    4,766
    @Baejie

    Have you switched the amp to USB Audio Class 2.0 ?

    ronnie

  5. #5
    Senior Member
    Join Date
    Jan 2011
    Location
    Staffordshire. UK
    Posts
    4,766
    @Baejie


    Also, have you read through page 16 of the manual about the Signal Sense function ?

    https://www.rotel.com/sites/default/...%20Ver%20P.pdf

    ronnie

  6. #6
    Senior Member
    Join Date
    Jan 2011
    Location
    Staffordshire. UK
    Posts
    4,766
    @Baejie


    I don't know if these settings survive a power off or require the amp to be left in standby

  7. #7
    Junior Member
    Join Date
    Aug 2021
    Posts
    4
    Quote Originally Posted by Man in a van View Post
    @Baejie


    Also, have you read through page 16 of the manual about the Signal Sense function ?

    https://www.rotel.com/sites/default/...%20Ver%20P.pdf

    ronnie
    Hey Ronnie,

    Thanks for your help!

    The pi is connected via the PC-USB port which, if I'm reading correctly, doesn't have the signal sense, only the powered usb-a port (22) does?

    And yep, USB 2.0 is activated.

  8. #8
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    8,004
    You might find something that works on this thread. Some posts deal with stopping squeezelite when the DAC is off and starting it when turned back on.
    https://forums.slimdevices.com/showt...-USB-dac/page7

    Sent from my Pixel 3a using Tapatalk

  9. #9
    Senior Member
    Join Date
    Jan 2011
    Location
    Staffordshire. UK
    Posts
    4,766
    Quote Originally Posted by Baejie View Post
    Hey Ronnie,

    Thanks for your help!

    The pi is connected via the PC-USB port which, if I'm reading correctly, doesn't have the signal sense, only the powered usb-a port (22) does?

    And yep, USB 2.0 is activated.
    From the manual:

    NOTE: When the SIGNAL SENSE function is activated the A14 will consume additional power in signal sense standby mode. • FIXED GAIN: Configures a Fixed Volume level for a specified input. To enable this feature, select the desired fixed volume level for AUX1, AUX2, USB, PC-USB, Optical 1, Optical 2, Coax 1, Coax 2, or Bluetooth. When enabled and the input with a Fixed Volume is selected, the Volume level will immediately be set to the specified level. Valid settings include: VARIABLE, FIXED MIN, FIXED 01-95, FIXED MAX. • AUX1 VOL: VARIABLE (disabled) is factory default. • AUX2 VOL: VARIABLE (disabled) is factory default. • USB VOL: VARIABLE (disabled) is factory default. • PC-USB VOL: VARIABLE (disabled) is factory default. • OPT1 VOL: VARIABLE (disabled) is factory default. • OPT2 VOL: VARIABLE (disabled) is factory default. • COAX1 VOL: VARIABLE (disabled) is factory default. • COAX2 VOL: VARIABLE (disabled) is factory default. • BTOOTH VOL: VARIABLE (disabled) is factory default

    I read this as disabled by default.

    I would check the setting and see if it works coming out of standby.

    Do you power off the amp and the pi, or just the amp and leave the pi powered on. It might help to try with the pi powered on and playing.

    It's hard to suggest a workaround without the amp to play with.

    I have a system with auto-sensing active speakers, a Toppin DX3 Pro dac/pre with autosensing on / off and two rpi players (pCP) plugged into the Topping, one usb and one co-ax spdif.

    The USB connected pi has autostart favourite enable.

    I power all through a powerextension. LMS is on another rpi which is powered on all the time.

    I power everything off, power it all on together and a minute or so later music starts playing.

    ronnie

  10. #10
    Junior Member
    Join Date
    Aug 2021
    Posts
    4
    Quote Originally Posted by slartibartfast View Post
    You might find something that works on this thread. Some posts deal with stopping squeezelite when the DAC is off and starting it when turned back on.
    https://forums.slimdevices.com/showt...-USB-dac/page7

    Sent from my Pixel 3a using Tapatalk
    That's definitely what I'm looking for and I played around with this for a while but still couldn't get it to work.

    Quote Originally Posted by Man in a van View Post
    I have a system with auto-sensing active speakers, a Toppin DX3 Pro dac/pre with autosensing on / off and two rpi players (pCP) plugged into the Topping, one usb and one co-ax spdif.
    The USB connected pi has autostart favourite enable.
    ronnie
    When reading this I just gave up trying an elegant solution and powered the Pi through the USB-A on the Rotel, so now when I turn the amp on or off the Pi also turns on and off. Simple and it works.

    Will continue playing around but this will do for now.

    Thank you both!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •