Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 2 12 LastLast
Results 1 to 10 of 12
  1. #1

    Track info/artwork display one track behind

    My LMS server firmware version is 8.1.1-1610364019. Touch firmware version is 8.0.1-r16855.The LMS material skin app and my Touch player display the information and cover art of the previous track, not the current one. I did a few experiements and found it happens when shuffle is turned on and right after the first song, which means after the first song finishes, the display repeats the same info and art work and then proceed to the second track when the third one is already playing. The problem is always there regardless the playlist consists of just one album (folder) or multiple albums (folder with subfolders). If shuffle is unchecked, the display repeats the second track and then proceed to the third while the fourth is playing. Obviously tracks are not of the same length, the display either skips the extra time or stops at the end and waits. In all the situation above, only a local library is in use, no online contents. Please advise.

  2. #2
    Senior Member
    Join Date
    Jan 2006
    Location
    Boston
    Posts
    264
    I'm not sure why you put this in the plugins forum.. are you using a now playing plugin?

    Problems like this have been reported a few times over the last couple years but never been reproducible.
    I will say the few times I've seen it, I have been using shuffle by song on a playlist.
    Hopefully Michael Herger sees this here.. see also this thread:

    http://forums.slimdevices.com/showthread.php?t=113482

    it might be better to follow up there.

  3. #3
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    7,637
    Quote Originally Posted by gregklanderman View Post
    I'm not sure why you put this in the plugins forum.. are you using a now playing plugin?

    Problems like this have been reported a few times over the last couple years but never been reproducible.
    I will say the few times I've seen it, I have been using shuffle by song on a playlist.
    Hopefully Michael Herger sees this here.. see also this thread:

    http://forums.slimdevices.com/showthread.php?t=113482

    it might be better to follow up there.
    Also here
    https://forums.slimdevices.com/showthread.php?p=982394

    Sent from my Pixel 3a using Tapatalk

  4. #4
    Senior Member
    Join Date
    Feb 2011
    Location
    Cheshire, UK
    Posts
    6,167
    Quote Originally Posted by verycd View Post
    My LMS server firmware version is 8.1.1-1610364019. Touch firmware version is 8.0.1-r16855.The LMS material skin app and my Touch player display the information and cover art of the previous track, not the current one. I did a few experiements and found it happens when shuffle is turned on and right after the first song, which means after the first song finishes, the display repeats the same info and art work and then proceed to the second track when the third one is already playing. The problem is always there regardless the playlist consists of just one album (folder) or multiple albums (folder with subfolders). If shuffle is unchecked, the display repeats the second track and then proceed to the third while the fourth is playing. Obviously tracks are not of the same length, the display either skips the extra time or stops at the end and waits. In all the situation above, only a local library is in use, no online contents. Please advise.
    This is something that appears with shuffle enabled from time to time but it’s not something that annoys many people probably because very few actually use shuffle as there are far better ways to get random play of a subset of your music.
    However all of these other ways require properly tagged files and I’m sure you said elsewhere that your reason for using folders is because your music isn’t tagged properly.
    Why not spend an hour or two tagging just one or two artists files properly then do a rescan and look at Artists and Albums in Material. You’ll see how these jump in points (and New Music) are much better than Folders from a navigation point of view. Then you can experiment with Random Play and Don’t Stop The Music / LastMix which are not quite the same as Shuffle but IMO give better results.
    Jim
    https://jukeradio.double6.net


    VB2.4 storage QNAP TS419p (NFS)
    Living Room Joggler & Pi4/Khadas -> Onkyo TXNR686 -> Celestion F20s
    Office Joggler & Pi3 -> Denon RCD N8 -> Celestion F10s
    Dining Room SB Radio
    Bedroom (Bedside) Pi Zero+DAC ->ToppingTP21 ->AKG Headphones
    Bedroom (TV) & Bathroom SB Touch ->Denon AVR ->Mordaunt Short M10s + Kef ceiling speakers
    Guest Room Joggler > Topping Amp -> Wharfedale Modus Cubes

  5. #5
    Senior Member
    Join Date
    Jan 2006
    Location
    Boston
    Posts
    264
    Is shuffling a curated mix playlist no longer a thing, d6jg? :-)
    Is there a preferred way to do that?

  6. #6
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    7,637
    Quote Originally Posted by gregklanderman View Post
    Is shuffling a curated mix playlist no longer a thing, d6jg? :-)
    Is there a preferred way to do that?
    When it happened to me I wasn't using shuffle anyway, just random mix of albums.

    Sent from my Pixel 3a using Tapatalk

  7. #7
    Senior Member
    Join Date
    Feb 2011
    Location
    Cheshire, UK
    Posts
    6,167
    Quote Originally Posted by gregklanderman View Post
    Is shuffling a curated mix playlist no longer a thing, d6jg? :-)
    Is there a preferred way to do that?
    Yes of course you can do that but the OP is accessing via folders choosing a folder or folder with sub folders and hitting play with shuffle. His tags are … not sure ……but it sounds like they are non existent and no mention of saved playlists.

    Personally went I want a random playlist I prefer to choose half a dozen tracks manually and then let DSTM/LastMix do it’s stuff.
    Jim
    https://jukeradio.double6.net


    VB2.4 storage QNAP TS419p (NFS)
    Living Room Joggler & Pi4/Khadas -> Onkyo TXNR686 -> Celestion F20s
    Office Joggler & Pi3 -> Denon RCD N8 -> Celestion F10s
    Dining Room SB Radio
    Bedroom (Bedside) Pi Zero+DAC ->ToppingTP21 ->AKG Headphones
    Bedroom (TV) & Bathroom SB Touch ->Denon AVR ->Mordaunt Short M10s + Kef ceiling speakers
    Guest Room Joggler > Topping Amp -> Wharfedale Modus Cubes

  8. #8
    In fact, I just tried one of my properly tagged albums. In the album directory, without using shuffle, the display as still one song behind while the album was played in regular order, i.e. after the first song finished, the second song started but the display remained the same untill the third song started, then the display changed to the second song.

    In any case, since the issue is not reproducible in other users' system, there is nothing to be expected.

    I posted the issue here because I thought it was related the LMS firmware (community developed new versions) or the material skin app, which are 3rd party software.
    Last edited by verycd; 2021-08-02 at 10:19.

  9. #9
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    7,637
    Quote Originally Posted by verycd View Post
    In fact, I just tried one of my properly tagged albums. In the album directory, without using shuffle, the display as still one song behind while the album was played in regular order, i.e. after the first song finished, the second song started but the display remained the same untill the third song started, then the display changed to the second song.

    In any case, since the issue is not reproducible in other users' system, there is nothing to be expected.

    I posted the issue here because I thought it was related the LMS firmware (community developed new versions) or the material skin app, which are 3rd party software.
    Is your artwork always one track behind? What happens if you skip forward to the next track?

    Sent from my Pixel 3a using Tapatalk

  10. #10
    Quote Originally Posted by slartibartfast View Post
    Is your artwork always one track behind? What happens if you skip forward to the next track?

    Sent from my Pixel 3a using Tapatalk
    Just tried another properly tagged album, same result. Yes, always one song behind except the first-played song no matter where I choose to start the album. If I click forward, the current song restarts and the artwork moves forward to the correct song. If choose to (re-)play the current song from "browse", the artwork moves forward too to the current correct song.

    The LMS is on a Windows 10 machine with i5 processor (not running anything else while testing), usb 2.0 HDD storage for the library. No longer than normal tracks.
    Last edited by verycd; 2021-08-02 at 10:52.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •