Home of the Squeezebox™ & Transporter® network music players.
Page 25 of 29 FirstFirst ... 152324252627 ... LastLast
Results 241 to 250 of 284
  1. #241
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,599

    [Announce] Spotty 4.6 - sorting optionfor Albums/Artists/Songs, replay gain fix

    > The official Spotify app also suggests genre mixes, decade mixes,
    > artists mixes and artists radios on the “made for you page”, but Spotty
    > does not show these extra suggestions.


    Are these mixes, or some playlists brought to the front every now and
    then? I don't see them.

  2. #242
    Quote Originally Posted by mherger View Post
    > The official Spotify app also suggests genre mixes, decade mixes,
    > artists mixes and artists radios on the “made for you page”, but Spotty
    > does not show these extra suggestions.


    Are these mixes, or some playlists brought to the front every now and
    then? I don't see them.
    They show up on the home page, but not every time. But I can go to search and then click on the made for you page and then they are their every time.

  3. #243
    Junior Member
    Join Date
    Sep 2021
    Posts
    8
    Quote Originally Posted by mherger View Post
    >
    I'm at a loss here... the warning about the VC runtime is a red hering.
    It's giving that warning whenever calling the helper fails on Windows,
    no matter the reason. But quite obviously the helper does run just fine,
    as you've tested multiple times now.

    Are you saying that Spotty did work before? I'm wondering whether this
    was due to some stricter protection in the Server edition of Windows. Could
    you check Windows' event logger whether you can find anything about
    spotty.exe?
    Yes, it was working for more than a year on that Windows server. Seem to stop working after the Visual C++ update to 2015-2019. I don't see anything in the event log. I'm a computer technician so I tried a lot of things. I'm gonna try a fresh install in a Windows server VM to see if it's related to the OS or the installation.

    Thanks

  4. #244
    Junior Member
    Join Date
    Sep 2021
    Posts
    8
    Quote Originally Posted by cthulhu View Post
    Yes, it was working for more than a year on that Windows server. Seem to stop working after the Visual C++ update to 2015-2019. I don't see anything in the event log. I'm a computer technician so I tried a lot of things. I'm gonna try a fresh install in a Windows server VM to see if it's related to the OS or the installation.

    Thanks
    Does spotty.exe use a specific port that might have been taken by another app? I've installed cryptomining apps on this server recently.

  5. #245
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,599

    [Announce] Spotty 4.6 - sorting optionfor Albums/Artists/Songs, replay gain fix

    > Does spotty.exe use a specific port that might have been taken by
    > another app? I've installed cryptomining apps on this server recently.


    It uses 5353 (udp/tcp). But that's a somewhat moot point, as you can run
    the helper interactively, and it would just work. That's really odd.

    Can you run it

    spotty.exe -a -c c:\temp -n test

    ? Then see whether it shows up in the Spotify app?

    I have no idea why the helper would run when launched manually, but not
    when launched from LMS. How are you running LMS? As an admin? Or the
    "SYSTEM" user?

  6. #246
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    7,795
    All my Spotty players reset to 49% volume again. Yet again logging for Spotty was turned off

    Sent from my Pixel 3a using Tapatalk

  7. #247
    Junior Member
    Join Date
    Sep 2021
    Posts
    8
    Quote Originally Posted by mherger View Post
    > Does spotty.exe use a specific port that might have been taken by
    > another app? I've installed cryptomining apps on this server recently.


    It uses 5353 (udp/tcp). But that's a somewhat moot point, as you can run
    the helper interactively, and it would just work. That's really odd.

    Can you run it

    spotty.exe -a -c c:\temp -n test

    ? Then see whether it shows up in the Spotify app?

    I have no idea why the helper would run when launched manually, but not
    when launched from LMS. How are you running LMS? As an admin? Or the
    "SYSTEM" user?
    When I run spotty.exe like you say, I should see a player named test in my Spotify app? I see nothing.

    I'm running LMS in the admin session of the server, and it run with the administrator account. I tested installing LMS and spotty in a fresh server 2019 VM in the same conditions, and it work well. Everything is up to date, and I even tried to update VC++ to the latest version without any issue.

  8. #248
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,599

    [Announce] Spotty 4.6 - sorting optionfor Albums/Artists/Songs, replay gain fix

    >> Can you run it
    >>
    >> spotty.exe -a -c c:\temp -n test
    >>
    >> ? Then see whether it shows up in the Spotify app?

    >
    > When I run spotty.exe like you say, I should see a player named test in
    > my Spotify app? I see nothing.


    But the helper would start? Any output?

  9. #249
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    7,795
    A couple of my players had their volume reset to 49 again but it looks like it wasn't at LMS restart but after checking the daemons. Logs attached
    Attached Files Attached Files

  10. #250
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,599

    [Announce] Spotty 4.6 - sorting optionfor Albums/Artists/Songs, replay gain fix

    > A couple of my players had their volume reset to 49 again but it looks
    > like it wasn't at LMS restart but after checking the daemons. Logs
    > attached


    Hmm... that log indeed shows incorrect behaviour. I'll have to dig deeper.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •