Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 2 12 LastLast
Results 1 to 10 of 16
  1. #1
    Senior Member
    Join Date
    Feb 2008
    Posts
    5,309

    Joggler & Squeezeplay resurrection

    After a couple of years in hibernation I have resurrected a Joggler with squeezeplay. OS installed.

    The first thing I noticed was when the Joggler is running the log message that 'you are using a Squeezebox with an outdated firmware'

    So checking through the Joggler settings I came across the Update option.... which states the unit is running ver. 1.60 with an update available to N. OU.....???

    Anybody seen the same?

    It looks suspicious to me.
    ------------------------------------------------------------------------------------

  2. #2
    Senior Member
    Join Date
    Jan 2011
    Location
    Staffordshire. UK
    Posts
    4,771
    Mr Webster recommended a fix for this and I think it was implemented by MHerger in one of the LMS versions.

    I don't have time to search for the links right now

    Are you using SQPOS 303 ? and is it internal or on a usb stick ?

    I can fire one up tomorrow, if you let me know what you are doing

    ronnie

  3. #3
    Senior Member
    Join Date
    Feb 2008
    Posts
    5,309
    Quote Originally Posted by Man in a van View Post
    Mr Webster recommended a fix for this and I think it was implemented by MHerger in one of the LMS versions.

    I don't have time to search for the links right now

    Are you using SQPOS 303 ? and is it internal or on a usb stick ?

    I can fire one up tomorrow, if you let me know what you are doing

    ronnie
    Hi

    303 on USB - Cisco
    ------------------------------------------------------------------------------------

  4. #4
    Senior Member
    Join Date
    Jan 2011
    Location
    Staffordshire. UK
    Posts
    4,771
    OK

    Just a couple of questions

    Is the Cisco connected by Wireless or Ethernet ?

    and

    which version of LMS is it connected to, and is that version on the same usb stick as Squeezeplay or on the Network.

    ronnie

  5. #5
    Senior Member
    Join Date
    Feb 2008
    Posts
    5,309
    Quote Originally Posted by Man in a van View Post
    OK

    Just a couple of questions

    Is the Cisco connected by Wireless or Ethernet ?

    and

    which version of LMS is it connected to, and is that version on the same usb stick as Squeezeplay or on the Network.

    ronnie
    Wireless
    8.1. 2
    Network
    ------------------------------------------------------------------------------------

  6. #6
    Senior Member
    Join Date
    Jan 2011
    Location
    Staffordshire. UK
    Posts
    4,771
    [21-07-02 08:47:11.4141] Slim::Networking:iscovery::getFakeVersion (131)
    You're using a SB SqueezePlay with a buggy firmware not recognizing this version of Logitech Media Server.
    Please consider patching it. Until then we'll try to play nice and return a fake version number...
    This was supposed to be fixed but maybe not

    I do remember at one time roobarb! did install an update procedure, so I went ahead and tapped on update. After eight minutes or so the wheel was still spinning, so I pulled the plug.

    Powered up again and started playing fip again, same message in the logs

    I restarted LMS but the message persisted.

    Here is a post from Mr Webster about the problem

    https://www.jogglerwiki.com/forum/vi...p=32803#p32803

    and here is the fix

    https://www.jogglerwiki.com/forum/vi...p=32469#p32469

    I'm going to have some Brerakfast and then I'll run the patch.

    I have done it before and it worked

    ronnie

  7. #7
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    4,962
    Not sure it is the same problem ... because I think my patch was to work around SqueezePlay saying the LMS is the wrong version.
    Anyway - it is here
    jogglerwiki.com/forum/viewtopic.php?p=32469#p32469
    Paul Webster
    Author of "Now Playing" plugins covering Radio France (FIP etc), PlanetRadio (Bauer - Kiss, Absolute, Scala, JazzFM etc), KCRW, ABC Australia and CBC/Radio-Canada
    and, via the extra "Radio Now Playing" plugin lots more - see https://forums.slimdevices.com/showt...Playing-plugin

  8. #8
    Senior Member
    Join Date
    Jan 2011
    Location
    Staffordshire. UK
    Posts
    4,771
    Well I did the patch, rebooted and the message is still there

    I restarted lms and

    Code:
    [21-07-02 10:44:05.0352] main::init (389) Starting Logitech Media Server (v8.1.2, 1624550702, Thu Jun 24 18:46:58 CEST 2021) perl 5.032000 - arm-linux-gnueabihf-thread-multi-64int
    [21-07-02 10:44:09.5146] Slim::Networking::Discovery::getFakeVersion (131) 
    You're using a SB SqueezePlay with a buggy firmware not recognizing this version of Logitech Media Server.
    Please consider patching it. Until then we'll try to play nice and return a fake version number...
    
    See https://github.com/Logitech/slimserver/blob/public/8.0/README.md#sb-radio-and-logitech-media-server-8.
    [21-07-02 10:44:11.4135] Slim::Formats::Playlists::Base::playlistEntryIsValid (125) Warning: iplayer://live?hls=http://a.files.bbci.co.uk/media/live/manifesto/audio/simulcast/hls/uk/sbr_high/ak/bbc_radio_two.m3u8&dash=http://a.files.bbci.co.uk/media/live/manifesto/audio/simulcast/dash/uk/dash_full/ak/bbc_radio_two.mpd&icon=http://radio-service-information.api.bbci.co.uk/logos/bbc_radio_two/128x128.png&radiovis=fm/ce1/c202/08880&onair=bbc_radio_two&track=on&title=BBC Radio 2&desc=The home of great music - Pop and Rock from the sixties, seventies, eighties and beyond to blues, big band, country and jazz with the best live music and documentaries found in playlist:
    	file:///usr/local/slimserver/prefs/clientplaylist_0004201ed766.m3u doesn't exist on disk - skipping!
    [21-07-02 10:44:11.4152] Slim::Formats::Playlists::Base::playlistEntryIsValid (125) Warning: file:///mnt/AirDisk/USB-DISK-A/Squeezebox/iplayer:/live%3Fhls=http:/a.files.bbci.co.uk/media/live/manifesto/audio/simulcast/hls/uk/sbr_high/ak/bbc_radio_two.m3u8&dash=http:/a.files.bbci.co.uk/media/live/manifesto/audio/simulcast/dash/uk/dash_full/ak/bbc_radio_two.mpd&icon=http:/radio-service-information.api.bbci.co.uk/logos/bbc_radio_two/128x128.png&radiovis=fm/ce1/c202/08880&onair=bbc_radio_two&track=on&title=BBC%20Radio%202&desc=The%20home%20of%20great%20music%20-%20Pop%20and%20Rock%20from%20the%20sixties,%20seventies,%20eighties%20and%20beyond%20to%20blues,%20big%20band,%20country%20and%20jazz%20with%20the%20best%20live%20music%20and%20documentaries found in playlist:
    	file:///usr/local/slimserver/prefs/clientplaylist_0004201ed766.m3u doesn't exist on disk - skipping!
    but everthing still works

    ronnie

  9. #9
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    4,962
    mherger made a change to LMS to accept the Joggler SqueezePlay version as OK with 8.x ... but I think you need LMS 8.2 (might be 8.1.2) to get it.
    Paul Webster
    Author of "Now Playing" plugins covering Radio France (FIP etc), PlanetRadio (Bauer - Kiss, Absolute, Scala, JazzFM etc), KCRW, ABC Australia and CBC/Radio-Canada
    and, via the extra "Radio Now Playing" plugin lots more - see https://forums.slimdevices.com/showt...Playing-plugin

  10. #10
    Senior Member
    Join Date
    Jan 2011
    Location
    Staffordshire. UK
    Posts
    4,771
    Quote Originally Posted by Paul Webster View Post
    mherger made a change to LMS to accept the Joggler SqueezePlay version as OK with 8.x ... but I think you need LMS 8.2 (might be 8.1.2) to get it.
    I'm running 8.1.2 now

    I'm also sure I had it working st some time previously, but I never check the logs if all is OK

    Im about to install lms v 8.2 on the usb stick, just have to expand the file system a little

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •