Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 8 of 8
  1. #1

    LMS on New Synology DS220+

    Is it possible to install any version of LMS on a new Synology DS220+ running DSM 6.2.4-25556?
    I understand there is no longer an official package from Synology. I can't find a package that can be installed using workarounds either. Have only used PC's for LMS so far with no experience of Synology. Docker, PERL etc. are all new to me but I am willing to try.

  2. #2
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,569

    LMS on New Synology DS220+

    > Is it possible to install any version of LMS on a new Synology DS220+
    > running DSM 6.2.4-25556?
    > I understand there is no longer an official package from Synology. I
    > can't find a package that can be installed using workarounds either.
    > Have only used PC's for LMS so far with no experience of Synology.
    > Docker, PERL etc. are all new to me but I am willing to try.


    The DS220+ should have Docker support. That's the way to go. Lot's of
    discussion about it around here.

  3. #3
    Thank you so much. New things to learn.

  4. #4
    I was able to find x86_64 versions for Perl 5.24.0-0074 and LMS 7.7.6-116. Installed successfully without any container but not tested on players yet. File copying will need some time! Auto update of packages is disabled.
    I hope this approach doesn't create some other problem.

  5. #5
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    20,644
    Quote Originally Posted by guptaas View Post
    I was able to find x86_64 versions for Perl 5.24.0-0074 and LMS 7.7.6-116. Installed successfully without any container but not tested on players yet. File copying will need some time! Auto update of packages is disabled.
    I hope this approach doesn't create some other problem.
    LMS 7.7 is ancient (last Logitech supported version) and has no https support so lots of plugins & services will not work.

    Use Docker container version 8.1.*

  6. #6
    Thank you. I'll probably do that in the second round. Since its my first NAS, I'm sure very soon I'll set it up again from scratch after learning about various pitfalls. There are many other background tasks I need to direct away from a PC to this little device. Each is going to be a mini challenge.
    However an ancient tool doesn't bother me as long as its not a security hole. I'm not feature hungry and actually love version 7.5.4 the most. Its a reliable old friend. Spotify was the sole reason to update which proved to be of little value to me.

  7. #7
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    4,429
    I don't remember if it is a 8.1.2 or 8.2 feature ... but enable "allow unsupported plugins" in the list of plugins and you should see many of the ones that you want are there.
    Since you managed to get Docker working with 8.1 ... then you might as well move to 8.2 anyway!
    Paul Webster
    http://dabdig.blogspot.com
    Author of "Now Playing" plugins covering Radio France (FIP etc), PlanetRadio (Bauer - Kiss, Absolute, Scala, JazzFM etc), KCRW, Supla Finland, ABC Australia, CBC/Radio-Canada and RTE Ireland

  8. #8

    Thank you

    Quote Originally Posted by Paul Webster View Post
    I don't remember if it is a 8.1.2 or 8.2 feature ... but enable "allow unsupported plugins" in the list of plugins and you should see many of the ones that you want are there.
    Since you managed to get Docker working with 8.1 ... then you might as well move to 8.2 anyway!
    I deleted my post almost immediately because I figured out how to get LMS to see plug-in files. You were quick. Thank you. This community is wonderful.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •