Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 3 of 3

Hybrid View

  1. #1
    Junior Member
    Join Date
    Jan 2018
    Location
    California near Sacramento
    Posts
    12

    Possible solution for Boom using LMS in Docker displaying UTC but not local time

    I have two Boom units and two Radios. All four had been connected to squeezenetwork.com and showed my local time. Recently I purchased a Synology NAS (DS920+) and installed LMS within Docker (thank you to others on this forum who wrote primers on how to do that!).

    I noticed that my Boom units were showing UTC while the Radio units were showing local time. So I read all (that I could find) posts here on the board that related to questions about getting Squeezebox Boom to display local timezone time.

    I understand that Boom doesn't have a timezone setting in it. I verified that my Boom does show PST/PDT when connected to squeezenetwork.com. Unfortunately while the media server at squeezenetwork.com allows setting timezones for a Boom, the LMS doesn't seem to have that feauture baked in.

    Based upon what others had mentioned, I updated my NAS server's timezone to Pacific. The date command confirmed local time was set. Then within the Docker container I defined a TZ environment variable and set that to America/Los_Angeles. From a SSH session, I ran "docker exec -it <container ID> date" and verified that the time within the container was also showing local time. The log for LMS has timestamps showing local time zone.

    My Boom units are now displaying local time. The reason I made all of these changes to the host and the docker container was because I understood that was where the Boom was getting the time display info from.

    Any corrections, or additional information from others that might help folks in the future is appreciated.

  2. #2
    Junior Member
    Join Date
    Jul 2021
    Posts
    1
    Hi, I'm solving the "timezone" problem with BOOM as well. Could I ask you for more info on the instructions "Then within the Docker container I defined a TZ environment variable and set that to America/Los_Angeles. From a SSH session, I ran "docker exec -it <container ID> date" and verified that the time within the container was also showing local time." ?
    How can I define the TZ variable and set it? Thanks a lot.

  3. #3

    Synology Timezone

    First you need to find out the name of your time zone. Wikipedia can help here - for me it is "Europe/Berlin".

    In DSM go to Docker, choose your image, "Launch" a new container. Click "Advanced Settings", "Environment" and add a new variable "TZ" with content"Europe/Berlin" (or wherever you are).

    BTW: You need to do the same for a Squeezebox Radio. Even if it shows the correct time without setting TZ the alarms go off at the wrong time.

    Tom


    Name:  syno1.jpg
Views: 38
Size:  99.0 KB
    Name:  syno2.jpg
Views: 43
Size:  112.3 KB

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •