Home of the Squeezebox™ & Transporter® network music players.
Page 39 of 39 FirstFirst ... 29373839
Results 381 to 389 of 389
  1. #381
    Member
    Join Date
    Nov 2011
    Location
    UK
    Posts
    99
    @michael

    Has the fix for volume normalisation made it into a released version yet, as it's not clear from the thread.

    Thanks

  2. #382
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,622

    [Announce] Spotty 4.5 - improved Oggdirect, Autoplay, multi-user setup

    > Has the fix for volume normalisation made it into a released version
    > yet, as it's not clear from the thread.


    No, but I hope to have it out later today.

  3. #383
    Senior Member
    Join Date
    Jan 2014
    Location
    Denmark
    Posts
    108
    Quote Originally Posted by mherger View Post
    > It was failing with an error saying something like “failed to get access
    > token, with a recommendation to try a spotty helper application. The
    > suggested helper application did not seem to fix the problem, so I tried
    > the legacy one (for ARM, this is running on an aging raspberry pi).


    What exact Pi? What helper is Spotty using now (see
    Settings/Advanced/Spotty)?

    > After a reboot I am not getting errors anymore, but when playing a track
    > I am getting these strange noises instead of music. Other sources than
    > Spotty seems to work fine though.


    Check Settings/Advanced/File Formats: what is Spotty using? Try SPT -> FLAC.
    The Pi model is B Plus rev 1.2 (512MB RAM). The Spotty helper application is listed as /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/SpottyARMLegacyBin/Bin/spotty (v0.12.2)

    I tried to fix the file format I now how the settings as follows

    Does that seem correct? The problem is still there. The player is a pi-zero with the hifiberry miniamp, if that matters.


    Sent from my iPhone using Tapatalk

  4. #384
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,622

    [Announce] Spotty 4.5 - improved Oggdirect, Autoplay, multi-user setup

    > The Pi model is B Plus rev 1.2 (512MB RAM). The Spotty helper
    > application is listed as
    > /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/SpottyARMLegacyBin/Bin/spotty
    > (v0.12.2)


    I guess you've been using that before? Can you double check what binary
    Spotty is using? It looks as if it didn't use the above, but the default
    helper. It should say "spotty-custom".

    In any case: please update to 4.6. If the problem persists (using FLAC
    and PCM), then please report in
    http://forums.slimdevices.com/showthread.php?t=114836 and include
    server.log if there's any info about spotty.



  5. #385
    Senior Member
    Join Date
    Jan 2014
    Location
    Denmark
    Posts
    108
    So now I am on 4.6. And the problem persists, I tried an other player to (squeezebox touch) and the sound is the same.

    I have tried removing the helper applications from the plugins menu and tried adding both the legacy one, and the ARMv8/aarch64 one. But only the legacy one (the one I listed above) seems to work (when that is not there the Spotty settings page tells me there is a problem finding the helper app). I tried running the different helper apps from command line and all but the legacy fail with errors either illegal instruction or Exec format error (which I believe hints the binary is for the wrong architecture?), this includes the one called spotty-custom you mentioned.

    I have also enabled flac and pcm for Spotty in the File Types settings.

    I have also re-entered my account credentials just to be sure.

    I am not really sure what to try next. Any ideas?


    Sent from my iPhone using Tapatalk

  6. #386
    Senior Member
    Join Date
    Jan 2014
    Location
    Denmark
    Posts
    108
    I should add, as long as the legacy helper was used there does not seem to be any messages in the log. Without it there are messages saying the helper cannot be found.


    Sent from my iPhone using Tapatalk

  7. #387
    Junior Member
    Join Date
    Jul 2010
    Location
    Sollentuna, Sweden
    Posts
    24
    Quote Originally Posted by mherger View Post
    > I understand the latest update of Spotty means that it is now not
    > compatible with 32-bit Windows 7 platform anymore. Is there a chance to
    > uninstall that update and reinstall a prior version that would work on a
    > 32-bit windows? The project of updating the system to 64bit will not
    > happen right now so would really want to find a way to get Spotty
    > working for a while more on this system.


    You can download
    https://github.com/michaelherger/Spo...ead/spotty.exe
    and put it as spotty-custom.exe somewhere in your helper search path
    (see Settings/Information). I'd recommend you do so outside LMS managed
    folders. This way it should survive plugin updates.

    Once you restart LMS, Spotty should pick up the custom version. You can
    check this in the Spotty settings.
    That worked great Thanks Michael!

  8. #388
    I am trying to get Spotify working on my squeezebox touch. I want to use my touch as a Spotify connect player and use the Spotify app to control the touch.
    I installed spotty and I am able to use my touch as a connected player but I have noticed that the ogg vorbis is recompiled as pcm and auto play does not work.

    I then installed the spotty helper, but now I cannot use my touch as a Spotify connect player, it doesnt show up in the app.

    My lms runs on a raspberry pi 4 (picore). How do I get Spotify to work and how can I use my touch as a Spotify connect player?

  9. #389
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,622

    [Announce] Spotty 4.5 - improved Oggdirect, Autoplay, multi-user setup

    > I installed spotty and I am able to use my touch as a connected player
    > but I have noticed that the ogg vorbis is recompiled as pcm and auto
    > play does not work.


    Spotty would stream PCM rather than Ogg if you had volume normalization
    enabled. But don't worry. It won't hurt the sound quality.

    > I then installed the spotty helper, but now I cannot use my touch as a
    > Spotify connect player, it doesn’t show up in the app.


    No need to install a helper, as it did play before, didn't it?

    > My lms runs on a raspberry pi 4 (picore). How do I get Spotify to work
    > and how can I use my touch as a Spotify connect player?


    From your description it looks as if it just worked as expected, until
    you started to try to change things. So please go back to default
    settings, no additional helper etc. And make sure you got your client ID
    configured correctly.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •