Home of the Squeezebox™ & Transporter® network music players.
Page 3 of 39 FirstFirst 1234513 ... LastLast
Results 21 to 30 of 389
  1. #21
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,600

    [Announce] Spotty 4.5 - improved Oggdirect, Autoplay, multi-user setup

    > Installed legacy plugin. No change - same red warning message as
    > initially reported.


    Please un-install all helper plugins. Then please download
    https://github.com/michaelherger/Spo.../aarch64-linux
    to your pCP, "chmod a+x spotty", then "./spotty -x". Would that not
    work? I've just had confirmation from Greg that it did work on his pCP.

  2. #22
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,600

    [Announce] Spotty 4.5 - improved Oggdirect, Autoplay, multi-user setup

    > Operating system: piCore - EN - utf8
    > Platform Architecture: armv8l-linux
    > Perl Version: 5.28.2 - arm-linux-gnueabihf-thread-multi-64int


    Hold on... what OS are you running? Perl 5.28 is rather dated for pCP.
    Mine is running 5.32.

  3. #23
    Senior Member
    Join Date
    Feb 2008
    Posts
    5,282
    Quote Originally Posted by mherger View Post
    > Operating system: piCore - EN - utf8
    > Platform Architecture: armv8l-linux
    > Perl Version: 5.28.2 - arm-linux-gnueabihf-thread-multi-64int


    Hold on... what OS are you running? Perl 5.28 is rather dated for pCP.
    Mine is running 5.32.
    It's
    piCorePlayer | piCorePlayer v6.1.0 | www v0009 | linux 4.19.122-pcpCore | piCore v10.3pCP | Squeezelite v1.9.9-1364-pCP
    ------------------------------------------------------------------------------------

  4. #24
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,600

    [Announce] Spotty 4.5 - improved Oggdirect, Autoplay, multi-user setup

    > It's
    > piCorePlayer | piCorePlayer v6.1.0 | www v0009 | linux 4.19.122-pcpCore
    > | piCore v10.3pCP | Squeezelite v1.9.9-1364-pCP


    I'm sorry... but it's time for an update. pCP7 has been out for months
    already, pCP8 is around the corner.

  5. #25
    Senior Member
    Join Date
    Feb 2008
    Posts
    5,282
    Quote Originally Posted by mherger View Post
    > It's
    > piCorePlayer | piCorePlayer v6.1.0 | www v0009 | linux 4.19.122-pcpCore
    > | piCore v10.3pCP | Squeezelite v1.9.9-1364-pCP


    I'm sorry... but it's time for an update. pCP7 has been out for months
    already, pCP8 is around the corner.
    Okay. Thanks.
    ------------------------------------------------------------------------------------

  6. #26
    Member
    Join Date
    Jun 2020
    Location
    UK
    Posts
    65

    Spotifer helper

    Hi, I'm not able to get Spotty 4.5.0 to run after upgrading today.

    I'm running Windows 10 on an old netbook that says its an X86 based PC which is 32bit windows I believe. The Spotty plugin page says a red warning
    There has been a problem running the Spotty helper application. Please make sure you have the Microsoft Visual C++ Runtime (32-bit!) installed on your system.

    I have this running but reinstalled it anyway.

    I can see the spotty.exe file in the plugins folder but if i try to run it separately I get the message "This app can't run on your PC"

    Heres the logs with my username for spotify changed to jkl123


    Search
    Refresh (50, 100, 500, 1000 lines) Download
    ]
    [21-06-18 14:49:57.9330] Slim::Web::JSONRPC::requestMethod (455) Request failed with error: Bad dispatch!
    [21-06-18 14:49:59.5567] Plugins::Spotty::Helper::get (51) Didn't find Spotty helper application!
    [21-06-18 14:49:59.5580] Plugins::Spotty::Helper::get (52) Last error:
    This version of C:\PROGRA~2\SQUEEZ~1\Cache\INSTAL~1\Plugins\Spotty \Bin\MSWIN3~1\spotty.exe is not compatible with the version of Windows you're running. Check your computer's system information and then contact the software publisher.
    [21-06-18 14:50:00.4469] Slim::Control::Request::execute (1888) Error: While trying to run function coderef [Slim::Plugin::Favorites::Plugin::cliBrowse]: [Can't use string ("jkl123") as a HASH ref while "strict refs" in use at C:\ProgramData\Squeezebox\Cache\InstalledPlugins/Plugins/Spotty/API/Token.pm line 141.
    ]
    [21-06-18 14:50:00.4493] Slim::Web::JSONRPC::requestMethod (455) Request failed with error: Bad dispatch!
    [21-06-18 14:50:02.6495] Plugins::Spotty::Helper::get (51) Didn't find Spotty helper application!
    [21-06-18 14:50:02.6508] Plugins::Spotty::Helper::get (52) Last error:
    This version of C:\PROGRA~2\SQUEEZ~1\Cache\INSTAL~1\Plugins\Spotty \Bin\MSWIN3~1\spotty.exe is not compatible with the version of Windows you're running. Check your computer's system information and then contact the software publisher.
    [21-06-18 14:50:03.4313] Slim::Control::Request::execute (1888) Error: While trying to run function coderef [Slim::Plugin::Favorites::Plugin::cliBrowse]: [Can't use string ("jkl123") as a HASH ref while "strict refs" in use at C:\ProgramData\Squeezebox\Cache\InstalledPlugins/Plugins/Spotty/API/Token.pm line 141.
    ]
    [21-06-18 14:50:03.4330] Slim::Web::JSONRPC::requestMethod (455) Request failed with error: Bad dispatch!
    [21-06-18 14:50:04.8219] Plugins::Spotty::Helper::get (51) Didn't find Spotty helper application!
    [21-06-18 14:50:04.8233] Plugins::Spotty::Helper::get (52) Last error:
    This version of C:\PROGRA~2\SQUEEZ~1\Cache\INSTAL~1\Plugins\Spotty \Bin\MSWIN3~1\spotty.exe is not compatible with the version of Windows you're running. Check your computer's system information and then contact the software publisher.
    [21-06-18 14:50:05.4942] Slim::Control::Request::execute (1888) Error: While trying to run function coderef [Slim::Plugin::Favorites::Plugin::cliBrowse]: [Can't use string ("jkl123") as a HASH ref while "strict refs" in use at C:\ProgramData\Squeezebox\Cache\InstalledPlugins/Plugins/Spotty/API/Token.pm line 141.
    ]
    [21-06-18 14:50:05.4966] Slim::Web::JSONRPC::requestMethod (455) Request failed with error: Bad dispatch!
    [21-06-18 14:50:57.9826] Plugins::Spotty::Helper::get (51) Didn't find Spotty helper application!
    [21-06-18 14:50:57.9840] Plugins::Spotty::Helper::get (52) Last error:
    This version of C:\PROGRA~2\SQUEEZ~1\Cache\INSTAL~1\Plugins\Spotty \Bin\MSWIN3~1\spotty.exe is not compatible with the version of Windows you're running. Check your computer's system information and then contact the software publisher.
    [21-06-18 14:50:59.8416] Plugins::Spotty::Helper::get (51) Didn't find Spotty helper application!
    [21-06-18 14:50:59.8429] Plugins::Spotty::Helper::get (52) Last error:
    This version of C:\PROGRA~2\SQUEEZ~1\Cache\INSTAL~1\Plugins\Spotty \Bin\MSWIN3~1\spotty.exe is not compatible with the version of Windows you're running. Check your computer's system information and then contact the software publisher.
    [21-06-18 14:51:00.7950] Plugins::Spotty::Helper::get (51) Didn't find Spotty helper application!
    [21-06-18 14:51:00.7966] Plugins::Spotty::Helper::get (52) Last error:
    This version of C:\PROGRA~2\SQUEEZ~1\Cache\INSTAL~1\Plugins\Spotty \Bin\MSWIN3~1\spotty.exe is not compatible with the version of Windows you're running. Check your computer's system information and then contact the software publisher.
    [21-06-18 14:51:00.7986] Plugins::Spotty::Connect::canSpotifyConnect (84) Cannot support Spotty Connect, need at least helper version 0.12.0
    [21-06-18 14:51:09.2636] Plugins::Spotty::Helper::get (51) Didn't find Spotty helper application!
    [21-06-18 14:51:09.2652] Plugins::Spotty::Helper::get (52) Last error:
    This version of C:\PROGRA~2\SQUEEZ~1\Cache\INSTAL~1\Plugins\Spotty \Bin\MSWIN3~1\spotty.exe is not compatible with the version of Windows you're running. Check your computer's system information and then contact the software publisher.
    [21-06-18 14:51:11.0760] Plugins::Spotty::Helper::get (51) Didn't find Spotty helper application!
    [21-06-18 14:51:11.0774] Plugins::Spotty::Helper::get (52) Last error:
    This version of C:\PROGRA~2\SQUEEZ~1\Cache\INSTAL~1\Plugins\Spotty \Bin\MSWIN3~1\spotty.exe is not compatible with the version of Windows you're running. Check your computer's system information and then contact the software publisher.
    [21-06-18 14:51:11.9666] Plugins::Spotty::Helper::get (51) Didn't find Spotty helper application!
    [21-06-18 14:51:11.9682] Plugins::Spotty::Helper::get (52) Last error:
    This version of C:\PROGRA~2\SQUEEZ~1\Cache\INSTAL~1\Plugins\Spotty \Bin\MSWIN3~1\spotty.exe is not compatible with the version of Windows you're running. Check your computer's system information and then contact the software publisher.
    [21-06-18 14:51:11.9695] Plugins::Spotty::Connect::canSpotifyConnect (84) Cannot support Spotty Connect, need at least helper version 0.12.0
    [21-06-18 15:00:19.4661] Plugins::Spotty::Helper::get (51) Didn't find Spotty helper application!
    [21-06-18 15:00:19.4674] Plugins::Spotty::Helper::get (52) Last error:
    This version of C:\PROGRA~2\SQUEEZ~1\Cache\INSTAL~1\Plugins\Spotty \Bin\MSWIN3~1\spotty.exe is not compatible with the version of Windows you're running. Check your computer's system information and then contact the software publisher.
    [21-06-18 15:00:21.7005] Plugins::Spotty::Helper::get (51) Didn't find Spotty helper application!
    [21-06-18 15:00:21.7018] Plugins::Spotty::Helper::get (52) Last error:
    This version of C:\PROGRA~2\SQUEEZ~1\Cache\INSTAL~1\Plugins\Spotty \Bin\MSWIN3~1\spotty.exe is not compatible with the version of Windows you're running. Check your computer's system information and then contact the software publisher.
    [21-06-18 15:00:22.7005] Plugins::Spotty::Helper::get (51) Didn't find Spotty helper application!
    [21-06-18 15:00:22.7018] Plugins::Spotty::Helper::get (52) Last error:
    This version of C:\PROGRA~2\SQUEEZ~1\Cache\INSTAL~1\Plugins\Spotty \Bin\MSWIN3~1\spotty.exe is not compatible with the version of Windows you're running. Check your computer's system information and then contact the software publisher.
    [21-06-18 15:00:22.7031] Plugins::Spotty::Connect::canSpotifyConnect (84) Cannot support Spotty Connect, need at least helper version 0.12.0

  7. #27
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,600

    [Announce] Spotty 4.5 - improved Oggdirect, Autoplay, multi-user setup

    > I'm running Windows 10 on an old netbook that says its an X86 based PC
    > which is 32bit windows I believe. The Spotty plugin page says a red
    > warning
    > There has been a problem running the Spotty helper application. Please
    > make sure you have the Microsoft Visual C++ Runtime (32-bit!) installed
    > on your system.


    Ouch... I forgot about this... yes, the new build is 64 bits. I haven't
    managed to build a 32 bit version on the 64 bit Windows I have. I'll
    probably have to provide access to those "legacy" builds :-(.

  8. #28
    Senior Member
    Join Date
    Feb 2008
    Posts
    5,282
    Quote Originally Posted by mherger View Post
    > It's
    > piCorePlayer | piCorePlayer v6.1.0 | www v0009 | linux 4.19.122-pcpCore
    > | piCore v10.3pCP | Squeezelite v1.9.9-1364-pCP


    I'm sorry... but it's time for an update. pCP7 has been out for months
    already, pCP8 is around the corner.
    Okay - updated to pcp 7.

    No go.

    There has been a problem running the Spotty helper application. You might want to give the additional "Spotty Legacy Helper for ARM" plugin a try.

    Operating system: piCore / armv7l-linux

    Helper Applications Folder:
    /usr/local/slimserver/Bin/armhf-linux
    /usr/local/slimserver/Bin
    /usr/local/sbin
    /usr/local/bin
    /sbin
    /usr/sbin
    /bin
    /usr/bin
    /usr/local/slimserver/Cache/InstalledPlugins/Plugins/CastBridge/Bin
    /usr/local/slimserver/Cache/InstalledPlugins/Plugins/RaopBridge/Bin
    /usr/local/slimserver/Cache/InstalledPlugins/Plugins/Spotty/Bin
    /usr/local/slimserver/Cache/InstalledPlugins/Plugins/Spotty/Bin/arm-linux
    /usr/local/slimserver/Cache/InstalledPlugins/Plugins/SpottyARMLegacyBin/Bin
    /usr/local/slimserver/Cache/InstalledPlugins/Plugins/UPnPBridge/Bin
    ldd (GNU libc) 2.31

    Exasperated!
    ------------------------------------------------------------------------------------

  9. #29
    Member
    Join Date
    Jun 2020
    Location
    UK
    Posts
    65
    Thanks. Thought it was my mistake.

    I'm not clear of what you're intending here Michael.

    Does that mean there's a good chance 32bit windows is now not going to be supported for this plugin in the future?

  10. #30
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,600

    [Announce] Spotty 4.5 - improved Oggdirect, Autoplay, multi-user setup

    > Okay - updated to pcp 7.
    >
    > No go.


    Don't give up: this does work. It's what I'm using myself.

    > /usr/local/slimserver/Cache/InstalledPlugins/Plugins/Spotty/Bin/arm-linux


    Would the file in there not run (in a terminal)?

    > /usr/local/slimserver/Cache/InstalledPlugins/Plugins/SpottyARMLegacyBin/Bin


    Please uninstall this.

    Can you give the remainder of the Settings/Information page?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •