Home of the Squeezebox™ & Transporter® network music players.
Page 21 of 39 FirstFirst ... 11192021222331 ... LastLast
Results 201 to 210 of 387
  1. #201
    Member
    Join Date
    Mar 2019
    Location
    Eindhoven - Netherlands
    Posts
    81
    Quote Originally Posted by mherger View Post
    > Ive changed basic into dynamic in the conf file and then it looks like
    > it is working without distortion.


    v4.5.2 is on its way, with this workaround put in place.
    Hi Michael,

    I've just updated to 4.5.2 but now I get
    21-06-23 09:24:36.1576] Slim::Control::Request::execute (1888) Error: While trying to run function coderef [Slim::Plugin::OPMLBased::__ANON__]: [Can't use string (" 0: 0x7bc200 -
    ") as a HASH ref while "strict refs" in use at /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/Spotty/API/Token.pm line 141.
    ]

    and spotty does not work...
    any ideas?

    sorry, should have just stayed with listening music

  2. #202
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,569

    [Announce] Spotty 4.5 - improved Oggdirect, Autoplay, multi-user setup

    > I've just updated to 4.5.2 but now I get
    > 21-06-23 09:24:36.1576] Slim::Control::Request::execute (1888) Error:
    > While trying to run function coderef
    > [Slim::Plugin::OPMLBased::__ANON__]: [Can't use string (" 0:
    > 0x7bc200 -


    Hmm... that looks oddly like what we fixed in 4.5.1. Is this
    reproducible? Could you please go through the steps we did before to
    figure out whether there was a problem with the spotty helper on your
    system?

    What OS are you using, and which helper (see Settings/Advanced/Spotty)?

  3. #203
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    7,292
    Quote Originally Posted by mherger View Post
    > Ive changed basic into dynamic in the conf file and then it looks like
    > it is working without distortion.


    v4.5.2 is on its way, with this workaround put in place.
    This might be a stupid question but does volume normalisation in Spotty actually reduce the volume to match local tracks which use replaygain? All this talk of dynamic Vs basic has me worried.

    Sent from my Pixel 3a using Tapatalk

  4. #204
    Member
    Join Date
    Mar 2019
    Location
    Eindhoven - Netherlands
    Posts
    81
    Quote Originally Posted by mherger View Post
    > I've just updated to 4.5.2 but now I get
    > 21-06-23 09:24:36.1576] Slim::Control::Request::execute (1888) Error:
    > While trying to run function coderef
    > [Slim::Plugin::OPMLBased::__ANON__]: [Can't use string (" 0:
    > 0x7bc200 -


    Hmm... that looks oddly like what we fixed in 4.5.1. Is this
    reproducible? Could you please go through the steps we did before to
    figure out whether there was a problem with the spotty helper on your
    system?

    What OS are you using, and which helper (see Settings/Advanced/Spotty)?
    Hi Michael

    root@Thuisserver4:/var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/Spotty/Bin/arm-linux# ./spotty-hf -x
    ok spotty v1.0.0 - using librespot 0.2.0 6066a5f (Built on 2021-05-18, Build ID: nD3S1sk3)
    {"autoplay":true,"debug":false,"lms-auth":true,"ogg-direct":true,"podcasts":true,"save-token":true,"version":"1.0.0","volume-normalisation":true,"zeroconf-port":true}
    root@Thuisserver4:/var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/Spotty/Bin/arm-linux#

    root@Thuisserver4:/var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/Spotty/Bin/arm-linux# ./spotty-hf -n Squeezebox -c "/var/lib/squeezeboxserver/cache/spotty/6f5b20a6" --get-token
    Missing credentials
    root@Thuisserver4:/var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/Spotty/Bin/arm-linux#

    it's a pi 4 with dietpi.

    I don't think i find some time till tonight.

    but thanks in advance for looking into it.

    cheers
    Dennis

  5. #205
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    7,292
    Quote Originally Posted by mherger View Post
    > Ive changed basic into dynamic in the conf file and then it looks like
    > it is working without distortion.


    v4.5.2 is on its way, with this workaround put in place.
    After a quick test normalisation seems to work properly for ogg vorbis, FLAC and PCM and it is indeed album gain. From the custom-convert.conf this is still basic normalisation mode which is probably a good thing. I have no idea what the dynamic mode is meant to achieve.

    Sent from my Pixel 3a using Tapatalk

  6. #206
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,569

    [Announce] Spotty 4.5 - improved Oggdirect, Autoplay, multi-user setup

    > root@Thuisserver4:/var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/Spotty/Bin/arm-linux#
    > ./spotty-hf -n Squeezebox -c
    > "/var/lib/squeezeboxserver/cache/spotty/6f5b20a6" --get-token
    > Missing credentials


    Is the above folder (6f5b20a6) yours actually, or something you picked
    up from a comment here? Make sure you point to a folder inside
    cache/spotty on your installation.

  7. #207
    Member
    Join Date
    Mar 2019
    Location
    Eindhoven - Netherlands
    Posts
    81
    Quote Originally Posted by mherger View Post
    Is the above folder (6f5b20a6) yours actually, or something you picked
    up from a comment here? Make sure you point to a folder inside
    cache/spotty on your installation.
    although 6f5b20a6 was in the folder, I picked another one and it gave me this

    root@Thuisserver4:/var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/Spotty/Bin/arm-linux# ./spotty-hf -n Squeezebox -c "/var/lib/squeezeboxserver/cache/spotty/27f3ff16" --get-token
    {"accessToken":"BQAn9v4KbLdlPjDL6xruN54pcuC_BWeS4C mNzTHKAqwwKth8n3c2Z-.....-SLwtjqsIKlsmScT-HO0XIZC7b.........","expiresIn":3600}
    root@Thuisserver4:/var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/Spotty/Bin/arm-linux#
    Last edited by mherger; 2021-06-23 at 05:45.

  8. #208
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,569
    Quote Originally Posted by cortegedusage View Post
    although 6f5b20a6 was in the folder, I picked another one and it gave me this

    root@Thuisserver4:/var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/Spotty/Bin/arm-linux# ./spotty-hf -n Squeezebox -c "/var/lib/squeezeboxserver/cache/spotty/27f3ff16" --get-token
    {"accessToken":"BQAn9v4KbLdlPjDL6xruN54pcuC_BWeS4C mNzTHKAqwwKth8n3c2Z-.....-SLwtjqsIKlsmScT-HO0XIZC7b.........","expiresIn":3600}
    root@Thuisserver4:/var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/Spotty/Bin/arm-linux#
    That's looking good. Is the issue you've reported reproducible? Are you using more than one account?
    Michael

    "It doesn't work - what shall I do?" - "Please check your server.log and/or scanner.log file!"
    (LMS: Settings/Information)

  9. #209
    Junior Member
    Join Date
    Jun 2021
    Posts
    5

    Auto-upgraded to 4.5.2 now spotify won't load

    Hi,

    I'm running LMS on a Pi4 with PiCorePlayer v7.0.0.
    My LMS recently upgraded to Spotty 4.5.2 and now Spotify won't load on my Squeezebox or via the web controller. When I click on Spotty in the list of apps, the browser just sits there waiting.

    After reading through most of this long thread, I think (but really not sure) that the issues have been related to the helper application. Fom my settings, I see that I'm currently running /usr/local/slimserver/Cache/InstalledPlugins/Plugins/Spotty/Bin/arm-linux/spotty-hf (v1.0.0)

    I have tried removing the account and re-adding it. That seems to work fine, so I guess Spotty is able to authenticate successfully.
    Any suggestions on what I could try next to see why it won't load?

    Thanks a lot, was really hoping I'd be able to figure this out from the thread.

  10. #210
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,569

    [Announce] Spotty 4.5 - improved Oggdirect, Autoplay, multi-user setup

    > Any suggestions on what I could try next to see why it won't load?

    Check your server.log. Any errors?
    Check the steps outlined before (running spotty-hf with the --get-token
    params etc.)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •