Home of the Squeezebox™ & Transporter® network music players.
Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 22
  1. #11
    Quote Originally Posted by Redrum View Post
    +1. I could have written this . Exactly my setup and experience. I have two 3b+ pcP LMS only (with USB HDD), and have deployed 2 others to friends.

    I have 4 that I just started paying with, but have found the 3B+ fine for my needs.

    There are several threads where "new to the setup" (myself included) have been walked through by allot of good people and advice. If you like, I'll search and post the threads...

    Jim

    Thanks guys, some links would be very helpful at this point. looks like I am about to dive head-first into the Pi rabbit hole !!

  2. #12
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    4,553
    You could start with the "official" ones ... which would usually be enough.
    If you find that they do not help enough then pointing out where they are not clear enough would help to get them improved.

    https://forums.slimdevices.com/showt...=1#post1025307
    Paul Webster
    http://dabdig.blogspot.com
    Author of "Now Playing" plugins covering Radio France (FIP etc), PlanetRadio (Bauer - Kiss, Absolute, Scala, JazzFM etc), KCRW, Supla Finland, ABC Australia, CBC/Radio-Canada and RTE Ireland

  3. #13
    Senior Member
    Join Date
    Oct 2009
    Location
    Western/Northern New York
    Posts
    547

    Threads from similar installs

    Here is one, specifically the nice summary from @kidstypike (post #19) https://forums.slimdevices.com/showt...aspberry-Pi-4B This will get you from install of pCP as a LMS server, through mounting a drive.

    Here's a loooong thread with some useful info in it https://forums.slimdevices.com/showt...erry-Pi-basics

    But, as Paul said, start with the "official" instructions, but realize that pCP functions, syntax, semantics evolve faster than the documentation, so it is easy for the documentation to be essentially correct, but slightly different than you will actually experience. That's why I like post #19 of the first thread. It's simple, current, and works.

    The other thing to take caution in, especially if you setup Samba, is to make sure your labels/names are exactly correct (including upper/lower case). I remember my first time setting up Samba entering the server and share names, then going to windows to create a network location, creating the path using those names and it not working...repeatedly...until I finally found a lower case letter than needed to be upper.

    You will not regret moving your LMS to a rpi. A little inexpensive box that can remain on always, draws very little power, and is quite nimble. The UI is simple and highly functional, and if you aren't using it already I (and others) recommend using the material skin plugin, it s a great LMS UI

    Jim

  4. #14
    Well thanks for the push guys, I am up an running !!

    Ordered a 4b with 4GB ram on Tuesday. Arrived today !!

    Name:  LMS.JPG
Views: 115
Size:  79.6 KB

  5. #15
    Senior Member
    Join Date
    May 2008
    Location
    United States, Florida
    Posts
    12,449
    Quote Originally Posted by leinster-lad View Post
    Well thanks for the push guys, I am up an running !!

    Ordered a 4b with 4GB ram on Tuesday. Arrived today !!
    notice you're on 8.1.1 from January. in rPi webGUI: LMS tab, select "select branch" and STABLE. Then click on UPDATE LMS. This will take you to a new page and likely it will say "No Update Found".....But below that, click on the "Manual Update Button". It will then download and install the latest 8.1.x LMS. You should then end up with:
    Logitech Media Server Version: 8.1.2 - 1622353561 @ Sun May 30 09:04:30 CEST 2021
    Home: Pi4B-8GB/pCP8.x/4TB>LMS 8.2.x>Transporter, Touch, Boom, Radio (all ethernet)
    Cottage: rPi4B-4GB/pCP8.x/4TB>LMS 8.2.x>Touch>Benchmark DAC I, Boom, Radio w/Battery (Radio WIFI)
    Office: Win10(64)>foobar2000
    The Wild: rPi3B+/pCP7.x/4TB>LMS 8.1.x>hifiberry Dac+Pro (LMS & Squeezelite)
    Controllers: iPhone11 & iPadAir3 (iPeng), CONTROLLER, Material Skin, or SqueezePlay 7.8 on Win10(64)
    Files: Ripping: dBpoweramp > FLAC; Post-rip: mp3tag, PerfectTunes, TuneFusion; Streaming: Spotify

  6. #16
    Thanks for the advice.
    is there a bug in 8.1.1 ?

  7. #17
    Senior Member
    Join Date
    May 2008
    Location
    United States, Florida
    Posts
    12,449
    Quote Originally Posted by leinster-lad View Post
    Thanks for the advice.
    is there a bug in 8.1.1 ?
    No major bug, but there have been a number of fixes for various things since then. And updating is very simple. A couple of mouse clicks and then LMS will restart automatically with the new version. All your settings survive.
    Home: Pi4B-8GB/pCP8.x/4TB>LMS 8.2.x>Transporter, Touch, Boom, Radio (all ethernet)
    Cottage: rPi4B-4GB/pCP8.x/4TB>LMS 8.2.x>Touch>Benchmark DAC I, Boom, Radio w/Battery (Radio WIFI)
    Office: Win10(64)>foobar2000
    The Wild: rPi3B+/pCP7.x/4TB>LMS 8.1.x>hifiberry Dac+Pro (LMS & Squeezelite)
    Controllers: iPhone11 & iPadAir3 (iPeng), CONTROLLER, Material Skin, or SqueezePlay 7.8 on Win10(64)
    Files: Ripping: dBpoweramp > FLAC; Post-rip: mp3tag, PerfectTunes, TuneFusion; Streaming: Spotify

  8. #18
    Thanks Gary

  9. #19
    Member
    Join Date
    Oct 2009
    Location
    Denmark
    Posts
    45

    Third Party Plugins Not Updating

    I have been successfully running picoreplayer/rpi/LMS with a SQB radio for months - until a few days ago when I noticed that I had no third party plugins and therefore no Spotty or BBC Sounds.
    I have reinstalled picoreplayer and LMS on the rpi but with no improvement in the error messages.
    The following extract from the log file shows a heap of problems which unfortunately I have no idea how to fix. Any help gratefully received, thank you.

    [70-01-01 01:00:50.4602] main::init (388) Starting Logitech Media Server (v8.1.1, 1610364019, Thu Jan 14 06:27:45 CET 2021) perl 5.032000 - arm-linux-gnueabihf-thread-multi-64int
    [70-01-01 01:00:51.5245] Slim::Utils::SQLiteHelper:ostConnect (377) Optimizing DB because of missing or empty sqlite_stat1 table
    [70-01-01 01:00:51.6209] Slim::Schema::forceCommit (2171) Warning: Trying to commit transactions before DB is initialized!
    [70-01-01 01:00:51.9365] Slim::Utils::SQLiteHelper:ostConnect (377) Optimizing DB because of missing or empty sqlite_stat1 table
    [70-01-01 01:00:51.9933] Slim::Schema::forceCommit (2171) Warning: Trying to commit transactions before DB is initialized!
    [70-01-01 01:00:53.0140] Slim::Utils::SQLiteHelper:ostConnect (377) Optimizing DB because of missing or empty sqlite_stat1 table
    [70-01-01 01:00:53.0763] Slim::Schema::forceCommit (2171) Warning: Trying to commit transactions before DB is initialized!
    [70-01-01 01:00:53.3950] main::checkDataSource (1108) Warning: Schema updated or no media found in the database, initiating scan.
    [70-01-01 01:00:53.5449] Slim::Networking::Repositories::__ANON__ (147) Failed to fetch https://github.com/LMS-Community/lms...xtensions.xml: Connect timed out:
    [70-01-01 01:00:53.5988] Slim::Formats::XML::gotErrorViaHTTP (339) Error: getting https://www.mysqueezebox.com/api/sounds/v1/opml
    Connect timed out:
    [70-01-01 01:00:53.5992] Slim::Plugin::Sounds::Plugin::_gotSoundsError (82) Error: Unable to cache Sounds & Effects menu from SN: Connect timed out:
    [70-01-01 01:00:56.8914] Slim::Utils::SQLiteHelper:ostConnect (377) Optimizing DB because of missing or empty sqlite_stat1 table
    [70-01-01 01:00:56.9065] Slim::Schema::forceCommit (2171) Warning: Trying to commit transactions before DB is initialized!
    [70-01-01 01:01:08.4898] Slim::Networking::Repositories::__ANON__ (147) Failed to fetch https://github.com/LMS-Community/lms...xtensions.xml: Connect timed out: Bad file descriptor
    [70-01-01 01:01:08.5093] Slim::Formats::XML::gotErrorViaHTTP (339) Error: getting https://www.mysqueezebox.com/api/sounds/v1/opml
    Connect timed out: Bad file descriptor
    [70-01-01 01:01:08.5098] Slim::Plugin::Sounds::Plugin::_gotSoundsError (82) Error: Unable to cache Sounds & Effects menu from SN: Connect timed out: Bad file descriptor
    [70-01-01 01:01:23.0831] Slim::Utils::Update::checkVersionError (185) There was an error while checking for updates to Logitech Media Server:
    Connect timed out:
    [70-01-01 01:01:38.0127] Slim::Utils::Update::checkVersionError (185) There was an error while checking for updates to Logitech Media Server:
    Connect timed out: Bad file descriptor
    [70-01-01 01:02:50.6684] Slim::Networking::SqueezeNetwork::_error (431) Unable to login to SN: Connect timed out:
    [70-01-01 01:03:19.8700] Slim::Networking::SqueezeNetwork::_error (431) Unable to login to SN: Connect timed out:
    [70-01-01 01:03:20.5969] Slim::Networking::SqueezeNetwork::_error (431) Unable to login to SN: Connect timed out: Bad file descriptor
    [70-01-01 01:03:49.7957] Slim::Networking::SqueezeNetwork::_error (431) Unable to login to SN: Connect timed out: Bad file descriptor
    [70-01-01 01:14:34.8809] Slim::Networking::SqueezeNetwork::_error (431) Unable to login to SN: Connect timed out:
    [70-01-01 01:15:04.8082] Slim::Networking::SqueezeNetwork::_error (431) Unable to login to SN: Connect timed out: Bad file descriptor
    [70-01-01 01:16:04.1423] Slim::Networking::SqueezeNetwork::_error (431) Unable to login to SN: Connect timed out:
    [70-01-01 01:16:27.0509] Slim::Networking::SqueezeNetwork::_error (431) Unable to login to SN: Connect timed out:
    [70-01-01 01:16:34.0701] Slim::Networking::SqueezeNetwork::_error (431) Unable to login to SN: Connect timed out: Bad file descriptor
    [70-01-01 01:16:56.9787] Slim::Networking::SqueezeNetwork::_error (431) Unable to login to SN: Connect timed out: Bad file descriptor
    [70-01-01 01:19:49.4520] Slim::Networking::SqueezeNetwork::_error (431) Unable to login to SN: Connect timed out:
    [70-01-01 01:20:19.3796] Slim::Networking::SqueezeNetwork::_error (431) Unable to login to SN: Connect timed out: Bad file descriptor
    [70-01-01 01:20:45.6035] Slim::Networking::SqueezeNetwork::_error (431) Unable to login to SN: Connect timed out:
    [70-01-01 01:21:15.5344] Slim::Networking::SqueezeNetwork::_error (431) Unable to login to SN: Connect timed out: Bad file descriptor
    [70-01-01 01:23:07.4140] Slim::Networking::SqueezeNetwork::_error (431) Unable to login to SN: Connect timed out:
    [70-01-01 01:23:15.3038] Slim::Networking::Repositories::__ANON__ (147) Failed to fetch https://github.com/LMS-Community/lms...xtensions.xml: Connect timed out:
    [70-01-01 01:23:30.2652] Slim::Networking::Repositories::__ANON__ (147) Failed to fetch https://github.com/LMS-Community/lms...xtensions.xml: Connect timed out: Bad file descriptor
    [70-01-01 01:23:37.3405] Slim::Networking::SqueezeNetwork::_error (431) Unable to login to SN: Connect timed out: Bad file descriptor

  10. #20
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,590

    Plugins not updating

    > [70-01-01 01:00:50.4602] main::init (388) Starting Logitech Media Server
    > (v8.1.1, 1610364019, Thu Jan 14 06:27:45 CET 2021) perl 5.032000 -


    Your time is wrong. Therefore SSL connections fail. Try a LMS restart,
    or pCP reboot.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •