Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 5 of 5
  1. #1
    Junior Member
    Join Date
    Aug 2008
    Posts
    21

    slimserver-vendor and perl 5.34

    Anyone here been able to build the required libs for perl 5.34? No clue what small furry animals I need to sacrifice to what deity. There is nothing I have tried which will render a functional SQLite.so

    Can't load '/opt/logitechmediaserver/CPAN/arch/5.34/auto/DBD/SQLite/SQLite.so' for module DBD::SQLite: /opt/logitechmediaserver/CPAN/arch/5.34/auto/DBD/SQLite/SQLite.so: undefined symbol: _ZTVN10__cxxabiv117__class_type_infoE at /usr/lib64/perl5/5.34/x86_64-linux-thread-multi/DynaLoader.pm line 193.

    I have a hunch said lib should be built with g++ and linked with stdc++. But no idea how to accomplish that. Yes, I have tried meddling with environment variables and buildme.sh. Platform is linux on x86_64. glibc/gcc.

    $ ldd /opt/logitechmediaserver/CPAN/arch/5.34/auto/DBD/SQLite/SQLite.so
    linux-vdso.so.1 (0x00007ffcf8768000)
    libgcc_s.so.1 => /usr/lib/gcc/x86_64-pc-linux-gnu/11.1.0/libgcc_s.so.1 (0x00007f5b4f568000)
    libc.so.6 => /lib64/libc.so.6 (0x00007f5b4f3ad000)
    /lib64/ld-linux-x86-64.so.2 (0x00007f5b4f848000)

    Thanks,

    Dag B

  2. #2
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,569

    slimserver-vendor and perl 5.34

    > Anyone here been able to build the required libs for perl 5.34? No clue
    > what small furry animals I need to sacrifice to what deity. There is
    > nothing I have tried which will render a functional SQLite.so


    Are you using the script from
    https://github.com/Logitech/slimserv...blic/8.0/CPAN? What
    Linux are you using?

  3. #3
    Junior Member
    Join Date
    Aug 2008
    Posts
    21
    Quote Originally Posted by mherger View Post
    > Anyone here been able to build the required libs for perl 5.34? No clue
    > what small furry animals I need to sacrifice to what deity. There is
    > nothing I have tried which will render a functional SQLite.so


    Are you using the script from
    https://github.com/Logitech/slimserv...blic/8.0/CPAN?
    Yes.

    What Linux are you using?
    Gentoo is my poison of choice. :-)

    I have been able to fix this exact problem before. But whatever I did to fix/work around it, I cannot recall.

  4. #4
    Junior Member
    Join Date
    Aug 2008
    Posts
    21

    workaround

    Quote Originally Posted by dagb View Post
    Yes.

    Gentoo is my poison of choice. :-)

    I have been able to fix this exact problem before. But whatever I did to fix/work around it, I cannot recall.

    I took the opportunity to finally move slimserver off of my workstation and onto a dedicated debian 10 VM. The latest available deb did not work out of the box. But straight from git works, yay.
    One of these days I may even consider a proper startup-script. Maybe.

    Thank you again for keeping the lights on, all.

    Dag B

  5. #5
    Senior Member
    Join Date
    Dec 2020
    Posts
    135
    Try `bubba` overlay (layman). It contains an ebuild for LMS 8.0 and required CPAN modules not available in the regular portage tree. As this build follows the Gentoo method it will keep in sync with world updates (may require running with `--bdeps=y` or run `perl-cleaner --all` afterwards).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •