I'd posted about this a while back, but thought I'd try again as I've not found a solution several months later.

I'm using LMS utlizing Spicefly SugarCube to push tracks to Foobar2k via foo_upnp in order to use the wonderful Sqrsoft crossfader. This setup only works using FLAC files; any other format will cause the crossfader not to work, but with stereo FLAC files it's generally flawless playback, and will play for hours, until it crashes.

When it fails, just as a track ends and the crossfader goes to begin the next track, I get a playback error in Foobar2k, usually citing network error, and not only does playback stop, but Foobar crashes. In the LMS UPnP bridge log, I see:

[17:47:32.084] sendSTAT:169 [0050FD10]: STAT:[STMs] msplayed 0
[17:50:27.945] output_http_thread:289 [0050FD10]: draining (21069824 bytes)
[17:50:27.945] sendSTAT:169 [0050FD10]: STAT:[STMd] msplayed 175000
[17:50:28.058] process_strm:238 [0050FD10] strm command s
[17:50:28.058] process_strm:307 [0050FD10], strm s autostart: 1 transition period: 10 transition type: 0 codec: f
[17:50:28.058] sendSTAT:169 [0050FD10]: STAT:[STMf] msplayed 175000
[17:50:28.064] bind_socket:397 cannot bind socket 1680
[17:50:28.064] bind_socket:397 cannot bind socket 1680
[17:50:28.064] bind_socket:397 cannot bind socket 1680
[17:50:28.064] bind_socket:397 cannot bind socket 1680
[17:50:28.064] output_start:81 [0050FD10]: start thread 1
[17:50:28.064] sq_callback:340 [004C30F0]:
artist:George Jones & Tammy Wynette
album:The President and the First Lady
title:We'll Talk About It Later
genre:Country
duration:146.332
size:0
cover:http://XXX.XXX.X.XX:9000/music/55e256ff/cover_.jpg
offset:1
[17:50:28.064] sq_callback:373 [004C30F0]: next URI gapless http://XXX.XXX.X.XX:49160/bridge-92.flac
[17:50:28.064] AVTSetNextURI:111 [004C30F0]: uPNP setNextURI http://XXX.XXX.X.XX:49160/bridge-92.flac (cookie 000067B9)
[17:50:28.065] process_start:1199 [0050FD10]: codec:c, ch:0, s:0, r:0
[17:50:28.075] sendSTAT:169 [0050FD10]: STAT:[STMc] msplayed 175000
[17:50:33.699] read_line:589 fd: 1432 read error: 10054 Unknown error

[17:50:33.699] http_parse:513 cannot read method
[17:50:33.699] handle_http:462 [0050FD10]: http parsing error (null)
[17:50:33.699] output_http_thread:192 [0050FD10]: HTTP close 1432 (bytes 21586206) (n:2 res:0)
[17:51:05.633] output_http_thread:140 [0050FD10]: got HTTP connection 1432
[17:51:05.633] output_http_thread:169 [0050FD10]: drain is 2621440 (waited 37565)
[17:51:05.633] handle_http:467 [0050FD10]: received GET /bridge-92.flac HTTP/1.1
[17:51:05.633] handle_http:470 [0050FD10]: HTTP headers
Host: XXX.XXX.X.XX:49160
Connection: close
User-Agent: foobar2000/1.6.6
Accept: */*
Icy-MetaData: 1

I've removed the IP addresses just in case posting an them violates anything here, even if it's internal. But it's actual numbers in the real log.

So I'm not entirely clear WHERE the problem is happening - does this suggest that the bridge here is working correctly and there's a connection issue with foo_upnp, or is this possibly just a general network error? If this doesn't provide enough info, what do I need to be looking at? The error message in Foobar2k always cites the IP address of the NEXT track as being unavailable, but if I copy and paste that into a browser within the correct time frame the track is there. Thanks in advance!