Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 5 of 5
  1. #1

    Cheapish replacement for UK SBT Power Supply to prevent noise

    I've been looking at some of the historical threads about power supplies, but thought I'd start yet another post on the topic to see what the latest recommendations are.

    I recently picked up a secondhand Squeezebox Touch, but think I might need to switch out the power supply to something better. When I plug my Sony WH-1000XM3 headphones into the headphone port (and I've also tried via the RCA-out using a 3.5mm adapter) I get a very noticeable background hum through the headphones when noise cancelling is enabled. The hum disappears when I turn ANC off though. I've tested the headphones wired to a few other devices - a laptop (plugged in) and a phone (plugged in) and don't get the problem, so it seems to only happen with my Squeezebox Touch, and only when ANC is enabled.

    Having read several threads about the poor quality of the original power adapter, I'm assuming that the problem is likely due to this?

    Due to the other threads being quite old now, can anybody recommend a decent replacement UK PSU that won't break the bank? I've seen the iFi iPower mentioned elsewhere, but it's ú50... which is almost as much as I paid for my Touch... so is there anything cheaper that might resolve the apparent electrical noise I'm experiencing?

    Edit: a friend suggested I try connecting via ethernet instead to see if wi-fi interference was the cause. The problem remained though. Interestingly if I touch any of the metal connectors on the rear (the coaxial or RCA sockets) then the humming stops, which does suggest it's electrical.

    Thanks for any advice!
    Last edited by FatPete; 2021-06-04 at 14:04.

  2. #2
    Senior Member Apesbrain's Avatar
    Join Date
    Jun 2005
    Location
    East Coast, USA
    Posts
    1,754
    Quote Originally Posted by FatPete View Post
    Having read several threads about the poor quality of the original power adapter, I'm assuming that the problem is likely due to this?
    Not likely. Have you tried another non-ANC headphone?

  3. #3
    Quote Originally Posted by Apesbrain View Post
    Not likely. Have you tried another non-ANC headphone?
    Yes, I also tried an old pair of iPhone earphones (for the ultimate in music quality!) but there wasn't any background hum with those.

    Interestingly my ANC headphones don't get interference when in 'passthrough' mode (i.e. the microphones are active, and pipe the sounds through to the earpieces). It's only when in full-on ANC mode.

  4. #4
    Senior Member Apesbrain's Avatar
    Join Date
    Jun 2005
    Location
    East Coast, USA
    Posts
    1,754
    Do you have the option to connect the Touch analog outputs to an appropriate device (amp/receiver) to see if the noise goes away as it did when you touched the rear panel jacks?

  5. #5
    Quote Originally Posted by Apesbrain View Post
    Do you have the option to connect the Touch analog outputs to an appropriate device (amp/receiver) to see if the noise goes away as it did when you touched the rear panel jacks?
    Unfortunately not at the moment - I've been out of work for a while now so have had to sell all my audio equipment, which is why I'm having to listen to everything via the Touch or my phone with headphones. I'm trying to think of any local friends who still have 'proper' audio gear for me to test it with but everybody I know just seems to be using smart speakers nowadays.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •