Home of the Squeezebox™ & Transporter® network music players.
Page 6 of 8 FirstFirst ... 45678 LastLast
Results 51 to 60 of 78
  1. #51
    Senior Member
    Join Date
    Jan 2012
    Posts
    117
    Quote Originally Posted by Paul Webster View Post
    I suspect that mherger can only see the public IP address, not your local 192.x.y.2/192.1x.y.4 (or whatever).
    The UserAgent field probably provides some system info so maybe he can see that it is coming from Docker.

    Can you get command line session into that Docker image and then try a wget on the same destination?
    Thanks for the suggestion Paul. Not familiar with the wget command line. What exactly would I need to type?
    • Synology D218+ running LMS 8.1.1 in Docker container
    • 1 x Squeezebox Touch, 2 x Squeezebox Radios, 1 x Squeezebox Receiver, Squeeze Player & Squeeze Ctrl apps on Galaxy Tab S5e & Galaxy A40
    • Raspberry Pi 4B 8GB (with 7" Touchscreen in case & Flirc USB IR dongle) & Pi 4B 8GB in Flirc case, both running piCorePlayer 8.0.0 & LMS 8.1.1, connecting over Wi-fi to DS218+, or LMS library copy on 2TB USB hard drive plugged into Pi when no Wi-fi available
    • LMS library of ALAC, ACC/M4A and MP3 files

  2. #52
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    4,914
    As simple as
    Code:
    wget https://www.mysqueezebox.com
    Paul Webster
    Author of "Now Playing" plugins covering Radio France (FIP etc), PlanetRadio (Bauer - Kiss, Absolute, Scala, JazzFM etc), KCRW, ABC Australia and CBC/Radio-Canada
    and, via the extra "Radio Now Playing" plugin, AllZIC Radio, Caroline Flashback, Cesky rozhlas, Dandelion Radio, Europa Radio Jazz, Frequence3, FSK, JukeRadio, KlassikRadio.de, Linn Radio, Mother Earth, Naim Radio, Nova.fr, RadioBlues Flac, Radio Espace, Radio Swiss, RTE Ireland, Somehow Jazz, Supla Finland

  3. #53
    Senior Member
    Join Date
    Jan 2012
    Posts
    117
    Quote Originally Posted by Paul Webster View Post
    I suspect that mherger can only see the public IP address, not your local 192.x.y.2/192.1x.y.4 (or whatever).
    The UserAgent field probably provides some system info so maybe he can see that it is coming from Docker.

    Can you get command line session into that Docker image and then try a wget on the same destination?
    Not 100% sure what I needed to do here, but in my Docker container on the Synology, there is a 'Terminal' tab for my LMS. First typed it like this - nothing happened:
    Name:  2021-06-10 LMS 8.1 Docker Terminal wget.JPG
Views: 73
Size:  19.8 KB

    Then tried it using the 'Open with command option' and get this:
    Name:  2021-06-10 LMS 8.1 Docker Terminal open with command wget.JPG
Views: 71
Size:  62.5 KB

    No new information in the LMS log, but the container log shows this:
    Name:  2012-06-10 LMS 8.1 Docker log.JPG
Views: 71
Size:  19.5 KB

    Not sure what most of this means - does it provide anymore info?

    Thanks

    Andy
    • Synology D218+ running LMS 8.1.1 in Docker container
    • 1 x Squeezebox Touch, 2 x Squeezebox Radios, 1 x Squeezebox Receiver, Squeeze Player & Squeeze Ctrl apps on Galaxy Tab S5e & Galaxy A40
    • Raspberry Pi 4B 8GB (with 7" Touchscreen in case & Flirc USB IR dongle) & Pi 4B 8GB in Flirc case, both running piCorePlayer 8.0.0 & LMS 8.1.1, connecting over Wi-fi to DS218+, or LMS library copy on 2TB USB hard drive plugged into Pi when no Wi-fi available
    • LMS library of ALAC, ACC/M4A and MP3 files

  4. #54
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    4,914
    Looks like it worked - it was able to fetch index.html
    So that seems to show that the underlying networking from your Docker to mysqueezebox.com is working.
    So it sort of helps a bit.
    It it had failed in the same was as LMS then it would have meant that we could have probably determined that there is a fundamental issue with the underlying networking.

    You could try it periodically (and delete the various index.html.* files that it is creating) to see if it sometimes fails - but given that mherger saw a successful login from LMS on your only Docker instance then it looks like an intermittent issue which could be difficult to track down.
    Paul Webster
    Author of "Now Playing" plugins covering Radio France (FIP etc), PlanetRadio (Bauer - Kiss, Absolute, Scala, JazzFM etc), KCRW, ABC Australia and CBC/Radio-Canada
    and, via the extra "Radio Now Playing" plugin, AllZIC Radio, Caroline Flashback, Cesky rozhlas, Dandelion Radio, Europa Radio Jazz, Frequence3, FSK, JukeRadio, KlassikRadio.de, Linn Radio, Mother Earth, Naim Radio, Nova.fr, RadioBlues Flac, Radio Espace, Radio Swiss, RTE Ireland, Somehow Jazz, Supla Finland

  5. #55
    Senior Member
    Join Date
    Jan 2012
    Posts
    117
    Quote Originally Posted by Paul Webster View Post
    Looks like it worked - it was able to fetch index.html
    So that seems to show that the underlying networking from your Docker to mysqueezebox.com is working.
    So it sort of helps a bit.
    It it had failed in the same was as LMS then it would have meant that we could have probably determined that there is a fundamental issue with the underlying networking.

    You could try it periodically (and delete the various index.html.* files that it is creating) to see if it sometimes fails - but given that mherger saw a successful login from LMS on your only Docker instance then it looks like an intermittent issue which could be difficult to track down.
    Any idea where those index.html files are saved, Paul?

    The trouble for me is it's not intermittent, I've never been able to get those Home > Radio menu shortcuts to appear at all in 8.1, which I'm told is because the LMS isn't logged into mysqueezebox, and consistently get the errors I see in the LMS log every time I clear and re-enter my password:

    [21-06-09 22:02:06.7883] Slim::Networking::SqueezeNetwork::_error (431) Unable to login to SN: Timed out waiting for data
    [21-06-09 22:02:06.7899] Slim::Networking::SqueezeNetwork::_init_error (156) Unable to login to mysqueezebox.com, sync is disabled: Timed out waiting for data (https://www.mysqueezebox.com)
    [21-06-09 22:02:06.7908] Slim::Networking::SqueezeNetwork::_init_error (172) mysqueezebox.com sync init failed: Timed out waiting for data, will retry in 300 (https://www.mysqueezebox.com)
    [21-06-09 22:02:36.0698] Slim::Networking::SqueezeNetwork::_error (431) Unable to login to SN: Timed out waiting for data


    Why does mysqueezebox show I've sucessfully logged in, when my LMS shows errors and hasn't? A few thoughts/questions to help me find a solution:

    1. Do we have any clearer definitions of these three errors (431, 156, 172) that would help me identify why mysqueezebox.com is logging me in, but my Docker LMS 8.1 installation doesn't seem to receive an acknowledgement or data from that sucessful login at my end?
    2. What does "sync is disabled" mean in error 156 and can I fix that in LMS, Docker or Synology?
    3. Are there other settings in LMS I can look for that may have missed relating to mysqueezebox that are stopping LMS getting logged in?
    4. Are there other suggestions for what could be causing this in the Synology/Docker environments (ports, firewalls, settings)?
    5. My plugins show mysqueezebox.com services handler (v1.0 - same as I have in 7.9) - have we confirmed that mysqueezebox.com login works properly in 8.1?
    6. Anyone else on this forum have a similar Synology/Docker/LMS 8.1 setup to me that can get logged into mysqueezebox and see their Radio menu options who could advise on their setup?


    Really hoping for a solution to this, as it's the only remaining issue stopping me from permanently migrating from 7.9 to 8.1 - and not having to resort to a Raspberry Pi setup.

    Thanks again

    Andy
    • Synology D218+ running LMS 8.1.1 in Docker container
    • 1 x Squeezebox Touch, 2 x Squeezebox Radios, 1 x Squeezebox Receiver, Squeeze Player & Squeeze Ctrl apps on Galaxy Tab S5e & Galaxy A40
    • Raspberry Pi 4B 8GB (with 7" Touchscreen in case & Flirc USB IR dongle) & Pi 4B 8GB in Flirc case, both running piCorePlayer 8.0.0 & LMS 8.1.1, connecting over Wi-fi to DS218+, or LMS library copy on 2TB USB hard drive plugged into Pi when no Wi-fi available
    • LMS library of ALAC, ACC/M4A and MP3 files

  6. #56
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    20,856
    Since wget worked - you should check that LMS has access to up to date SSL modules.

    What version of IO::Socket::SSL shows in WebUI Settings/Information

    From a shell prompt inside Docker (like wget) check that openssl version is about 1.1.* - use "openssl version" command.

  7. #57
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,623

    Cant connect to mysqueezebox.com"unexpect error - check your networking"

    > [21-06-09 22:02:06.7883] Slim::Networking::SqueezeNetwork::_error (431)
    > Unable to login to SN: Timed out waiting for data
    > [21-06-09 22:02:06.7899] Slim::Networking::SqueezeNetwork::_init_error
    > (156) Unable to login to mysqueezebox.com, sync is disabled: Timed out
    > waiting for data (https://www.mysqueezebox.com)
    > [21-06-09 22:02:06.7908] Slim::Networking::SqueezeNetwork::_init_error
    > (172) mysqueezebox.com sync init failed: Timed out waiting for data,
    > will retry in 300 (https://www.mysqueezebox.com)


    But would you see the same message thereafter? That's the initial
    attempt. Maybe the container's networking isn't fully ready yet. That's
    why LMS would try again a few minutes later. If those messages don't
    continue, and only show up right after startup, then you should be fine.
    Just be a little patient. It might take a few minutes before the menus
    show up. But as I've shown your LMS has signed in to mysb several times
    in the past 24h. And I only checked one out of four or more hosts.

    If you let it sit there, don't access the web UI for an hour, and then
    still don't get any Radio menu (please try some other interface than the
    default web skin, too), then there might something else be wrong. But
    there are so many successful signins from Docker instances today, I
    doubt there's a problem with the image itself.

  8. #58
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    4,914
    Should work fine in 8.1 and with that Docker image - if not there would be a lot more complaints.

    Set loggin (Settings/Advanced/Logging/network.squeezenetwork) to Debug (click apply)
    and then check the logs to see what is going on.

    I just put in a bad password and then the good one to see what the logs show ... so compare yours with:
    Code:
    [21-06-10 15:55:05.5214] Slim::Networking::SqueezeNetwork::PrefSync::shutdown (151) SqueezeNetwork pref sync shutdown
    [21-06-10 15:55:05.5259] Slim::Networking::SqueezeNetwork::login (271) Logging in to www.mysqueezebox.com as paul@dabdig.com
    [21-06-10 15:55:05.7199] Slim::Networking::SqueezeNetwork::_error (431) Unable to login to SN: Invalid mysqueezebox.com username or password.
    [21-06-10 15:55:05.7823] Slim::Networking::SqueezeNetwork::PrefSync::_init_done (57) Got list of SN prefs to sync: 55 prefs
    [21-06-10 15:55:05.7877] Slim::Networking::SqueezeNetwork::PrefSync::syncDownGlobal (200) Requesting global sync down from SN: { since => "1623336502" }
    [21-06-10 15:55:05.7886] Slim::Networking::SqueezeNetwork::_createHTTPRequest (369) Logging in to SqueezeNetwork to obtain session ID
    [21-06-10 15:55:05.7892] Slim::Networking::SqueezeNetwork::login (271) Logging in to www.mysqueezebox.com as someone@example.com
    [21-06-10 15:55:07.0035] Slim::Networking::SqueezeNetwork::_createHTTPRequest (369) Logging in to SqueezeNetwork to obtain session ID
    [21-06-10 15:55:07.0043] Slim::Networking::SqueezeNetwork::login (248) We've failed to log in a few moments ago, or are still waiting for a response. Let's not try again just yet, we don't want to hammer mysqueezebox.com.
    [21-06-10 15:55:07.0056] Slim::Networking::SqueezeNetwork::PrefSync::_syncDown_error (361) Sync Down failed: An unexpected error occurred while validating your mysqueezebox.com account. Please make sure network connectivity is working fine., will retry in 14495184
    [21-06-10 15:55:08.0105] Slim::Networking::SqueezeNetwork::_createHTTPRequest (369) Logging in to SqueezeNetwork to obtain session ID
    [21-06-10 15:55:08.0114] Slim::Networking::SqueezeNetwork::login (248) We've failed to log in a few moments ago, or are still waiting for a response. Let's not try again just yet, we don't want to hammer mysqueezebox.com.
    [21-06-10 15:55:08.0129] Slim::Networking::SqueezeNetwork::PrefSync::_syncDown_error (361) Sync Down failed: An unexpected error occurred while validating your mysqueezebox.com account. Please make sure network connectivity is working fine., will retry in 8587105    <<<<< huge number there ....
    [21-06-10 15:55:09.0047] Slim::Networking::SqueezeNetwork::_createHTTPRequest (369) Logging in to SqueezeNetwork to obtain session ID
    [21-06-10 15:55:09.0058] Slim::Networking::SqueezeNetwork::login (248) We've failed to log in a few moments ago, or are still waiting for a response. Let's not try again just yet, we don't want to hammer mysqueezebox.com.
    [21-06-10 15:55:09.0080] Slim::Networking::SqueezeNetwork::PrefSync::_syncDown_error (361) Sync Down failed: An unexpected error occurred while validating your mysqueezebox.com account. Please make sure network connectivity is working fine., will retry in 604800
    [21-06-10 15:55:12.0181] Slim::Networking::SqueezeNetwork::_createHTTPRequest (369) Logging in to SqueezeNetwork to obtain session ID
    [21-06-10 15:55:12.0188] Slim::Networking::SqueezeNetwork::login (248) We've failed to log in a few moments ago, or are still waiting for a response. Let's not try again just yet, we don't want to hammer mysqueezebox.com.
    [21-06-10 15:55:12.0200] Slim::Networking::SqueezeNetwork::PrefSync::_syncDown_error (361) Sync Down failed: An unexpected error occurred while validating your mysqueezebox.com account. Please make sure network connectivity is working fine., will retry in 10492051
    [21-06-10 15:55:35.0152] Slim::Networking::SqueezeNetwork::_createHTTPRequest (369) Logging in to SqueezeNetwork to obtain session ID
    [21-06-10 15:55:35.0161] Slim::Networking::SqueezeNetwork::login (271) Logging in to www.mysqueezebox.com as someone@example.com
    [21-06-10 15:55:35.9518] Slim::Networking::SqueezeNetwork::_error (431) Unable to login to SN: Timed out waiting for data
    [21-06-10 15:55:35.9528] Slim::Networking::SqueezeNetwork::PrefSync::_syncDown_error (370) Global Sync Down failed: Timed out waiting for data
    [21-06-10 15:55:39.4017] Slim::Networking::SqueezeNetwork::PrefSync::shutdown (151) SqueezeNetwork pref sync shutdown
    [21-06-10 15:55:39.4027] Slim::Networking::SqueezeNetwork::_createHTTPRequest (369) Logging in to SqueezeNetwork to obtain session ID
    [21-06-10 15:55:39.4035] Slim::Networking::SqueezeNetwork::login (271) Logging in to www.mysqueezebox.com as someone@example.com
    Paul Webster
    Author of "Now Playing" plugins covering Radio France (FIP etc), PlanetRadio (Bauer - Kiss, Absolute, Scala, JazzFM etc), KCRW, ABC Australia and CBC/Radio-Canada
    and, via the extra "Radio Now Playing" plugin, AllZIC Radio, Caroline Flashback, Cesky rozhlas, Dandelion Radio, Europa Radio Jazz, Frequence3, FSK, JukeRadio, KlassikRadio.de, Linn Radio, Mother Earth, Naim Radio, Nova.fr, RadioBlues Flac, Radio Espace, Radio Swiss, RTE Ireland, Somehow Jazz, Supla Finland

  9. #59
    Senior Member
    Join Date
    Jan 2012
    Posts
    117
    Quote Originally Posted by bpa View Post
    Since wget worked - you should check that LMS has access to up to date SSL modules.

    What version of IO::Socket::SSL shows in WebUI Settings/Information

    From a shell prompt inside Docker (like wget) check that openssl version is about 1.1.* - use "openssl version" command.
    Here's my LMS 8.1 settings - looks like IO::Socket::SSL is 2.044:
    Name:  2021-05-26 LMS 8.1 Clear and rescan without text index.JPG
Views: 66
Size:  165.0 KB

    And openssl shows as version 1.1.0:
    Name:  2021-06-10 Open SSL version.JPG
Views: 65
Size:  16.8 KB

    How's that all look - and what's next steps for error diagnosis?

    Thanks
    • Synology D218+ running LMS 8.1.1 in Docker container
    • 1 x Squeezebox Touch, 2 x Squeezebox Radios, 1 x Squeezebox Receiver, Squeeze Player & Squeeze Ctrl apps on Galaxy Tab S5e & Galaxy A40
    • Raspberry Pi 4B 8GB (with 7" Touchscreen in case & Flirc USB IR dongle) & Pi 4B 8GB in Flirc case, both running piCorePlayer 8.0.0 & LMS 8.1.1, connecting over Wi-fi to DS218+, or LMS library copy on 2TB USB hard drive plugged into Pi when no Wi-fi available
    • LMS library of ALAC, ACC/M4A and MP3 files

  10. #60
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,623

    Cant connect to mysqueezebox.com"unexpect error - check your networking"

    > Here's my LMS 8.1 settings - looks like IO::Socket::SSL is 2.044:

    It's not an SSL issue. As I said your instance did successfully sign in
    (as do many others running the same image). I believe it's only some
    timing issue. Give it some time before checking the web UI.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •