Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 8 of 8
  1. #1
    Junior Member
    Join Date
    Jun 2021
    Posts
    5

    Spotty Connecting Issue

    Hi there I am trying to setup spotty for my workplace using the squeeze box touch.

    I have spotty installed and am using LMS 7.9.0. When playing a song through spotify it connects and shows the track playing, the trouble is I don't get an audio source.

    When checking the squeezebox touch there is just a "connecting" displayed that will flicker in and out.

    The radio audio works it just is an issue when using spotty.

    Anyone have a potential fix?

  2. #2
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,569

    Spotty Connecting Issue

    > I have spotty installed and am using LMS 7.9.0. When playing a song
    > through spotify it connects and shows the track playing, the trouble is
    > I don't get an audio source.


    But you've been able to authenticate and can browse content? Do you have
    a Premium subscription? Is there anything about Spotty in the server.log
    file (see Settings/Information)?

  3. #3
    Junior Member
    Join Date
    Jun 2021
    Posts
    5
    Quote Originally Posted by mherger View Post
    > I have spotty installed and am using LMS 7.9.0. When playing a song
    > through spotify it connects and shows the track playing, the trouble is
    > I don't get an audio source.


    But you've been able to authenticate and can browse content? Do you have
    a Premium subscription? Is there anything about Spotty in the server.log
    file (see Settings/Information)?


    I have been able to authenticate and do have a premium subscription. I can browse content both on the Squeezebox and the LMS, I will have to check the server log

  4. #4
    Junior Member
    Join Date
    Jun 2021
    Posts
    5
    Quote Originally Posted by mherger View Post
    > I have spotty installed and am using LMS 7.9.0. When playing a song
    > through spotify it connects and shows the track playing, the trouble is
    > I don't get an audio source.


    But you've been able to authenticate and can browse content? Do you have
    a Premium subscription? Is there anything about Spotty in the server.log
    file (see Settings/Information)?
    Here is the server log

    Slim::Networking::IO::Select::__ANON__ (131) Error: Select task failed calling Slim::Networking::Async::HTTP::_http_read_body: illegal file descriptor or filehandle (either no attached file descriptor or illegal value): at /<C:\PROGRA~2\SQUEEZ~1\server\SQUEEZ~3.EXE>Slim/Networking/IO/Select.pm line 134.
    ; fh=Slim::Networking::Async::Socket::HTTPS=GLOB(0xb 9e8bdc)

  5. #5
    Junior Member
    Join Date
    Jun 2021
    Posts
    5
    Quote Originally Posted by mherger View Post
    > I have spotty installed and am using LMS 7.9.0. When playing a song
    > through spotify it connects and shows the track playing, the trouble is
    > I don't get an audio source.


    But you've been able to authenticate and can browse content? Do you have
    a Premium subscription? Is there anything about Spotty in the server.log
    file (see Settings/Information)?
    [21-06-03 16:31:47.5370] Slim::Networking::SqueezeNetwork::_error (565) Unable to login to SN: Timed out waiting for data
    [21-06-03 16:31:47.5388] Slim::Web::JSONRPC::requestWrite (472) Context not found in requestWrite!!!!
    [21-06-03 16:32:34.3486] Slim::Networking::SqueezeNetwork::_error (565) Unable to login to SN: Timed out waiting for data
    [21-06-03 16:32:34.3496] Slim::Web::JSONRPC::requestWrite (472) Context not found in requestWrite!!!!
    [21-06-03 16:32:40.8346] Slim::Networking::SqueezeNetwork::_error (565) Unable to login to SN: Timed out waiting for data
    [21-06-03 16:32:40.8355] Slim::Web::JSONRPC::requestWrite (472) Context not found in requestWrite!!!!
    [21-06-03 16:45:32.8023] Plugins::Spotty::API::__ANON__ (1410) Invalid data

  6. #6
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,569

    Spotty Connecting Issue

    > [21-06-03 16:45:32.8023] Plugins::Spotty::API::__ANON__ (1410) Invalid
    > data


    You seem to have quite a few networking related issues. Also: 7.9.0 is
    outdated. It lacks support for more recent HTTPS encryption methods on
    Windows. Please update to the latest 8.1 and try again.

    If that doesn't help, then please enable logging for plugin.spotty
    (Settings/Advanced/Logging). Try to play again, then send me your full
    server.log.zip to https://www.dropbox.com/request/T3RctyzGgNg0oFDubq6a

  7. #7
    Junior Member
    Join Date
    Jun 2021
    Posts
    5
    Quote Originally Posted by mherger View Post
    > [21-06-03 16:45:32.8023] Plugins::Spotty::API::__ANON__ (1410) Invalid
    > data


    You seem to have quite a few networking related issues. Also: 7.9.0 is
    outdated. It lacks support for more recent HTTPS encryption methods on
    Windows. Please update to the latest 8.1 and try again.

    If that doesn't help, then please enable logging for plugin.spotty
    (Settings/Advanced/Logging). Try to play again, then send me your full
    server.log.zip to https://www.dropbox.com/request/T3RctyzGgNg0oFDubq6a
    I have sent you the full server log, I also updated to 8.1.1 with no success, let me know what I should try next

  8. #8
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,569

    Spotty Connecting Issue

    > I have sent you the full server log, I also updated to 8.1.1 with no
    > success, let me know what I should try next


    I see a lot of successful requests to Spotify, and no "invalid data"
    response. Am I looking at the wrong file? Can you run your tests with
    logging enabled once again, then send me the file once you've received
    that "invalid data" message again. And please tell me when (time) this
    happened, and what you did. This should allow me to find the
    corresponding response in the log file.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •