Home of the Squeezebox™ & Transporter® network music players.
Page 2 of 5 FirstFirst 1234 ... LastLast
Results 11 to 20 of 45
  1. #11
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    7,624
    Quote Originally Posted by slartibartfast View Post
    In my case it was using the pause button in Material skin.

    Sent from my Pixel 3a using Tapatalk
    Well, URL is from soundcloud and is volatile... hmmm, that might be a tough one
    LMS 8.2 on Odroid-C4 - SqueezeAMP!, 5xRadio, 5xBoom, 2xDuet, 1xTouch, 1xSB3. Sonos PLAY:3, PLAY:5, Marantz NR1603, Foobar2000, ShairPortW, 2xChromecast Audio, Chromecast v1 and v2, Squeezelite on Pi, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5, RivaArena 1 & 3

  2. #12
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    7,976
    Quote Originally Posted by philippe_44 View Post
    Well, URL is from soundcloud and is volatile... hmmm, that might be a tough one
    Did you try playing that podcast yourself?

    Sent from my Pixel 3a using Tapatalk

  3. #13
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    7,624
    Quote Originally Posted by slartibartfast View Post
    Did you try playing that podcast yourself?

    Sent from my Pixel 3a using Tapatalk
    Yes I did - what happens is that the URL is redirected and when you pause, LMS closes the connection (depending on player's buffer fullness, but that's details...). When it re-opens, it re-opens from the redirected URL which was volatile.
    LMS 8.2 on Odroid-C4 - SqueezeAMP!, 5xRadio, 5xBoom, 2xDuet, 1xTouch, 1xSB3. Sonos PLAY:3, PLAY:5, Marantz NR1603, Foobar2000, ShairPortW, 2xChromecast Audio, Chromecast v1 and v2, Squeezelite on Pi, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5, RivaArena 1 & 3

  4. #14
    Senior Member dolodobendan's Avatar
    Join Date
    Dec 2017
    Location
    Braunschweig, Germany
    Posts
    1,446
    Quote Originally Posted by slartibartfast View Post
    I just tried your podcast and see the same. Before I press play to restart it shows the correct elapsed time but when I press play the elapsed time changes to 00:00 and playback does not restart. Other podcasts do not have the same issue though.
    Thank you for confirming this!

    Quote Originally Posted by philippe_44 View Post
    How do you pause/resume?
    Like slartibartfast, I use Material's pause button.
    QLMS 8.3@2.21 x64 (digimaster) / QNAP 469L QTS 4.3.4
    LMS 8.3 x64 / Intel NUC8 i3

  5. #15
    Senior Member dolodobendan's Avatar
    Join Date
    Dec 2017
    Location
    Braunschweig, Germany
    Posts
    1,446
    Quote Originally Posted by philippe_44 View Post
    Yes I did - what happens is that the URL is redirected and when you pause, LMS closes the connection (depending on player's buffer fullness, but that's details...). When it re-opens, it re-opens from the redirected URL which was volatile.
    So Caching and a larger buffer would work?
    QLMS 8.3@2.21 x64 (digimaster) / QNAP 469L QTS 4.3.4
    LMS 8.3 x64 / Intel NUC8 i3

  6. #16
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    7,624

    Resuming podcasts stopped working

    Quote Originally Posted by dolodobendan View Post
    So Caching and a larger buffer would work?
    Not really as LMS will always re-try from where it paused (tbc). In other words, when there is a redirection of an url, LMS only uses the final redirected one to query the stream using HTTP (to simplify). When paused, under various conditions, it stops the streaming and will re-open a new connection upon resume. For that, it uses the redirected url. Unfortunately, these podcasts, hosted on soundcloud, seem to have a volatile *redirected* url which vanished after a short while.

    I have a solution, but it's a hack and not satisfactory at all. For now, I cannot find an elegant solution that does not restructure potentially a lot of things on how LMS handles redirection and track's url . And that bothers me because the day servers start to use systematically redirected url that change at every GET, then the core of LMS (not all plugins) will stop working.

    But there is probably a simple solution, as usual. I just need to find it
    Last edited by philippe_44; 2021-05-26 at 22:58.
    LMS 8.2 on Odroid-C4 - SqueezeAMP!, 5xRadio, 5xBoom, 2xDuet, 1xTouch, 1xSB3. Sonos PLAY:3, PLAY:5, Marantz NR1603, Foobar2000, ShairPortW, 2xChromecast Audio, Chromecast v1 and v2, Squeezelite on Pi, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5, RivaArena 1 & 3

  7. #17
    Senior Member dolodobendan's Avatar
    Join Date
    Dec 2017
    Location
    Braunschweig, Germany
    Posts
    1,446
    Quote Originally Posted by philippe_44 View Post
    Not really as LMS will always re-try from where it paused (tbc). In other words, when there is a redirection of an url, LMS only uses the final redirected one to query the stream using HTTP (to simplify). When paused, under various conditions, it stops the streaming and will re-open a new connection upon resume. For that, it uses the redirected url. Unfortunately, these podcasts, hosted on soundcloud, seem to have a volatile *redirected* url which vanished after a short while.

    I have a solution, but it's a hack and not satisfactory at all. For now, I cannot find an elegant solution that does not restructure potentially a lot of things on how LMS handles redirection and track's url . And that bothers me because the day servers start to use systematically redirected url that change at every GET, then the core of LMS (not all plugins) will stop working.

    But there is probably a simple solution, as usual. I just need to find it
    Thank you for explaining the problem and your continuing effort to make things even better!
    QLMS 8.3@2.21 x64 (digimaster) / QNAP 469L QTS 4.3.4
    LMS 8.3 x64 / Intel NUC8 i3

  8. #18
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    7,624
    Quote Originally Posted by dolodobendan View Post
    Thank you for explaining the problem and your continuing effort to make things even better!
    Try the latest LMS 8.2 nightly
    LMS 8.2 on Odroid-C4 - SqueezeAMP!, 5xRadio, 5xBoom, 2xDuet, 1xTouch, 1xSB3. Sonos PLAY:3, PLAY:5, Marantz NR1603, Foobar2000, ShairPortW, 2xChromecast Audio, Chromecast v1 and v2, Squeezelite on Pi, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5, RivaArena 1 & 3

  9. #19
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    7,976
    Quote Originally Posted by philippe_44 View Post
    Try the latest LMS 8.2 nightly
    No difference for me with LMS 8.2.0-1623416430.

    Sent from my Pixel 3a using Tapatalk

  10. #20
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    7,976
    Quote Originally Posted by philippe_44 View Post
    Try the latest LMS 8.2 nightly
    Ignore the last post, there was another update queued up after the one I downloaded. Now I can resume the podcast but it resumes from the beginning and not from the paused position. The podcast also does not appear in the recently played list.

    Sent from my Pixel 3a using Tapatalk

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •