Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 4 of 4
  1. #1
    Junior Member
    Join Date
    May 2021

    wlan0 not appearing with piCorePlayer on Raspberry Pi Zero W

    I've got a new Pi zero, and a recently downloaded piCorePlayer. It's working fine with Ethernet, but the wireless isn't showing up. I'm not sure how best to debut, as e.g. iwconfig is not present. All the debug output I can think of is below. Any suggestions? I've done a similar setup on a Model 3B without trouble. I've also tried with a USB WiFi adapter (from the Pi Hut, several years old) without success.

    > cat /proc/cpuinfo
    processor	: 0
    model name	: ARMv6-compatible processor rev 7 (v6l)
    BogoMIPS	: 1138.45
    Features	: half thumb fastmult vfp edsp java tls
    CPU implementer	: 0x41
    CPU architecture: 7
    CPU variant	: 0x0
    CPU part	: 0xb76
    CPU revision	: 7
    Hardware	: BCM2835
    Revision	: 9000c1
    Serial		: 000000006ea9a012
    Model		: Raspberry Pi Zero W Rev 1.1
     > ifconfig
    eth0      Link encap:Ethernet  HWaddr 00:E6:99:00:0C:89
              inet addr:  Bcast:  Mask:
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:513 errors:0 dropped:106 overruns:0 frame:0
              TX packets:257 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:104057 (101.6 KiB)  TX bytes:44350 (43.3 KiB)
    lo        Link encap:Local Loopback
              inet addr:  Mask:
              UP LOOPBACK RUNNING  MTU:65536  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
    piCorePlayer version is:
    #piCorePlayer version
    PCPVERS="piCorePlayer 7.0.0"
    WWW_BUILD: 00011
    > lsusb
    Bus 001 Device 001: ID 1d6b:0002
    Bus 001 Device 005: ID 148f:5370
    Bus 001 Device 003: ID 0fe6:9900
    Bus 001 Device 002: ID 214b:7250
    Bus 001 Device 004: ID 1a86:e2e3

  2. #2
    Senior Member Greg Erskine's Avatar
    Join Date
    Sep 2006
    Sydney, Australia
    hi mo-seph,

    I just installed wifi on my RPi0W via USB ethernet and it worked fine.

    Are you using a SD card from your other RPi3B by any chance?

    There is a [Diagnostics] button on the [Wifi Settings] page that gives you more debug information.


  3. #3
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Ive set them up many times using this procedure.

    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  4. #4
    Junior Member
    Join Date
    May 2021
    Thanks both - not sure what the issue was, as I had started from a blank SD card, but I've gone through from the beginning and now WiFi works. I really like being able to setup wpa_supplicant before first boot!

    (now if I can just figure out why it has decided the touch screen is not a touch screen, I'm golden )

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts