Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 3 of 3
  1. #1
    Junior Member
    Join Date
    Mar 2020
    Location
    Ohio, USA
    Posts
    4

    Error starting web streams in 8.2.0 - 1620537046

    New issue for me in the recent days releases.

    Version Logitech Media Server Version: 8.2.0 - 1620537046 @ Sun May 9 07:33:06 WEDT 2021

    When playing web streams from Favorites or player preset keys. Used these addresses for years, Receiving the following repeatedly.


    [21-05-09 18:38:54.2825] Slim::Control::Request::execute (1888) Error: While trying to run function coderef [Slim::Control::Commands:laylistXitemCommand]: [Can't locate object method "artistName" via package "http://sail.yachtrockmiami.com:8000/radio.mp3" (perhaps you forgot to load "http://sail.yachtrockmiami.com:8000/radio.mp3"?) at /Slim/Player/Playlist.pm line 798.
    ]
    [21-05-09 18:39:43.8889] Slim::Control::Request::execute (1888) Error: While trying to run function coderef [Slim::Control::Commands:laylistXitemCommand]: [Can't locate object method "artistName" via package "http://sail.yachtrockmiami.com:8000/radio.mp3" (perhaps you forgot to load "http://sail.yachtrockmiami.com:8000/radio.mp3"?) at /Slim/Player/Playlist.pm line 798.
    ]
    [21-05-09 18:39:51.3776] Slim::Control::Request::execute (1888) Error: While trying to run function coderef [Slim::Control::Commands:laylistXitemCommand]: [Can't locate object method "artistName" via package "http://sail.yachtrockmiami.com:8000/radio.mp3" (perhaps you forgot to load "http://sail.yachtrockmiami.com:8000/radio.mp3"?) at /Slim/Player/Playlist.pm line 798.
    ]
    [21-05-09 18:39:51.7224] Slim::Control::Request::execute (1888) Error: While trying to run function coderef [Slim::Control::Commands:laylistXitemCommand]: [Can't locate object method "artistName" via package "http://sail.yachtrockmiami.com:8000/radio.mp3" (perhaps you forgot to load "http://sail.yachtrockmiami.com:8000/radio.mp3"?) at /Slim/Player/Playlist.pm line 798.
    ]

    Eventually it will play but need multiple attempts to make connection before playing begins.

    I've attached the server.log file
    Attached Files Attached Files
    Players: Touch, Boom, Radio x3 ,PiCorePlayer(RPi 3), Various Chromecasts & SqueezePlays
    Server: LMS Version: 8.2.0 - 1620537046 Windows 10
    Remotes: SqueezeCtrl/Squeeze Commander/PC
    Music: 567GB, 3K albums with 56K songs by 5K artists mostly FLACs (w/DSDs & Videos)

  2. #2
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,556
    Thanks for the report! This should be fixed in the upcoming next build. Until then turn off shuffling of the current playlist. That should work around that limitation.
    Michael

    "It doesn't work - what shall I do?" - "Please check your server.log and/or scanner.log file!"
    (LMS: Settings/Information)

  3. #3
    Junior Member
    Join Date
    Mar 2020
    Location
    Ohio, USA
    Posts
    4
    That does the trick! Thanks for the workaround!
    Players: Touch, Boom, Radio x3 ,PiCorePlayer(RPi 3), Various Chromecasts & SqueezePlays
    Server: LMS Version: 8.2.0 - 1620537046 Windows 10
    Remotes: SqueezeCtrl/Squeeze Commander/PC
    Music: 567GB, 3K albums with 56K songs by 5K artists mostly FLACs (w/DSDs & Videos)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •