Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 3 123 LastLast
Results 1 to 10 of 28
  1. #1
    Senior Member
    Join Date
    May 2008
    Location
    United States, Florida
    Posts
    12,320

    Track count different between rPi3B+ and rPi4B, running same version of LMS

    I saw a similar post in the last few months regarding media count not matching and how to figure out differences with the database, but I can't locate it now. Here's my issue.

    Short version: The number of files scanned *and* the total number of tracks is 31 fewer on the newly setup rPi3B+ as compared with existing rPi4B running same version of LMS. Both running current PcP 7.0.1 and LMS 8.1.2. Scanner logs have no errors noted. And swapping out the two USB HDDs between the two rPis doesn't change anything. (Both USB HDDs are WD spinning drive, USB 3.0 portable 4TB.) Based on library statistic numbers, it seems two albums by two different artists are missing in the rPi3B+ (total of 31 tracks). Details below.

    Any thoughts (or links to other threads) on how to track down what is different? Thanks.

    Details:

    I setup an rPi3B+ with DAC hat today from scratch with LMS and squeezelite running. PcP 7.0.1 (32bit). Running LMS 8.1.2

    With rPi3B+ and attached USB drive and "clear library and rescan everything" I get the following results.

    Name:  Capture.JPG
Views: 343
Size:  105.0 KB

    With rPi4B running pCP 7.0.1 (64 bit) and a *different* USB drive (with identical files as the other USB drive) and LMS 8.1.2, I get the following results from a clear and rescan.

    Name:  Capture2.JPG
Views: 321
Size:  108.3 KB


    Also note, that with either of the USB HDDs (the one attached to the rPi3B+ or the one attached to rPi4B), I get a track count of 116,509 when connected to my PC and scanned with foobar2000. And even more mysterious, if I switch out the USB HDDs and connect the one from the rPi4B instead to the rPi3B+, I still get the same 31 lower track count. And if I connect the orginal rPi3B+ USB drive to the rPi4B, I get the correct 116,509 track count. So the USB drives have identical files/folders (and even byte count when I look at the properties of the music directory on each).

    It's a mystery!

    p.s. on a more positive note, notice the scan time difference between the rPi4B (piCorePlayer 64bit), with USB HD connected to USB 3.0 port, 1 hour, 17 minutes, vs the rPi3B+ (piCorePlayer 32bit), 3 hours and 2 minutes.
    Home: Pi4B-8GB/pCP7.x/4TB>LMS 8.1.x>Transporter, Touch, Boom, Radio (all ethernet)
    Cottage: rPi4B-4GB/pCP7.x/4TB>LMS 8.1.x>Touch>Benchmark DAC I, Boom, Radio w/Battery (Radio WIFI)
    Office: Win10(64)>foobar2000
    The Wild: rPi3B+/pCP7.x/4TB>LMS 8.1.x>hifiberry Dac+Pro (LMS & Squeezelite)
    Controllers: iPhone11 & iPadAir3 (iPeng), CONTROLLER, Material Skin, or SqueezePlay 7.8 on Win10(64)
    Files: Ripping: dBpoweramp > FLAC; Post-rip: mp3tag, PerfectTunes, TuneFusion; Streaming: Spotify

  2. #2
    Senior Member
    Join Date
    Feb 2011
    Location
    Cheshire, UK
    Posts
    5,791
    Quote Originally Posted by garym View Post
    I saw a similar post in the last few months regarding media count not matching and how to figure out differences with the database, but I can't locate it now. Here's my issue.

    Short version: The number of files scanned *and* the total number of tracks is 31 fewer on the newly setup rPi3B+ as compared with existing rPi4B running same version of LMS. Both running current PcP 7.0.1 and LMS 8.1.2. Scanner logs have no errors noted. And swapping out the two USB HDDs between the two rPis doesn't change anything. (Both USB HDDs are WD spinning drive, USB 3.0 portable 4TB.) Based on library statistic numbers, it seems two albums by two different artists are missing in the rPi3B+ (total of 31 tracks). Details below.

    Any thoughts (or links to other threads) on how to track down what is different? Thanks.

    Details:

    I setup an rPi3B+ with DAC hat today from scratch with LMS and squeezelite running. PcP 7.0.1 (32bit). Running LMS 8.1.2

    With rPi3B+ and attached USB drive and "clear library and rescan everything" I get the following results.

    Name:  Capture.JPG
Views: 343
Size:  105.0 KB

    With rPi4B running pCP 7.0.1 (64 bit) and a *different* USB drive (with identical files as the other USB drive) and LMS 8.1.2, I get the following results from a clear and rescan.

    Name:  Capture2.JPG
Views: 321
Size:  108.3 KB


    Also note, that with either of the USB HDDs (the one attached to the rPi3B+ or the one attached to rPi4B), I get a track count of 116,509 when connected to my PC and scanned with foobar2000. And even more mysterious, if I switch out the USB HDDs and connect the one from the rPi4B instead to the rPi3B+, I still get the same 31 lower track count. And if I connect the orginal rPi3B+ USB drive to the rPi4B, I get the correct 116,509 track count. So the USB drives have identical files/folders (and even byte count when I look at the properties of the music directory on each).

    It's a mystery!

    p.s. on a more positive note, notice the scan time difference between the rPi4B (piCorePlayer 64bit), with USB HD connected to USB 3.0 port, 1 hour, 17 minutes, vs the rPi3B+ (piCorePlayer 32bit), 3 hours and 2 minutes.
    It was a post by me before but its not the same issue.
    I had Qobuz OMLI set up and one of the two LMS had this ticked and other didn't

    Name:  2021-04-23 11_49_33-Server Settings.jpg
Views: 85
Size:  22.9 KB

    In your case I would suggest a permissions issue where one Pi can see the files and other can't?
    VB2.4 storage QNAP TS419p (NFS)
    Living Room Joggler & Pi4/Khadas -> Onkyo TXNR686 -> Celestion F20s
    Office Joggler & Pi3 -> Denon RCD N8 -> Celestion F10s
    Dining Room SB Boom
    Kitchen UE Radio (upgraded to SB Radio)
    Bedroom (Bedside) Pi Zero+DAC ->ToppingTP21 ->AKG Headphones
    Bedroom (TV) & Bathroom SB Touch ->Denon AVR ->Mordaunt Short M10s + Kef ceiling speakers
    Guest Room Joggler > Topping Amp -> Wharfedale Modus Cubes
    Everything controlled by iPeng & Material on iOS

  3. #3
    Senior Member
    Join Date
    May 2008
    Location
    United States, Florida
    Posts
    12,320
    Quote Originally Posted by d6jg View Post
    It was a post by me before but its not the same issue.
    I had Qobuz OMLI set up and one of the two LMS had this ticked and other didn't

    Name:  2021-04-23 11_49_33-Server Settings.jpg
Views: 85
Size:  22.9 KB

    In your case I would suggest a permissions issue where one Pi can see the files and other can't?
    Hmmm, I've never had to deal with permissions issues before. Any thoughts on how I would check this?
    Home: Pi4B-8GB/pCP7.x/4TB>LMS 8.1.x>Transporter, Touch, Boom, Radio (all ethernet)
    Cottage: rPi4B-4GB/pCP7.x/4TB>LMS 8.1.x>Touch>Benchmark DAC I, Boom, Radio w/Battery (Radio WIFI)
    Office: Win10(64)>foobar2000
    The Wild: rPi3B+/pCP7.x/4TB>LMS 8.1.x>hifiberry Dac+Pro (LMS & Squeezelite)
    Controllers: iPhone11 & iPadAir3 (iPeng), CONTROLLER, Material Skin, or SqueezePlay 7.8 on Win10(64)
    Files: Ripping: dBpoweramp > FLAC; Post-rip: mp3tag, PerfectTunes, TuneFusion; Streaming: Spotify

  4. #4
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    6,857
    It would be strange if only 2 albums were affected by permissions.

    Sent from my Pixel 3a using Tapatalk

  5. #5
    Senior Member
    Join Date
    May 2008
    Location
    United States, Florida
    Posts
    12,320
    Quote Originally Posted by slartibartfast View Post
    It would be strange if only 2 albums were affected by permissions.

    Sent from my Pixel 3a using Tapatalk
    my thoughts as well. And I've setup 4 other rPis and never had to deal with permissions. But something odd is happening.....
    Home: Pi4B-8GB/pCP7.x/4TB>LMS 8.1.x>Transporter, Touch, Boom, Radio (all ethernet)
    Cottage: rPi4B-4GB/pCP7.x/4TB>LMS 8.1.x>Touch>Benchmark DAC I, Boom, Radio w/Battery (Radio WIFI)
    Office: Win10(64)>foobar2000
    The Wild: rPi3B+/pCP7.x/4TB>LMS 8.1.x>hifiberry Dac+Pro (LMS & Squeezelite)
    Controllers: iPhone11 & iPadAir3 (iPeng), CONTROLLER, Material Skin, or SqueezePlay 7.8 on Win10(64)
    Files: Ripping: dBpoweramp > FLAC; Post-rip: mp3tag, PerfectTunes, TuneFusion; Streaming: Spotify

  6. #6
    Senior Member
    Join Date
    May 2008
    Location
    United States, Florida
    Posts
    12,320
    Quote Originally Posted by garym View Post
    my thoughts as well. And I've setup 4 other rPis and never had to deal with permissions. But something odd is happening.....
    In file explorer on windows, all the files show up with exactly the same "owner" and all have the same file attribute ("A" for archive), with each folder also having the same owner as files with attribute of "D" for directory. No outliers.
    Home: Pi4B-8GB/pCP7.x/4TB>LMS 8.1.x>Transporter, Touch, Boom, Radio (all ethernet)
    Cottage: rPi4B-4GB/pCP7.x/4TB>LMS 8.1.x>Touch>Benchmark DAC I, Boom, Radio w/Battery (Radio WIFI)
    Office: Win10(64)>foobar2000
    The Wild: rPi3B+/pCP7.x/4TB>LMS 8.1.x>hifiberry Dac+Pro (LMS & Squeezelite)
    Controllers: iPhone11 & iPadAir3 (iPeng), CONTROLLER, Material Skin, or SqueezePlay 7.8 on Win10(64)
    Files: Ripping: dBpoweramp > FLAC; Post-rip: mp3tag, PerfectTunes, TuneFusion; Streaming: Spotify

  7. #7
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    6,857
    Quote Originally Posted by garym View Post
    In file explorer on windows, all the files show up with exactly the same "owner" and all have the same file attribute ("A" for archive), with each folder also having the same owner as files with attribute of "D" for directory. No outliers.
    Maybe check the scanner log with scan.scanner set to debug. It will be long.

    Sent from my Pixel 3a using Tapatalk

  8. #8
    Senior Member
    Join Date
    May 2008
    Location
    United States, Florida
    Posts
    12,320
    Quote Originally Posted by slartibartfast View Post
    Maybe check the scanner log with scan.scanner set to debug. It will be long.

    Sent from my Pixel 3a using Tapatalk
    I'll do this with both rPis today while I'm away and report back.
    Home: Pi4B-8GB/pCP7.x/4TB>LMS 8.1.x>Transporter, Touch, Boom, Radio (all ethernet)
    Cottage: rPi4B-4GB/pCP7.x/4TB>LMS 8.1.x>Touch>Benchmark DAC I, Boom, Radio w/Battery (Radio WIFI)
    Office: Win10(64)>foobar2000
    The Wild: rPi3B+/pCP7.x/4TB>LMS 8.1.x>hifiberry Dac+Pro (LMS & Squeezelite)
    Controllers: iPhone11 & iPadAir3 (iPeng), CONTROLLER, Material Skin, or SqueezePlay 7.8 on Win10(64)
    Files: Ripping: dBpoweramp > FLAC; Post-rip: mp3tag, PerfectTunes, TuneFusion; Streaming: Spotify

  9. #9
    Senior Member
    Join Date
    Feb 2011
    Location
    Cheshire, UK
    Posts
    5,791
    Quote Originally Posted by garym View Post
    In file explorer on windows, all the files show up with exactly the same "owner" and all have the same file attribute ("A" for archive), with each folder also having the same owner as files with attribute of "D" for directory. No outliers.
    Windows is irrelevant. You need to look at the *nix permissions. Use WinSCP.
    VB2.4 storage QNAP TS419p (NFS)
    Living Room Joggler & Pi4/Khadas -> Onkyo TXNR686 -> Celestion F20s
    Office Joggler & Pi3 -> Denon RCD N8 -> Celestion F10s
    Dining Room SB Boom
    Kitchen UE Radio (upgraded to SB Radio)
    Bedroom (Bedside) Pi Zero+DAC ->ToppingTP21 ->AKG Headphones
    Bedroom (TV) & Bathroom SB Touch ->Denon AVR ->Mordaunt Short M10s + Kef ceiling speakers
    Guest Room Joggler > Topping Amp -> Wharfedale Modus Cubes
    Everything controlled by iPeng & Material on iOS

  10. #10
    Senior Member
    Join Date
    Feb 2011
    Location
    Cheshire, UK
    Posts
    5,791
    Quote Originally Posted by slartibartfast View Post
    It would be strange if only 2 albums were affected by permissions.

    Sent from my Pixel 3a using Tapatalk
    Not at all. This can be quite common if for example some files were ripped and others downloaded from somewhere and put onto the USB disk in a different way to the norm.
    VB2.4 storage QNAP TS419p (NFS)
    Living Room Joggler & Pi4/Khadas -> Onkyo TXNR686 -> Celestion F20s
    Office Joggler & Pi3 -> Denon RCD N8 -> Celestion F10s
    Dining Room SB Boom
    Kitchen UE Radio (upgraded to SB Radio)
    Bedroom (Bedside) Pi Zero+DAC ->ToppingTP21 ->AKG Headphones
    Bedroom (TV) & Bathroom SB Touch ->Denon AVR ->Mordaunt Short M10s + Kef ceiling speakers
    Guest Room Joggler > Topping Amp -> Wharfedale Modus Cubes
    Everything controlled by iPeng & Material on iOS

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •