Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 2 12 LastLast
Results 1 to 10 of 13
  1. #1

    LMS Playlist coming up empty

    A while ago I made some playlists to use with LMS, jRiver, foobar, VLC. They worked with all of these. Now their content comes up empty when I launch them in LMS. They still work with jRiver, VLC and foobar without issues.

    I have attached one of the m3u playlists (renamed to *.txt). Can anyone see something wrong with the playlist for use with LMS?
    Thanks a lot
    Attached Files Attached Files
    • Logitech Media Server Version: 8.1.2 on Synology DS1815+ DSM 6 / Docker
    • SB Touch (2x)

  2. #2
    Senior Member kidstypike's Avatar
    Join Date
    Feb 2007
    Location
    Brindle
    Posts
    4,499
    Quote Originally Posted by jacobacci View Post
    A while ago I made some playlists to use with LMS, jRiver, foobar, VLC. They worked with all of these. Now their content comes up empty when I launch them in LMS. They still work with jRiver, VLC and foobar without issues.

    I have attached one of the m3u playlists (renamed to *.txt). Can anyone see something wrong with the playlist for use with LMS?
    Thanks a lot
    File paths?

    Make a small playlist of a couple of tracks using LMS, open it in a text editor and compare paths with those made with your other software.
    Server - LMS 8.2.0 Pi4B 4GB/Argon one case/pCP v7.0.1 - 75K library, playlists & LMS cache on SSD (ntfs)
    Study - Pi3B/pCP 7.0.1/pi screen/AlloBoss DAC HAT/Ruark MR1 Mk2
    Lounge - Pi2/pCP 6.0.0 > HiFiBerry DIGI+ > AudioEngine DAC1 > AVI DM5
    Dining Room - Pi3B/pCP/Bluetooth/Echo Show 8
    Garage - DAC32 > Edifier speakers

    Spares - 2xTouch, 1xSB Radio. 1xSB3, 6xRPi

  3. #3
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    4,138
    The playlist is using a relative path

    Which folder is the playlist in and where is the music in relation to it?
    Paul Webster
    http://dabdig.blogspot.com
    Author of "Now Playing" plugins covering Radio France (FIP etc), PlanetRadio (Bauer - Kiss, Absolute, Scala, JazzFM etc), KCRW, Supla Finland, ABC Australia, CBC/Radio-Canada and RTE Ireland

  4. #4
    Thanks for your pointers. I am indeed using relative paths in my playlists. I am very sure this used to work (as our regular Sunday breakfast music is one of the playlists. I haven't used it for a while as I am now mainly using Roon).

    The folder structure of my music folder (on the NAS) looks as follows:

    Volume 1/music/folder 1
    Volume 1/music/folder 2
    Volume 1/music/folder 3
    Volume 1/music/folder 4
    Volume 1/music/folder 5
    Volume 1/music/folder 6
    Volume 1/music/folder 7
    Volume 1/music/LMS_Playlists

    Googling I have found a lot of posts (most quite old) that claim that LMS does not support relative paths, but I struggle to believe that.
    • Logitech Media Server Version: 8.1.2 on Synology DS1815+ DSM 6 / Docker
    • SB Touch (2x)

  5. #5
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    4,138
    Relative playlists should work provided the path is correct.

    You could try enabling more in Settings/Advanced/Logging
    Paul Webster
    http://dabdig.blogspot.com
    Author of "Now Playing" plugins covering Radio France (FIP etc), PlanetRadio (Bauer - Kiss, Absolute, Scala, JazzFM etc), KCRW, Supla Finland, ABC Australia, CBC/Radio-Canada and RTE Ireland

  6. #6
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    20,404
    Quote Originally Posted by jacobacci View Post
    Googling I have found a lot of posts (most quite old) that claim that LMS does not support relative paths, but I struggle to believe that.
    Looking at the M3U code - it seems to handles relative path for files in playlist but your relative path may be incorrect in terms of where LMS considers its base.

    What are the path you have entered as Setting for Music Folder ?

  7. #7
    Quote Originally Posted by bpa View Post
    What are the path you have entered as Setting for Music Folder ?
    You may be onto something here. I changed from Pinkdot's LMS on Synology to Docker (to be future proof). It may well be that LMS running as a docker container impacts the functioning of relative playlists.

    I have set the folder names as follows:


    Music folder:

    Name:  music folder.png
Views: 43
Size:  159.5 KB


    Playlist folder:

    Name:  playlists.png
Views: 42
Size:  114.6 KB


    And here are the Docker Volume settings:

    Name:  docker.png
Views: 40
Size:  52.1 KB


    If I create a playlist from the webinterface of LMS, it works. LMS creates it with absolute paths.
    Last edited by jacobacci; 2021-04-19 at 04:00.
    • Logitech Media Server Version: 8.1.2 on Synology DS1815+ DSM 6 / Docker
    • SB Touch (2x)

  8. #8
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    4,138
    Your first one is

    Code:
    ../3c 96.0/Queffelec, Anne/Satie, Erik - Satie et Compagnie (96.0)/01-01-Gnossienne 1.flac
    Not 100% sure if LMS expects the path to be relative to the playlist location or the music folder but in either case ... this would not work.

    My guess is that you used to have the playlists folder inside the music folder.
    Paul Webster
    http://dabdig.blogspot.com
    Author of "Now Playing" plugins covering Radio France (FIP etc), PlanetRadio (Bauer - Kiss, Absolute, Scala, JazzFM etc), KCRW, Supla Finland, ABC Australia, CBC/Radio-Canada and RTE Ireland

  9. #9
    Senior Member kidstypike's Avatar
    Join Date
    Feb 2007
    Location
    Brindle
    Posts
    4,499
    Quote Originally Posted by jacobacci View Post
    If I create a playlist from the webinterface of LMS, it works. LMS creates it with absolute paths.
    Using a text editor use find and replace on one of your playlists to match what LMS expects, and rescan.
    Server - LMS 8.2.0 Pi4B 4GB/Argon one case/pCP v7.0.1 - 75K library, playlists & LMS cache on SSD (ntfs)
    Study - Pi3B/pCP 7.0.1/pi screen/AlloBoss DAC HAT/Ruark MR1 Mk2
    Lounge - Pi2/pCP 6.0.0 > HiFiBerry DIGI+ > AudioEngine DAC1 > AVI DM5
    Dining Room - Pi3B/pCP/Bluetooth/Echo Show 8
    Garage - DAC32 > Edifier speakers

    Spares - 2xTouch, 1xSB Radio. 1xSB3, 6xRPi

  10. #10
    Thinking about this some more, it seems to me that relative paths cannot work in the Docker container. Docker uses two completely different paths for /music and /playlists that do not share a common root. As a consequence a relative path in /playlists points to nowhere.
    I have now replaced ../ with file:///music/ in the playlists and they seem to work.
    Thanks a lot for your inputs. They led me to the root cause of the issue.
    Last edited by jacobacci; 2021-04-19 at 04:42.
    • Logitech Media Server Version: 8.1.2 on Synology DS1815+ DSM 6 / Docker
    • SB Touch (2x)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •