Hello all!

I use with success pcp for my audio multiroom since 4 years now. All works fine.

One of my player is hoste on a Rpi3 (with embedded wifi chip), so I want this player do more things like sharing LAN access.

I activate WAP mode, go to wap mode page and fill in fields. After reboot access point is OK; I can connect to it with all my devices. But in this mode, there is another dhcp server on the Rpi giving devices connected an IP adress. I want use the bridge mode as connected devices will have IP from my primary DHCP server.
This mode doesn't work because of brctl command can't operate the bridgingbetween eth0 and wlan0:

tc@pCP:~$ brctl
Usage: brctl [commands]
        addbr           <bridge>                add bridge
        delbr           <bridge>                delete bridge
        addif           <bridge> <device>       add interface to bridge
        delif           <bridge> <device>       delete interface from bridge
        hairpin         <bridge> <port> {on|off}        turn hairpin on/off
        setageing       <bridge> <time>         set ageing time
        setbridgeprio   <bridge> <prio>         set bridge priority
        setfd           <bridge> <time>         set bridge forward delay
        sethello        <bridge> <time>         set hello time
        setmaxage       <bridge> <time>         set max message age
        setpathcost     <bridge> <port> <cost>  set path cost
        setportprio     <bridge> <port> <prio>  set port priority
        show            [ <bridge> ]            show a list of bridges
        showmacs        <bridge>                show a list of mac addrs
        showstp         <bridge>                show bridge stp info
        stp             <bridge> {on|off}       turn stp on/off
tc@pCP:~$ brctl addbr br0
add bridge failed: Package not installed
After many web search, it appears that the kernel of piCorePlayer is compiled with the option "CONFIG_BRIDGE=m" ...

There is a way to make brctl command working without compiling a new kernel ?