Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: lost apps

  1. #1
    Senior Member
    Join Date
    May 2007
    Posts
    122

    lost apps

    All -

    I know this comes up periodically on the forums, and I've done some reading, but have yet to find an unambiguous answer: after several years of flawless operation, LMS has stopped showing my apps.

    Yes, I logged back in using the tab under settings in LMS, and yes I restarted the hardware LMS is running on. Anyone have a thought on what I should do next?

    tks,

    Scott A.

  2. #2
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,540

    lost apps

    > Anyone have a thought on one I should do next?

    Check your server.log for any networking related issue.

  3. #3
    Senior Member
    Join Date
    May 2007
    Posts
    122
    Here are the top lines from server. I'm the furthest thing from a networking expert, but nothing jumps out at me.

    [21-04-12 19:06:08.5555] Slim::Plugin::FullTextSearch::Plugin::_rebuildInde x (489) Create fulltext index for contributors
    [21-04-12 19:06:08.5818] Slim::Plugin::FullTextSearch::Plugin::_rebuildInde x (499) Create fulltext index for playlists
    [21-04-12 19:06:08.5881] Slim::Plugin::FullTextSearch::Plugin::_rebuildInde x (514) Optimize fulltext index
    [21-04-12 19:06:08.6363] Slim::Plugin::FullTextSearch::Plugin::_rebuildInde x (529) Fulltext index build done!
    [21-04-12 19:06:08.6367] Slim::Music::Import::endImporter (709) Completed Slim::Plugin::FullTextSearch::Plugin Scan in 0 seconds.
    [21-04-12 19:06:08.6372] Slim::Music::Import::runImporter (577) Starting Slim::Plugin::ExtendedBrowseModes::Libraries scan
    [21-04-12 19:06:08.6376] Slim::Music::Import::runImporter (577) Starting Slim::Plugin::OnlineLibrary::Importer::VirtualLibr ariesCleanup scan
    [21-04-12 19:06:08.6390] Slim::Music::Import::endImporter (709) Completed Slim::Plugin::OnlineLibrary::Importer::VirtualLibr ariesCleanup Scan in 0 seconds.
    [21-04-12 19:06:08.6414] Slim::Music::Artwork::updateStandaloneArtwork (234) Starting updateStandaloneArtwork for 0 albums
    [21-04-12 19:06:08.6438] Slim::Music::Artwork:recacheAllArtwork (659) Starting precacheArtwork for 0 albums
    [21-04-12 19:06:08.6441] Slim::Music::Import::endImporter (709) Completed precacheArtwork Scan in 0 seconds.
    [21-04-12 19:06:08.6457] Slim::Music::Import::runScanPostProcessing (479) Starting Database optimization.
    [21-04-12 19:06:09.3145] Slim::Music::Import::endImporter (709) Completed dbOptimize Scan in 0 seconds.
    You're using a rather old version of IO::Socket::SSL (v1.22) - please try to update to at least 2.020 for improved compatibility.
    [21-04-12 20:06:07.3698] main::main (206) Starting Logitech Media Server scanner (v8.0.0, 1605892076, Fri Nov 20 21:24:10 CET 2020) perl 5.010000
    [21-04-12 20:06:07.6696] Slim::Schema::forceCommit (2160) Warning: Trying to commit transactions before DB is initialized!
    [21-04-12 20:06:07.9578] Slim::Plugin:eezer::Importer::isImportEnabled (42) Failed to get Deezer accounts: Protocol scheme 'https' is not supported (LWP::Protocol::https not installed)
    [21-04-12 20:06:07.9841] Slim::Music::Import::runImporter (577) Starting Slim::Plugin::FullTextSearch::Plugin scan
    [21-04-12 20:06:07.9852] Slim::Plugin::FullTextSearch::Plugin::_rebuildInde x (453) Starting fulltext index build
    [21-04-12 20:06:07.9855] Slim::Plugin::FullTextSearch::Plugin::_rebuildInde x (457) Initialize fulltext table
    [21-04-12 20:06:08.0173] Slim::Plugin::FullTextSearch::Plugin::_rebuildInde x (470) Create fulltext index for tracks
    [21-04-12 20:06:08.3837] Slim::Plugin::FullTextSearch::Plugin::_rebuildInde x (480) Create fulltext index for albums
    [21-04-12 20:06:08.5837] Slim::Plugin::FullTextSearch::Plugin::_rebuildInde x (489) Create fulltext index for contributors
    [21-04-12 20:06:08.6101] Slim::Plugin::FullTextSearch::Plugin::_rebuildInde x (499) Create fulltext index for playlists
    [21-04-12 20:06:08.6164] Slim::Plugin::FullTextSearch::Plugin::_rebuildInde x (514) Optimize fulltext index
    [21-04-12 20:06:08.6643] Slim::Plugin::FullTextSearch::Plugin::_rebuildInde x (529) Fulltext index build done!
    [21-04-12 20:06:08.6647] Slim::Music::Import::endImporter (709) Completed Slim::Plugin::FullTextSearch::Plugin Scan in 0 seconds.
    [21-04-12 20:06:08.6652] Slim::Music::Import::runImporter (577) Starting Slim::Plugin::ExtendedBrowseModes::Libraries scan
    [21-04-12 20:06:08.6655] Slim::Music::Import::runImporter (577) Starting Slim::Plugin::OnlineLibrary::Importer::VirtualLibr ariesCleanup scan
    [21-04-12 20:06:08.6670] Slim::Music::Import::endImporter (709) Completed Slim::Plugin::OnlineLibrary::Importer::VirtualLibr ariesCleanup Scan in 0 seconds.
    [21-04-12 20:06:08.6693] Slim::Music::Artwork::updateStandaloneArtwork (234) Starting updateStandaloneArtwork for 0 albums
    [21-04-12 20:06:08.6716] Slim::Music::Artwork:recacheAllArtwork (659) Starting precacheArtwork for 0 albums
    [21-04-12 20:06:08.6719] Slim::Music::Import::endImporter (709) Completed precacheArtwork Scan in 0 seconds.
    [21-04-12 20:06:08.6735] Slim::Music::Import::runScanPostProcessing (479) Starting Database optimization.
    [21-04-12 20:06:09.3120] Slim::Music::Import::endImporter (709) Completed dbOptimize Scan in 0 seconds.

    s.

  4. #4
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,540

    lost apps

    > You're using a rather old version of IO::Socket::SSL (v1.22) - please
    > try to update to at least 2.020 for improved compatibility.
    > [21-04-12 20:06:07.3698] main::main (206) Starting Logitech Media Server
    > scanner (v8.0.0, 1605892076, Fri Nov 20 21:24:10 CET 2020) perl
    > 5.010000


    What OS are you on? This is really the oldest Perl (5.10) which is
    barely supported by LMS, and its HTTPS support is sorely lacking. It's
    there, but way outdated.

    > (42) Failed to get Deezer accounts: Protocol scheme 'https' is not
    > supported (LWP::Protocol::https not installed)


    Oh, it's actually missing some libraries for https support, too.

  5. #5
    Senior Member
    Join Date
    May 2007
    Posts
    122
    I've been running it on an ancient Mac Mini, which tops out at 10.6.8. It's no chore to move to something more modern, either a Windows 10 machine, a current Mint Linux box or an OS X Mac that's a couple of generations old. Any preference among them?

    tks,

    s.

  6. #6
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,540

    lost apps

    > I've been running it on an ancient Mac Mini, which tops out at 10.6.8.
    > It's no chore to move to something more modern, either a Windows 10
    > machine, a current Mint Linux box or an OS X Mac that's a couple of
    > generations old. Any preference among them?


    If you feel comfortable using Linux, I'd recommend using it. Linux
    (Unix) is where Perl (the language used to develop LMS) feels at home.

  7. #7
    Senior Member
    Join Date
    May 2017
    Posts
    777
    I would say purchase a raspberry pi en put picoreplayer on it with LMS.
    Not to hard to setup and works great.
    SqueezeBoxes: 1x Transporter (Living room) 1x SB2 (shed), 1x Radio (Kitchen), 1x Boom (Dining room), 1x piCorePlayer (jacuzzi), 1x piCorePlayer (Garden) 1x OSMC + Squeezelite (Movie room), 1x Touch (Study 2), few spare unit's (SB2, SB3, Boom, Touch)
    Server: LMS on Pi3B+ 8.1.2 on PcP 7.0.1
    Network: Draytek, Netgear Smart Switch 24p, Ubiquiti PoE, 3x Ubiquity

  8. #8
    Senior Member
    Join Date
    May 2007
    Posts
    122
    Quote Originally Posted by mherger View Post
    > I've been running it on an ancient Mac Mini, which tops out at 10.6.8.
    > It's no chore to move to something more modern, either a Windows 10
    > machine, a current Mint Linux box or an OS X Mac that's a couple of
    > generations old. Any preference among them?


    If you feel comfortable using Linux, I'd recommend using it. Linux
    (Unix) is where Perl (the language used to develop LMS) feels at home.
    As always, thank you. I'll bring it up on my Linux box.

    best,

    s.

  9. #9
    Senior Member
    Join Date
    May 2007
    Posts
    122
    And just to finish off this thread...

    I ended up installing LMS on an old Win 10 box I have. The Linux box was my first choice - see above - but my son may be reclaiming that machine.

    The Win 10 box is plenty powerful; an i7 with 16 gigs of ram - it feels a little silly to be devoting it to running LMS, so I may at some point do something that is more proportional to the task at hand, a new Pi4 as some have suggested, or a less capable, salvaged desktop/laptop.

    One oddity; I tried but could not get 8.1.1 to install. The installer complained about compatibility problems, so I dropped back to 7.7.

    Anyway, problem worked around. Thanks all.

    s.

  10. #10
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    4,173
    Going back to 7.7 will also bring you the problems that 7.8, 7.9, 8.0, 8.1 and presumably soon 8.2 have solved.
    Some https source will not work properly and some integrations with 3rd-party services will not work or not be available.

    Trying to resolve the problem that you had with the installer should also help others who may well hit the same issue in the future.
    Paul Webster
    http://dabdig.blogspot.com
    Author of "Now Playing" plugins covering Radio France (FIP etc), PlanetRadio (Bauer - Kiss, Absolute, Scala, JazzFM etc), KCRW, Supla Finland, ABC Australia, CBC/Radio-Canada and RTE Ireland

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •