Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 4 of 4
  1. #1
    Senior Member
    Join Date
    Sep 2007
    Posts
    366

    "Remove Played Songs" Plugin No Longer Working

    I manually updated Erland's "Remove Played Songs" plugin .XML file to "<maxVersion>8.*</maxVersion>" hoping that would give it functionality under LMS 8.* but that hasn't revived the plugin. Obviously, it needs something else changed to make it work with 8(?). Does anyone know what else needs to be done to get this working again? I'm used to my Spicefly random plays having the old songs removed but now I'm having to delete each song manually.

    Plugin that was updated back in 2008 by Eric Koldinger is available here: https://github.com/koldinger/RemovePlayedSongs

    This was probably the very first plugin that I installed after I bought my first 'Box from SlimDevices.

  2. #2
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    20,415
    Have you tried checking the "use unsupported extensions" box " on the Settings/Plugins tab

  3. #3
    Senior Member Apesbrain's Avatar
    Join Date
    Jun 2005
    Location
    East Coast, USA
    Posts
    1,685
    Does it show up on your Plugins tab as loaded? Note that this plugin has a "per player" setting: Settings > Player > Remove Played Songs > [X].

    I just downloaded it from the link you provided, put it in folder below without any edits, and it loaded without issue on LMS 8.2 Win 7 x86:

    C:\Program Files\Squeezebox\server\Plugins

    However, for me it does not work as expected and only somewhat randomly deletes prior tracks from playlist.

    If the plugin is important to you, you could go back to LMS 7.9 which I assume is when it last worked properly:

    http://downloads.slimdevices.com/nig...ex.php?ver=7.9

  4. #4
    Senior Member
    Join Date
    Sep 2007
    Posts
    366
    Sorry .. been away for a couple of days since I posted this.

    @bpa .. I looked on the "Settings/Plugins" tab but don't see an "unsupported plugins" option. Even did a search for "supported" and unsupported." Not on my install.

    @apesbrain .. It is enabled on all of my players. Is listed in "active plugins." Just doesn't work. I did try to "downgrade" to 7.* and re-install all plugins and settings (with the .xml updated to maxversion = 8.* )but still seem to be stuck on 8.0.0 . So, that doesn't even work (for me, anyway).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •