Home of the Squeezebox™ & Transporter® network music players.
Page 3 of 6 FirstFirst 12345 ... LastLast
Results 21 to 30 of 59
  1. #21
    Senior Member
    Join Date
    Feb 2011
    Location
    Cheshire, UK
    Posts
    5,766
    Quote Originally Posted by chill View Post
    I've never looked into using EDO on my Jogglers, mostly because they're used only as controllers. I also boot them off tiny USB flash drives, so the USB socket is occupied. If I get a chance this weekend I'll set one up with a USB hub, so that I can output to a USB DAC while also booting from the flash drive, and I'll have a play with EDO.

    But at this point I have to say that I have no advantage over anyone else when it comes to this sort of tinkering - it's long enough since I stopped working on the Joggler that my memory of what I did is a bit dim!
    I thought your install was some Linux or other with Jivelite and an instance of Squeezelite? It should not need the EDO plugin should it? It should just need to properly detect the capability of the USB DAC (kernel) and setup Squeezelite accordingly - or am I being thick?
    Your install is effectively the same as a basic pCP with screen but instead on an old Joggler
    VB2.4 storage QNAP TS419p (NFS)
    Living Room Joggler & Pi4/Khadas -> Onkyo TXNR686 -> Celestion F20s
    Office Joggler & Pi3 -> Denon RCD N8 -> Celestion F10s
    Dining Room SB Boom
    Kitchen UE Radio (upgraded to SB Radio)
    Bedroom (Bedside) Pi Zero+DAC ->ToppingTP21 ->AKG Headphones
    Bedroom (TV) & Bathroom SB Touch ->Denon AVR ->Mordaunt Short M10s + Kef ceiling speakers
    Guest Room Joggler > Topping Amp -> Wharfedale Modus Cubes
    Everything controlled by iPeng & Material on iOS

  2. #22
    Senior Member chill's Avatar
    Join Date
    Mar 2007
    Location
    Nottingham, UK
    Posts
    2,098
    Quote Originally Posted by d6jg View Post
    I thought your install was some Linux or other with Jivelite and an instance of Squeezelite? It should not need the EDO plugin should it? It should just need to properly detect the capability of the USB DAC (kernel) and setup Squeezelite accordingly - or am I being thick?
    Your install is effectively the same as a basic pCP with screen but instead on an old Joggler
    Yes, it is just Ubuntu (with patches to suit the Joggler hardware - but they were in the base image that I started with) with Jivelite and Squeezelite. So I think you're right about it only needing Squeezelite configuration.

  3. #23
    Senior Member Heuer's Avatar
    Join Date
    Nov 2005
    Location
    Nottinghamshire
    Posts
    758
    So as my Topping E30 DAC only played 96khz tracks at 48khz does that mean I need to try the various 'Select Output Device' options to find one that delivers the true resolution or do I need to configure the Squeezelite?
    Lounge: Transporter>Audio Synthesis DAX Decade>Audio Research LS22>Krell FPB300>Wilson Benesch Act 1's + 2 x Velodyne SPL1000 sub's
    Kitchen: SB3>Topping DAC>Arcam Solo>Anthony Gallo Micro's+Sub, Joggler controller
    Office: DAC32>Acoustic Energy AE1 Active's, Joggler controller
    Garage: Boom>QAcoustics 7000s subwoofer
    Bedroom: Radio
    Shed: Radio
    Workshop: Boom
    Garden 1: SB3>JVC amp>Rock outdoor speakers
    Garden 2: SB3>JVC amp>Rock outdoor speakers

  4. #24
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    6,771
    Quote Originally Posted by Heuer View Post
    So as my Topping E30 DAC only played 96khz tracks at 48khz does that mean I need to try the various 'Select Output Device' options to find one that delivers the true resolution or do I need to configure the Squeezelite?
    Which output device have you selected? In pCP I choose hw:CARD=E30,DEV=0

    Sent from my Pixel 3a using Tapatalk

  5. #25
    Senior Member Heuer's Avatar
    Join Date
    Nov 2005
    Location
    Nottinghamshire
    Posts
    758
    Will need to check but I think it was the first on the list which had E30 in it.
    Lounge: Transporter>Audio Synthesis DAX Decade>Audio Research LS22>Krell FPB300>Wilson Benesch Act 1's + 2 x Velodyne SPL1000 sub's
    Kitchen: SB3>Topping DAC>Arcam Solo>Anthony Gallo Micro's+Sub, Joggler controller
    Office: DAC32>Acoustic Energy AE1 Active's, Joggler controller
    Garage: Boom>QAcoustics 7000s subwoofer
    Bedroom: Radio
    Shed: Radio
    Workshop: Boom
    Garden 1: SB3>JVC amp>Rock outdoor speakers
    Garden 2: SB3>JVC amp>Rock outdoor speakers

  6. #26
    Senior Member
    Join Date
    Feb 2011
    Location
    Cheshire, UK
    Posts
    5,766
    I think you also need to look at the command that runs Squeezelite and the parameters being passed to it.

    https://ralph-irving.github.io/squeezelite.html
    Last edited by d6jg; 2021-04-02 at 06:22.

  7. #27
    Senior Member Heuer's Avatar
    Join Date
    Nov 2005
    Location
    Nottinghamshire
    Posts
    758
    I am using the hw:CARD=E30,DEV=0 option.

    No sound on any frequency sample but the E30 does show the sample rate divided by 2. So the Mother Earth stream is 192khz but the Topping shows 96khz; the BluesFlac stream is 96khz and the E30 shows 48khz, both the same as the SB3 via S/PIDF into the DAC. I tried all the other USB device settings. Need to do more investigating!


    This is what my asound.conf looks like:
    Last edited by Heuer; 2021-04-02 at 08:27.
    Lounge: Transporter>Audio Synthesis DAX Decade>Audio Research LS22>Krell FPB300>Wilson Benesch Act 1's + 2 x Velodyne SPL1000 sub's
    Kitchen: SB3>Topping DAC>Arcam Solo>Anthony Gallo Micro's+Sub, Joggler controller
    Office: DAC32>Acoustic Energy AE1 Active's, Joggler controller
    Garage: Boom>QAcoustics 7000s subwoofer
    Bedroom: Radio
    Shed: Radio
    Workshop: Boom
    Garden 1: SB3>JVC amp>Rock outdoor speakers
    Garden 2: SB3>JVC amp>Rock outdoor speakers

  8. #28
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    6,771
    Quote Originally Posted by Heuer View Post
    I am using the hw:CARD=E30,DEV=0 option.

    No sound on any frequency sample but the E30 does show the sample rate divided by 2. So the Mother Earth stream is 192khz but the Topping shows 96khz; the BluesFlac stream is 96khz and the E30 shows 48khz, both the same as the SB3 via S/PIDF into the DAC. I tried all the other USB device settings. Need to do more investigating!
    I thought Mother Earth was 96kHz.

    Sent from my Pixel 3a using Tapatalk

  9. #29
    Senior Member Heuer's Avatar
    Join Date
    Nov 2005
    Location
    Nottinghamshire
    Posts
    758
    Sorry, yes 96khz - getting confused.

    So the E30 is displaying the correct sample rate but no sound from USB but sound working with SB3 S/PIDF. When I switch to the Joggler internal speaker I get sound.

    E30 is showing the correct sample rates for 44.1, 48, 96 and 192khz files.
    Last edited by Heuer; 2021-04-02 at 08:53.
    Lounge: Transporter>Audio Synthesis DAX Decade>Audio Research LS22>Krell FPB300>Wilson Benesch Act 1's + 2 x Velodyne SPL1000 sub's
    Kitchen: SB3>Topping DAC>Arcam Solo>Anthony Gallo Micro's+Sub, Joggler controller
    Office: DAC32>Acoustic Energy AE1 Active's, Joggler controller
    Garage: Boom>QAcoustics 7000s subwoofer
    Bedroom: Radio
    Shed: Radio
    Workshop: Boom
    Garden 1: SB3>JVC amp>Rock outdoor speakers
    Garden 2: SB3>JVC amp>Rock outdoor speakers

  10. #30
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    6,771
    Quote Originally Posted by Heuer View Post
    Sorry, yes 96khz - getting confused.

    So the E30 is displaying the correct sample rate but no sound from USB but working with SB3 S/PIDF.
    Are you using LMS 8.2? There was a change to convert.conf to allow OGG FLAC streams to be downsampled for playback on players which were limited to 48kHz. This would apply to SB3 as well though.

    Sent from my Pixel 3a using Tapatalk

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •