Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 4 of 4
  1. #1
    Junior Member
    Join Date
    Mar 2021

    New life into an old smart radio

    Hey there fellow squeezeboxers. I had a feeling a forum like this must exist, and I finally found it!

    I have a UE Smart Radio and as with many of you, its slowly worked less and less over the years, then I found iPeng, but now it has problems staying connected to the internet and needs a full system reset to give me a few mins listening time. I'm ready to call it quits, but then thought there might be someone who, like with iPeng, has some kind of custom firmware update I could install on my device to make it work like new again. I have tried to find such a hold grail on this forum but was quickly overwhelmed. Does it exist?

    So i'm admittedly a newbie, and not so well informed but can anyone direct me to a place/guide where i can read some instructions of how I can return life to my device (if this exists).

  2. #2
    Senior Member
    Join Date
    Apr 2005
    You might be in luck - but it depends on why your device is failing.

    If it is a hardware problem then ... new firmware (etc) probably will not fix it.

    However, if you convert it from a UE Smart Radio to a Squeezebox Radio (see https://forums.slimdevices.com/showt...-upgradability ) AND you run Logitech Media Server (LMS) on your home network then you have the possibility of playing many more stations, services and even local media.

    Also - there is a community built firmware for the Radio. Most of it is the same as Logitech released but there are some bug fixes and the possibility of more in the future.
    Paul Webster
    Author of "Now Playing" plugins covering Radio France (FIP etc), PlanetRadio (Bauer - Kiss, Absolute, Scala, JazzFM etc), KCRW, Supla Finland, ABC Australia, CBC/Radio-Canada and RTE Ireland

  3. #3
    Senior Member
    Join Date
    Nov 2012
    Southern California
    Quote Originally Posted by emjayteef View Post

    I have a UE Smart Radio and as with many of you, its slowly worked less and less over the years, then I found iPeng, but now it has problems staying connected to the internet and needs a full system reset to give me a few mins listening time.
    If your Radio is connected by Wifi, but gets the red symbol and loses connection, but is restored by turning it off and back on again so it reboots, then the problem might be caused by interference with your Wifi, or a neighbors Wifi. See the threads in the Radio forum. It appears the new mesh networks is incompatible with the Radio's Wifi. Unfortunately, the Squeezebox Community Firmware will not fix the problem. However, others are working on a possible fix. I suffer from the interference problem on some of my Radios. For me, the problem is location specific as one location a Radio will not have the problem, but another Radio which as 100% signal strength to my router has the problem.

    A test to determine if the Wifi is the problem is to connect the Radio with an ethernet cable to your router. If it works without a problem, that is a sign it is the wifi interference problem. The only solution for now is to use a Wifi to Ethernet bridge which plugs into the ethernet connection on the radio. I am using a TP-Link N300 travel router in client mode; it is easy to set up. Others have used a Vonets VAP11G-300, but I had difficultly setting it up. The Vonets is rated up to 15 volts, but Radio's power supply is 18 volts; however many people use the Vonets without a problem.

    Most of the people on this forum with Radios use the Squeezebox (SB) Radio, as opposed to the UE Smart Radio. The difference is a SB Radio can use either MySequeezebox.com or Logitech Media Server (LMS). If you run LMS you can play music on your computer. There is more community development of LMS and options with a SB Radio than the UE Smart Radio. It is possible to convert the UE Radio to an SB Radio.

    Good luck!


  4. #4
    Senior Member
    Join Date
    Feb 2010

    Just got a VONETS

    My SB Radio (an upgraded UE) has gone from having the red WiFi icon three or so times a week, to every morning and every evening for the most recent couple of weeks.

    The Network reconnect spinner and reconnect options show it is still connected to my network, but fails at the sb.com step. I have had the same router for years, now. I do not use LMS. Only a full reboot seems to be resetting it.

    I just took delivery of the VONETS VAP11G-300. I got it set up and it's running at the SB Radio. After the setup through my laptop, I could not log back into it after its reboot. It has a hard reset button, so as long as it is working now, I might never need to admin it, again, anyway.

    I'll let you know if it fails with the new setup. This is a $25 fix, so wish me luck.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts