Hello all,
There might be a better way to do this but I thought I'd share my quick fix for getting my USB DAC working.

After setting audio output to USB instead of loggin in over SSH and setting things up with ALSA as suggested I did something else. I disabled onboard audio and one reboot later there was sweet music .

Take care!