Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 2 of 2
  1. #1
    Junior Member
    Join Date
    Mar 2021
    Posts
    1

    Forcing UTF-8 on Windows LMS 8.x.x

    Regards.

    Having realized that my Windows 10 (x86) LMS server does not scan my media files with accented letters in their paths, I have changed the default windows codepage to CP1250, reinstalled LMS 8.2.0 and re-scanned the whole library. This made all my files detectable to LMS.

    Still, there are some strange path listings like for example (with wrong path letters in red):

    Location: L:\MEDiA\MUSiC\LiBRARY\Arsen Dedi─ç\(2006) The Platinum Collection\32) Ĺ˝ivot se troši kao kreda.m4a

    Just then I have realized (found similar thread on this forum) that Windows LMS can run in UTF-8 mode with

    "C:\Program Files\Squeezebox\server\SqueezeSvr.exe" --charset=utf8

    which would solve all my related LMS problems from the very start and also displays correctly all accented paths within LMS.

    Therefore I have decided to run LMS in UTF-8.

    But now I have a different problem: After each restart of my Windows LMS machine, LMS automatically starts in CP1250 by SqueezeTray.exe. To go back to UTF-8, I have to stop LMS and manually restart with aforementioned charset option.

    I know that a solution would be to disable "Automatically run at login" SqueezeTray option and create my own run-at-login OS entry with desired --charset=utf8 option, but there surely must be a LMS configuration option somewhere (C:\ProgramData\Squeezebox\prefs\server.prefs maybe?) which would force Windows LMS to run in UTF-8 charset.

    So my questions are - is there such an option, and if there is - what is this option?

    Thanks in advance for your help.

  2. #2
    Senior Member
    Join Date
    Jan 2010
    Posts
    752
    See here.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •