Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1

    Squeezeboxserver on CentOS v7/8 x86_64

    Hi,

    Has anyone managed to get Squeezeboxserver running on CentOS v7 or 8 x84_64?

    In my experience CentOS 7/8 expects /usr/lib/perl5/vendor_perl/Slim in /usr/lib64/perl5/vendor_perl. But even after creating a symbolic link I have issues. Has anyone solved this?

    Regards, Johan

  2. #2
    Senior Member Jeff07971's Avatar
    Join Date
    Aug 2011
    Location
    London, England
    Posts
    1,637
    Quote Originally Posted by Johan S View Post
    Hi,

    Has anyone managed to get Squeezeboxserver running on CentOS v7 or 8 x84_64?

    In my experience CentOS 7/8 expects /usr/lib/perl5/vendor_perl/Slim in /usr/lib64/perl5/vendor_perl. But even after creating a symbolic link I have issues. Has anyone solved this?

    Regards, Johan
    Yes, no problems I have spun up many CentOS 8 LMS servers and in fact have today while experimenting with AlmaLinux 8 RC1

    Installed and added the symlink, all worked fine

    Code:
    sudo ln -s /usr/lib/perl5/vendor_perl/Slim /usr/lib64/perl5/Slim
    Jeff
    Last edited by Jeff07971; 2021-03-20 at 12:23. Reason: corrected syntax

    Want a webapp ? Get SqueezeLite-X ! https://forums.slimdevices.com/showt...l=1#post903953

  3. #3
    Quote Originally Posted by Jeff07971 View Post
    No, no problems I have spun up many CentOS LMS servers and in fact have today while experimenting with AlmaLinux 8 RC1

    Installed and added the symlink, all worked fine

    Code:
    sudo ln -s /usr/lib/perl5/vendor_perl/Slim /usr/lib64/perl5/Slim
    Jeff
    Thanks. Which version of LMS do you use?

  4. #4
    Senior Member Jeff07971's Avatar
    Join Date
    Aug 2011
    Location
    London, England
    Posts
    1,637
    Quote Originally Posted by Johan S View Post
    Thanks. Which version of LMS do you use?
    I get latest nightly with a script

    Code:
    Latest_LMS_Downloads=$(wget -q -O - http://downloads.slimdevices.com/releases/nightly/stable.xml)
    Latest_LMS_RPM=$(echo $Latest_LMS_Downloads | sed 's/>/>\n/g' | grep rpm)
    Latest_URL=$(echo $Latest_LMS_RPM | awk -F '"' {'print $4'})
    dnf -y install $Latest_URL
    Jeff

    Want a webapp ? Get SqueezeLite-X ! https://forums.slimdevices.com/showt...l=1#post903953

  5. #5
    Senior Member
    Join Date
    Feb 2011
    Location
    Cheshire, UK
    Posts
    5,789
    Iíve also run successfully on Centos 7 and 8 and the only issue Iíve come across is the need to symlink the Perl library
    VB2.4 storage QNAP TS419p (NFS)
    Living Room Joggler & Pi4/Khadas -> Onkyo TXNR686 -> Celestion F20s
    Office Joggler & Pi3 -> Denon RCD N8 -> Celestion F10s
    Dining Room SB Boom
    Kitchen UE Radio (upgraded to SB Radio)
    Bedroom (Bedside) Pi Zero+DAC ->ToppingTP21 ->AKG Headphones
    Bedroom (TV) & Bathroom SB Touch ->Denon AVR ->Mordaunt Short M10s + Kef ceiling speakers
    Guest Room Joggler > Topping Amp -> Wharfedale Modus Cubes
    Everything controlled by iPeng & Material on iOS

  6. #6
    Quote Originally Posted by d6jg View Post
    Iíve also run successfully on Centos 7 and 8 and the only issue Iíve come across is the need to symlink the Perl library
    I got it running, I needed to manually install perl-Digest-MD5, I guess I had installed a too slim server.

    Though when I connected to LMS I got a 403 error because the access to the settings page was protected. Have you ever had that?

    Regards, Johan

  7. #7
    Senior Member Jeff07971's Avatar
    Join Date
    Aug 2011
    Location
    London, England
    Posts
    1,637
    Quote Originally Posted by Johan S View Post
    I got it running, I needed to manually install perl-Digest-MD5, I guess I had installed a too slim server.

    Though when I connected to LMS I got a 403 error because the access to the settings page was protected. Have you ever had that?

    Regards, Johan
    From memory I don't think I've ever seen 40x responses from my server on port 9000.

    I've no connections due to firewalld being enabled by default on Centos8

    Jeff

    Want a webapp ? Get SqueezeLite-X ! https://forums.slimdevices.com/showt...l=1#post903953

  8. #8
    Quote Originally Posted by Jeff07971 View Post
    From memory I don't think I've ever seen 40x responses from my server on port 9000.

    I've no connections due to firewalld being enabled by default on Centos8

    Jeff
    For some reason the server came up with the setting

    protectSettings: 1

    in server prefs. I still haven't understood why. I am testing on a CentOS v7 running as a VM under Hyper-V. Doing exactly the same installation on openSUSE 15.2 does not show the same behaviour.

    Regards, Johan

  9. #9
    Senior Member Jeff07971's Avatar
    Join Date
    Aug 2011
    Location
    London, England
    Posts
    1,637
    Quote Originally Posted by Johan S View Post
    For some reason the server came up with the setting

    protectSettings: 1

    in server prefs. I still haven't understood why. I am testing on a CentOS v7 running as a VM under Hyper-V. Doing exactly the same installation on openSUSE 15.2 does not show the same behaviour.

    Regards, Johan
    Can't really help on this one I always use Centos8 VMs on ESXi

    Jeff

    Want a webapp ? Get SqueezeLite-X ! https://forums.slimdevices.com/showt...l=1#post903953

  10. #10
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,543

    Squeezeboxserver on CentOS v7/8 x86_64

    > For some reason the server came up with the setting
    >
    > protectSettings: 1


    Are you NATing traffic from outside the VM? LMS doesn't like to be
    accessed from another network.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •