Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 2 12 LastLast
Results 1 to 10 of 13
  1. #1
    Junior Member
    Join Date
    Apr 2020
    Location
    Switzerland
    Posts
    10

    Installation LMS 8.1.2 auf einem HC2 mit armbian

    Hallo zusammen

    Ich habe heute leider erfolglos versucht den LMS 8.1.2 auf einem HC2 (https://www.hardkernel.com/shop/odro...ome-cloud-two/) mit Armbian Focal (https://www.armbian.com/odroid-hc1/) zu installieren.

    Ich habe für die Installation das Paket "logitechmediaserver_8.1.2~1614990085_arm.deb" verwendet. Die Installation läuft ohne Fehler durch. Aber der Server lässt sich nicht starten. Das /var/log/squeezeboxserver/server.log sagt:

    Code:
    2021-03-16 18:36:13 Logitech Media Server died. Restarting.
    2021-03-16 18:36:18 Logitech Media Server died. Restarting.
    2021-03-16 18:36:23 Logitech Media Server died. Restarting.
    etc.
    perl -v sagt:
    Code:
    This is perl 5, version 30, subversion 0 (v5.30.0) built for arm-linux-gnueabihf-thread-multi-64int
    (with 50 registered patches, see perl -V for more detail)
    
    etc.
    Und wenn ich den Server mit sudo /usr/sbin/squeezeboxserver --d_startup starte (Achtung, habe das Log gekürzt, weil es die Max-Länge des Forums überschreitet):
    Code:
    ound SELinux - setting security context to: texrel_shlib_t for *.so files.
    Got @INC containing:
    /usr/share/squeezeboxserver/CPAN
    /usr/share/squeezeboxserver
    /usr/sbin
    /etc/perl
    /usr/local/lib/arm-linux-gnueabihf/perl/5.30.0
    /usr/local/share/perl/5.30.0
    /usr/lib/arm-linux-gnueabihf/perl5/5.30
    /usr/share/perl5
    /usr/lib/arm-linux-gnueabihf/perl/5.30
    /usr/share/perl/5.30
    /usr/local/lib/site_perl
    /usr/lib/arm-linux-gnueabihf/perl-base
    
    Extended @INC to contain:
    /usr/share/squeezeboxserver/CPAN/arch/5.30/arm-linux-gnueabihf-thread-multi-64int
    /usr/share/squeezeboxserver/CPAN/arch/5.30/arm-linux-gnueabihf-thread-multi-64int/auto
    /usr/share/squeezeboxserver/CPAN/arch/5.30.0/arm-linux-gnueabihf-thread-multi-64int
    /usr/share/squeezeboxserver/CPAN/arch/5.30.0/arm-linux-gnueabihf-thread-multi-64int/auto
    /usr/share/squeezeboxserver/CPAN/arch/5.30/arm-linux-gnueabihf-thread-multi-64int
    /usr/share/squeezeboxserver/CPAN/arch/5.30/arm-linux-gnueabihf-thread-multi-64int/auto
    /usr/share/squeezeboxserver/CPAN/arch/arm-linux-gnueabihf-thread-multi-64int
    /usr/share/squeezeboxserver/CPAN/arch/5.30
    /usr/share/squeezeboxserver/lib
    /usr/share/squeezeboxserver/CPAN
    /usr/share/squeezeboxserver
    /usr/share/squeezeboxserver/CPAN
    /usr/share/squeezeboxserver
    /usr/sbin
    /etc/perl
    /usr/local/lib/arm-linux-gnueabihf/perl/5.30.0
    /usr/local/share/perl/5.30.0
    /usr/lib/arm-linux-gnueabihf/perl5/5.30
    /usr/share/perl5
    /usr/lib/arm-linux-gnueabihf/perl/5.30
    /usr/share/perl/5.30
    /usr/local/lib/site_perl
    /usr/lib/arm-linux-gnueabihf/perl-base
    
    Loaded module: [version] ok!
    Loaded module: [Time::HiRes] ok!
    Module [DBI] failed to load:
    Can't locate loadable object for module DBI in @INC (@INC contains: /usr/share/squeezeboxserver/CPAN/arch/5.30/arm-linux-gnueabihf-thread-multi-64int /usr/share/squeezeboxserver/CPAN/arch/5.30/arm-linux-gnueabihf-thread-multi-64int/auto /usr/share/squeezeboxserver/CPAN/arch/5.30.0/arm-linux-gnueabihf-thread-multi-64int /usr/share/squeezeboxserver/CPAN/arch/5.30.0/arm-linux-gnueabihf-thread-multi-64int/auto /usr/share/squeezeboxserver/CPAN/arch/5.30/arm-linux-gnueabihf-thread-multi-64int /usr/share/squeezeboxserver/CPAN/arch/5.30/arm-linux-gnueabihf-thread-multi-64int/auto /usr/share/squeezeboxserver/CPAN/arch/arm-linux-gnueabihf-thread-multi-64int /usr/share/squeezeboxserver/CPAN/arch/5.30 /usr/share/squeezeboxserver/lib /usr/share/squeezeboxserver/CPAN /usr/share/squeezeboxserver /usr/share/squeezeboxserver/CPAN /usr/share/squeezeboxserver /usr/sbin /etc/perl /usr/local/lib/arm-linux-gnueabihf/perl/5.30.0 /usr/local/share/perl/5.30.0 /usr/lib/arm-linux-gnueabihf/perl5/5.30 /usr/share/perl5 /usr/lib/arm-linux-gnueabihf/perl/5.30 /usr/share/perl/5.30 /usr/local/lib/site_perl /usr/lib/arm-linux-gnueabihf/perl-base) at /usr/share/squeezeboxserver/CPAN/arch/5.30/DBI.pm line 277.
    BEGIN failed--compilation aborted at /usr/share/squeezeboxserver/CPAN/arch/5.30/DBI.pm line 277.
    Compilation failed in require at (eval 12) line 1.
    BEGIN failed--compilation aborted at (eval 12) line 1.
    .
    .
    .
    Removing [Sub::Name] from the symbol table - load failed.
    The following modules are loaded after the first attempt:
    	Carp.pm => /usr/share/perl/5.30/Carp.pm
    	Tie/Hash.pm => /usr/share/perl/5.30/Tie/Hash.pm
    	POSIX.pm => /usr/lib/arm-linux-gnueabihf/perl/5.30/POSIX.pm
    	XSLoader.pm => /usr/share/perl/5.30/XSLoader.pm
    	overload.pm => /usr/share/perl/5.30/overload.pm
    	Cwd.pm => /usr/lib/arm-linux-gnueabihf/perl/5.30/Cwd.pm
    	version.pm => /usr/share/squeezeboxserver/CPAN/version.pm
    	YAML/XS/LibYAML.pm => 
    	Time/HiRes.pm => /usr/lib/arm-linux-gnueabihf/perl/5.30/Time/HiRes.pm
    	vars.pm => /usr/share/perl/5.30/vars.pm
    	lib.pm => /usr/lib/arm-linux-gnueabihf/perl/5.30/lib.pm
    	Slim/Utils/OS.pm => /usr/share/perl5/Slim/Utils/OS.pm
    	Slim/Utils/OS/Unix.pm => /usr/share/perl5/Slim/Utils/OS/Unix.pm
    	Slim/bootstrap.pm => /usr/share/perl5/Slim/bootstrap.pm
    	Exporter.pm => /usr/share/perl/5.30/Exporter.pm
    	constant.pm => /usr/share/perl/5.30/constant.pm
    	warnings/register.pm => /usr/share/perl/5.30/warnings/register.pm
    	Getopt/Long.pm => /usr/share/perl/5.30/Getopt/Long.pm
    	File/Basename.pm => /usr/share/perl/5.30/File/Basename.pm
    	overloading.pm => /usr/share/perl/5.30/overloading.pm
    	locale.pm => /usr/share/perl/5.30/locale.pm
    	Slim/Utils/OSDetect.pm => /usr/share/perl5/Slim/Utils/OSDetect.pm
    	Exporter/Heavy.pm => /usr/share/perl/5.30/Exporter/Heavy.pm
    	File/Spec/Unix.pm => /usr/lib/arm-linux-gnueabihf/perl/5.30/File/Spec/Unix.pm
    	File/Path.pm => /usr/share/perl/5.30/File/Path.pm
    	Symbol.pm => /usr/share/perl/5.30/Symbol.pm
    	Fcntl.pm => /usr/lib/arm-linux-gnueabihf/perl/5.30/Fcntl.pm
    	strict.pm => /usr/share/perl/5.30/strict.pm
    	DynaLoader.pm => /usr/lib/arm-linux-gnueabihf/perl/5.30/DynaLoader.pm
    	if.pm => /usr/share/perl/5.30/if.pm
    	File/Spec.pm => /usr/lib/arm-linux-gnueabihf/perl/5.30/File/Spec.pm
    	Config_heavy.pl => /usr/lib/arm-linux-gnueabihf/perl/5.30/Config_heavy.pl
    	Slim/Utils/OS/Debian.pm => /usr/share/perl5/Slim/Utils/OS/Debian.pm
    	version/regex.pm => /usr/share/squeezeboxserver/CPAN/version/regex.pm
    	Slim/Utils/OS/Linux.pm => /usr/share/perl5/Slim/Utils/OS/Linux.pm
    	FindBin.pm => /usr/share/perl/5.30/FindBin.pm
    	Config_git.pl => /usr/lib/arm-linux-gnueabihf/perl/5.30/Config_git.pl
    	version/vpp.pm => /usr/share/squeezeboxserver/CPAN/version/vpp.pm
    	base.pm => /usr/share/perl/5.30/base.pm
    	Config.pm => /usr/lib/arm-linux-gnueabihf/perl/5.30/Config.pm
    	File/Spec/Functions.pm => /usr/lib/arm-linux-gnueabihf/perl/5.30/File/Spec/Functions.pm
    	warnings.pm => /usr/share/perl/5.30/warnings.pm
    .
    .
    .
    
    etc.
    Ich habe spasseshalber auch mal versucht ältere LMS Versionen (7.9.3 und 8.0.0) zu installieren. Aber die laufen auch nicht.

    Hat mir jemand einen Tip woran das liegen kann?

  2. #2
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,536
    Tschou Bärengraben :-)

    Quote Originally Posted by baerengraben View Post
    Und wenn ich den Server mit sudo /usr/sbin/squeezeboxserver --d_startup starte (Achtung, habe das Log gekürzt, weil es die Max-Länge des Forums überschreitet):
    Die Antwort liegt ganz am Schluss des Logs, im Teil, den du weggelassen hast: LMS hat keine Binaries für deine Perl Version auf ARM. Du musst wohl selber kompilieren (falls du nicht auf ein anderes, unterstütztes Linux umsteigen willst). Instruktionen finden sich eben da, am Schluss des Logs.
    Michael

    "It doesn't work - what shall I do?" - "Please check your server.log and/or scanner.log file!"
    (LMS: Settings/Information)

  3. #3
    Junior Member
    Join Date
    Apr 2020
    Location
    Switzerland
    Posts
    10
    Quote Originally Posted by mherger View Post
    Tschou Bärengraben :-)



    Die Antwort liegt ganz am Schluss des Logs, im Teil, den du weggelassen hast: LMS hat keine Binaries für deine Perl Version auf ARM. Du musst wohl selber kompilieren (falls du nicht auf ein anderes, unterstütztes Linux umsteigen willst). Instruktionen finden sich eben da, am Schluss des Logs.
    Tschou Michael

    Anbei noch der Schluss des Logs

    Code:
    The following modules failed to load: DBI EV XML::Parser::Expat HTML::Parser JSON::XS Digest::SHA1 YAML::XS Sub::Name
    
    
    This is perl 5, version 30, subversion 0 (v5.30.0) built for arm-linux-gnueabihf-thread-multi-64int
    (with 50 registered patches, see perl -V for more detail)
    
    Copyright 1987-2019, Larry Wall
    
    Perl may be copied only under the terms of either the Artistic License or the
    GNU General Public License, which may be found in the Perl 5 source kit.
    
    Complete documentation for Perl, including FAQ lists, should be found on
    this system using "man perl" or "perldoc perl".  If you have access to the
    Internet, point your browser at http://www.perl.org/, the Perl Home Page.
    
    
    *******
    
    NOTE:
    
    If you're running some unsupported Linux/Unix platform, please use the buildme.sh
    script located here:
    
    https://github.com/Logitech/slimserver-vendor/tree/public/8.1/CPAN
    
    If 8.1 is outdated by the time you read this, Replace "8.1" with the major version
    You should never need to do this if you're on Windows or Mac OSX. If the installers
    don't work for you, ask for help and/or report a bug.
    
    *******
    
    			
    Exiting
    Gesehen habe ich diese Meldung, aber der Link https://github.com/Logitech/slimserv...ublic/8.1/CPAN führt ins leere.

    Ok. Sinnigerweise wäre es wohl am besten ein OS zu verwenden, welches mit LMS "out of the box" kompatibel ist. Das aktuellste Armbian Focal ist es wohl nicht. Der HC2 hat einen 32Bit Prozi - Leider keine 64Bit. Was würdest du als OS empfehlen?
    Last edited by baerengraben; 2021-03-17 at 04:20.

  4. #4
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,536

    Installation LMS 8.1.2 auf einem HC2 mit armbian

    > Ok, der erste Versuch wäre es in diesem Falle auf ein anderes,
    > unterstütztes Linux umzusteigen. Der HC2 hat einen 32Bit Prozi - Leider
    > keine 64Bit.


    Hast du versucht, die Module zu kompilieren? Ist üblicherweise kein
    grosses Ding. Braucht etwas Zeit, sollte aber theoretisch automatisch
    durchlaufen.

  5. #5
    Junior Member
    Join Date
    Apr 2020
    Location
    Switzerland
    Posts
    10
    Quote Originally Posted by mherger View Post
    > Ok, der erste Versuch wäre es in diesem Falle auf ein anderes,
    > unterstütztes Linux umzusteigen. Der HC2 hat einen 32Bit Prozi - Leider
    > keine 64Bit.


    Hast du versucht, die Module zu kompilieren? Ist üblicherweise kein
    grosses Ding. Braucht etwas Zeit, sollte aber theoretisch automatisch
    durchlaufen.
    Du meinst diese hier?
    Code:
    DBI EV XML::Parser::Expat HTML::Parser JSON::XS Digest::SHA1 YAML::XS Sub::Name
    Kann ich mal ausprobieren. Da ich kein Perl-Spezi bin: Gibt's irgendwo ein Howto?

  6. #6
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,536

    Installation LMS 8.1.2 auf einem HC2 mit armbian

    > Kann ich mal ausprobieren. Da ich kein Perl-Spezi bin: Gibt's irgendwo
    > ein Howto?


    https://github.com/Logitech/slimserv...ublic/8.0/CPAN
    herunterladen. "buildme.sh" ausführen. Die README hat etwas mehr Infos:

    https://github.com/Logitech/slimserv...CPAN/README.md

  7. #7
    Junior Member
    Join Date
    Apr 2020
    Location
    Switzerland
    Posts
    10
    Quote Originally Posted by mherger View Post
    > Kann ich mal ausprobieren. Da ich kein Perl-Spezi bin: Gibt's irgendwo
    > ein Howto?


    https://github.com/Logitech/slimserv...ublic/8.0/CPAN
    herunterladen. "buildme.sh" ausführen. Die README hat etwas mehr Infos:

    https://github.com/Logitech/slimserv...CPAN/README.md
    Vielen Dank für die Links. Habe den compile wie beschrieben durchgeführt. Ein bisschen weiter sind wir. Jetzt meldet das Server-Log folgendes:

    Code:
    2021-03-17 21:51:51 squeezeboxserver_safe started.
    [21-03-17 21:51:52.8187] main::init (389) Starting Logitech Media Server (v8.1.2, 1614990085, Sat Mar  6 02:37:31 CET 2021) perl 5.030000 - arm-linux-gnueabihf-thread-multi-64int
    [21-03-17 21:51:54.0721] Slim::Utils::SQLiteHelper::postConnect (377) Optimizing DB because of missing or empty sqlite_stat1 table
    [21-03-17 21:51:54.1251] Slim::Schema::forceCommit (2171) Warning: Trying to commit transactions before DB is initialized!
    [21-03-17 21:51:54.2575] Slim::bootstrap::tryModuleLoad (286) Warning: Module [Template::Stash::XS] failed to load:
    Couldn't load Template::Stash::XS 2.21:
    
    Can't locate loadable object for module Template::Stash::XS in @INC (@INC contains: /var/lib/squeezeboxserver/cache/InstalledPlugins /usr/share/squeezeboxserver/CPAN/arch/5.30/arm-linux-gnueabihf-thread-multi-64int /usr/share/squeezeboxserver/CPAN/arch/5.30/arm-linux-gnueabihf-thread-multi-64int/auto /usr/share/squeezeboxserver/CPAN/arch/5.30.0/arm-linux-gnueabihf-thread-multi-64int /usr/share/squeezeboxserver/CPAN/arch/5.30.0/arm-linux-gnueabihf-thread-multi-64int/auto /usr/share/squeezeboxserver/CPAN/arch/5.30/arm-linux-gnueabihf-thread-multi-64int /usr/share/squeezeboxserver/CPAN/arch/5.30/arm-linux-gnueabihf-thread-multi-64int/auto /usr/share/squeezeboxserver/CPAN/arch/arm-linux-gnueabihf-thread-multi-64int /usr/share/squeezeboxserver/CPAN/arch/5.30 /usr/share/squeezeboxserver/lib /usr/share/squeezeboxserver/CPAN /usr/share/squeezeboxserver /usr/share/squeezeboxserver/CPAN /usr/share/squeezeboxserver /usr/sbin /etc/perl /usr/local/lib/arm-linux-gnueabihf/perl/5.30.0 /usr/local/share/perl/5.30.0 /usr/lib/arm-linux-gnueabihf/perl5/5.30 /usr/share/perl5 /usr/lib/arm-linux-gnueabihf/perl/5.30 /usr/share/perl/5.30 /usr/local/lib/site_perl /usr/lib/arm-linux-gnueabihf/perl-base) at /usr/share/squeezeboxserver/CPAN/Template/Stash/XS.pm line 31.
    
    BEGIN failed--compilation aborted at /usr/share/squeezeboxserver/CPAN/Template/Stash/XS.pm line 31.
    Compilation failed in require at (eval 744) line 1.
    BEGIN failed--compilation aborted at (eval 744) line 1.
    
    [21-03-17 21:51:54.7475] Slim::Utils::SQLiteHelper::postConnect (377) Optimizing DB because of missing or empty sqlite_stat1 table
    [21-03-17 21:51:54.8008] Slim::Schema::forceCommit (2171) Warning: Trying to commit transactions before DB is initialized!
    [21-03-17 21:51:55.0373] main::checkDataSource (1113) Warning: Schema updated or no media found in the database, initiating scan.
    [21-03-17 21:51:57.3913] Slim::Utils::SQLiteHelper::postConnect (377) Optimizing DB because of missing or empty sqlite_stat1 table
    [21-03-17 21:51:57.4529] Slim::Schema::forceCommit (2171) Warning: Trying to commit transactions before DB is initialized!
    [21-03-17 21:52:30.3791] Slim::Networking::IO::Select::__ANON__ (130) Error: Select task failed calling Slim::Web::HTTP::processHTTP: Can't call method "context" on an undefined value at /usr/share/perl5/Slim/Web/Template/SkinManager.pm line 360.
    ; fh=Slim::Web::HTTP::ClientConn=GLOB(0x47a53b8)
    [21-03-17 21:53:45.0258] Slim::Networking::IO::Select::__ANON__ (130) Error: Select task failed calling Slim::Web::HTTP::processHTTP: Can't call method "context" on an undefined value at /usr/share/perl5/Slim/Web/Template/SkinManager.pm line 360.
    ; fh=Slim::Web::HTTP::ClientConn=GLOB(0xd164b8)
    Das Webinterface läuft aktuell entsprechend noch nicht.

    Ich habe mal versucht mit
    Code:
    sudo apt install libtemplate-perl
    dieses Template zu installieren. Geht aber auch nicht. Server.log sagt dann:

    Code:
    Template::Stash::XS object version 2.27 does not match bootstrap parameter 2.21 at /usr/lib/arm-linux-gnueabihf/perl/5.30/DynaLoader.pm line 210.
    Es braucht offenbar die Version 2.21, nicht die Version 2.27.

    Hast du mir nochmals einen Tip wie ich das in den Griff bekomme?
    Last edited by baerengraben; 2021-03-17 at 14:28.

  8. #8
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,536

    Installation LMS 8.1.2 auf einem HC2 mit armbian

    > Vielen Dank für die Links. Habe den compile wie beschrieben
    > durchgeführt. Ein bisschen weiter sind wir. Jetzt meldet das Server-Log


    Das sieht schon sehr vielversprechend aus! Wo hast du denn die Dateien
    hinkopiert?

    > [21-03-17 21:51:54.2575] Slim::bootstrap::tryModuleLoad (286) Warning: Module [Template::Stash::XS] failed to load:
    > Couldn't load Template::Stash::XS 2.21:
    >
    > Can't locate loadable object for module Template::Stash::XS in @INC (@INC contains:


    Ok, das ist die Liste der Ordner, in welcher LMS nach diesen Dateien sucht:

    /var/lib/squeezeboxserver/cache/InstalledPlugins
    /usr/share/squeezeboxserver/CPAN/arch/5.30/arm-linux-gnueabihf-thread-multi-64int
    /usr/share/squeezeboxserver/CPAN/arch/5.30/arm-linux-gnueabihf-thread-multi-64int/auto
    /usr/share/squeezeboxserver/CPAN/arch/5.30.0/arm-linux-gnueabihf-thread-multi-64int
    /usr/share/squeezeboxserver/CPAN/arch/5.30.0/arm-linux-gnueabihf-thread-multi-64int/auto
    /usr/share/squeezeboxserver/CPAN/arch/5.30/arm-linux-gnueabihf-thread-multi-64int
    /usr/share/squeezeboxserver/CPAN/arch/5.30/arm-linux-gnueabihf-thread-multi-64int/auto
    /usr/share/squeezeboxserver/CPAN/arch/arm-linux-gnueabihf-thread-multi-64int
    /usr/share/squeezeboxserver/CPAN/arch/5.30
    /usr/share/squeezeboxserver/lib
    /usr/share/squeezeboxserver/CPAN
    /usr/share/squeezeboxserver
    /usr/share/squeezeboxserver/CPAN
    /usr/share/squeezeboxserver
    /usr/sbin
    /etc/perl
    /usr/local/lib/arm-linux-gnueabihf/perl/5.30.0
    /usr/local/share/perl/5.30.0
    /usr/lib/arm-linux-gnueabihf/perl5/5.30
    /usr/share/perl5
    /usr/lib/arm-linux-gnueabihf/perl/5.30
    /usr/share/perl/5.30
    /usr/local/lib/site_perl
    /usr/lib/arm-linux-gnueabihf/perl-base

    kannst du irgendwo da drin eine Stash/XS.so Datei finden? Oder hast du
    beim Kompilieren irgendwelche Fehlermeldungen erhalten?

    > Das Webinterface läuft aktuell entsprechend noch nicht. Hast du mir
    > nochmals einen Tip wie ich das in den Griff bekomme? Liegt es evtl.
    > daran, dass ich das Paket logitechmediaserver_8.1.2~1614990085_arm.deb
    > installiert habe, aber die Perl Binaries aus version 8.0 stammen?


    Nein, nein, das sollte Kein Problem sein.

  9. #9
    Junior Member
    Join Date
    Apr 2020
    Location
    Switzerland
    Posts
    10
    Quote Originally Posted by mherger View Post
    > Vielen Dank für die Links. Habe den compile wie beschrieben
    > durchgeführt. Ein bisschen weiter sind wir. Jetzt meldet das Server-Log


    Das sieht schon sehr vielversprechend aus! Wo hast du denn die Dateien
    hinkopiert?

    > [21-03-17 21:51:54.2575] Slim::bootstrap::tryModuleLoad (286) Warning: Module [Template::Stash::XS] failed to load:
    > Couldn't load Template::Stash::XS 2.21:
    >
    > Can't locate loadable object for module Template::Stash::XS in @INC (@INC contains:


    Ok, das ist die Liste der Ordner, in welcher LMS nach diesen Dateien sucht:

    /var/lib/squeezeboxserver/cache/InstalledPlugins
    /usr/share/squeezeboxserver/CPAN/arch/5.30/arm-linux-gnueabihf-thread-multi-64int
    /usr/share/squeezeboxserver/CPAN/arch/5.30/arm-linux-gnueabihf-thread-multi-64int/auto
    /usr/share/squeezeboxserver/CPAN/arch/5.30.0/arm-linux-gnueabihf-thread-multi-64int
    /usr/share/squeezeboxserver/CPAN/arch/5.30.0/arm-linux-gnueabihf-thread-multi-64int/auto
    /usr/share/squeezeboxserver/CPAN/arch/5.30/arm-linux-gnueabihf-thread-multi-64int
    /usr/share/squeezeboxserver/CPAN/arch/5.30/arm-linux-gnueabihf-thread-multi-64int/auto
    /usr/share/squeezeboxserver/CPAN/arch/arm-linux-gnueabihf-thread-multi-64int
    /usr/share/squeezeboxserver/CPAN/arch/5.30
    /usr/share/squeezeboxserver/lib
    /usr/share/squeezeboxserver/CPAN
    /usr/share/squeezeboxserver
    /usr/share/squeezeboxserver/CPAN
    /usr/share/squeezeboxserver
    /usr/sbin
    /etc/perl
    /usr/local/lib/arm-linux-gnueabihf/perl/5.30.0
    /usr/local/share/perl/5.30.0
    /usr/lib/arm-linux-gnueabihf/perl5/5.30
    /usr/share/perl5
    /usr/lib/arm-linux-gnueabihf/perl/5.30
    /usr/share/perl/5.30
    /usr/local/lib/site_perl
    /usr/lib/arm-linux-gnueabihf/perl-base

    kannst du irgendwo da drin eine Stash/XS.so Datei finden? Oder hast du
    beim Kompilieren irgendwelche Fehlermeldungen erhalten?

    > Das Webinterface läuft aktuell entsprechend noch nicht. Hast du mir
    > nochmals einen Tip wie ich das in den Griff bekomme? Liegt es evtl.
    > daran, dass ich das Paket logitechmediaserver_8.1.2~1614990085_arm.deb
    > installiert habe, aber die Perl Binaries aus version 8.0 stammen?


    Nein, nein, das sollte Kein Problem sein.
    Fehler sind beim compilieren keine geworfen worden.

    Nach dem compilieren habe ich folgenden Kopierbefehl ausgeführt:
    Code:
    sudo cp -r build/arch/5.30/arm-linux-gnueabihf-thread-multi-64int /usr/share/squeezeboxserver/CPAN/arch/5.30/
    Was mir aber jetzt beim studieren des compile-logs aufgefallen ist, dass Stash/XS.so compiliert wird, aber dann nicht in das build-Verzeichnis, sondern nach ~/perl5 kopiert wird. Wie dieses perl5 in mein home-verzeichnis kommt ist mir grad etwas schleierhaft:

    Code:
    .....@odroidxu4:~/perl5$ find . -name XS.so
    ./lib/perl5/arm-linux-gnueabihf-thread-multi-64int/auto/Template/Stash/XS/XS.so
    Was mache ich jetzt am besten mit diesem ~/perl5 Verzeichnis? In mein Home-Ordner gehört das sicher nicht

  10. #10
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,536

    Installation LMS 8.1.2 auf einem HC2 mit armbian

    >> /usr/share/squeezeboxserver/CPAN/arch/5.30/arm-linux-gnueabihf-thread-multi-64int/auto

    > ./lib/perl5/arm-linux-gnueabihf-thread-multi-64int/auto/Template/Stash/XS/XS.so


    > Was mache ich jetzt am besten mit diesem ~/perl5 Verzeichnis? In mein
    > Home-Ordner gehört das sicher nicht


    Hast du da noch mehr drin? Verschiebe alles von

    ../lib/perl5/arm-linux-gnueabihf-thread-multi-64int/auto

    nach

    /usr/share/squeezeboxserver/CPAN/arch/5.30/arm-linux-gnueabihf-thread-multi-64int/auto

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •