Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 2 of 2
  1. #1
    Junior Member
    Join Date
    Mar 2021

    Help with iTunes in Docker on Synology <Solved>

    I've installed LMS in Docker on a Synology RS1221+. I've checked the "Use iTunes" box in the LMS Settings on the iTunes page, but when I attempt to set the "iTunes Music Library.xml Location" and "Tunes Media Folder" media folders I receive the following error messages. The paths are the correct paths. I've also tried without the leading /volume1. I suspect that I need to map those two volumes in the Docker container but I have no idea what to map them to or where to find what to map them to.

    Invalid value "/volume1/ITunes/iTunes/iTunes Library.xml" for xml_file
    Invalid value "/volume1/ITunes/iTunes/iTunes Media" for music_path

    Thanks in advance for your help.
    Last edited by JimH; 2021-03-12 at 21:04. Reason: Marked as solved

  2. #2
    Junior Member
    Join Date
    Mar 2021

    Well duh

    There were a few things that needed to be changed to get the iTunes plugin working. There may be easier/better ways to accomplish this, but this worked for me.

    My environment
    DSM version 6.2.3
    Docker version 19.09.0-0513
    LMS installed from lmscommunity/logitechmediaserver:latest (version 8.1.8)
    iTunes library share located at /volume1/ITunes/iTunes

    User/Security -- LMS was running under a non-existent user id and group id. There were a few steps needed to resolve this.
    1. Created a new group named "SqueezeBox" using the Synology Group screen (Control Panel -> Group -> Create). Gave that group read/write access to the Tunes share that contains the iTunes library/media/etc.
    2. Created a new user named "SqueezeBox" using the Synology Group screen (Control Panel -> User -> Create). Added this user to only the SqueezeBox group.
    3. SSH'ed into the Diskstation and entered the following command in order to display the numeric user id (uid) and group id (gid) for the SqueezeBox entities just created . On my system the uid is 1029 and the gid is 65537.

    Result from command "id SqueezeBox": uid=1029(SqueezeBox) gid=100(users) groups=100(users),65537(SqueezeBox)

    Docker Configuration --
    1. If LMS is running in Docker stop the LMS container.
    2. Edit the LMS container
      1. On the "Volume" tab add two mappings:
        1. Click on Add File, browse to the share containing your iTunes library (.xml file) and select your "iTunes Library.xml" file. In my case that was "/volume1/ITunes/iTunes/iTunes Library.xml". Enter "/xml_file" in the mount point field.
        2. Click on Add Folder, browse to the share containing your iTunes media and select your iTunes Media folder. In my case "/volume1/ITunes/iTunes/iTunes Media". Enter "/music_path" in the mount point field.

      2. On the "Environment" tab
        1. Change the value of PUID to the user id previously retrieved via SSH (1029 in my case).
        2. Change the value of PGID to the group id previously retrieved via SSH (65537 in my case).

    3. Apply the changes.
    4. Start the LMS container.

    LMS Configuration --
    1. On the iTunes tab of the LMS Settings page
      1. Ensure "Use iTunes" is checked
      2. Enter "/xml_file" in the "iTunes Music Library.xml Location" field.
      3. Enter "/music_path" in the "Tunes Media Folder" field
      4. Apply

    2. At this point you may want to delete any duplicate files you put in your /docker/music and docker/playlist folders (assuming all of your music is in your iTunes library). (I had copied a few files there in order to ensure LMS was working properly without the iTunes plugin.)
    3. On the "Basic Settings" tab of the LMS Settings page change the "Rescan Media Library" drop down to "Clear Library and Rescan Everything" and press the Rescan button

    Once the Rescan is finished all of your iTunes media should be in LMS.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts