Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 6 of 6
  1. #1
    Senior Member
    Join Date
    Mar 2011
    Posts
    156

    25% CPU slimserver.pl in 8.2 docker while idle

    As the docker image has no top or htop included, i'm asking here which debug protocol i should enable to find the culprit?
    The "Server information" protocol task doesn't reveal anything special......

  2. #2
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,530

    25% CPU slimserver.pl in 8.2docker while idle

    > As the docker image has no top or htop included, i'm asking here which
    > debug protocol i should enable to find the culprit?
    > The "Server information" protocol task doesn't reveal anything
    > special......


    Disabling plugins is always an option to narrow down the culprit. But as
    you're working on TrackStat anyway, my bet would be on it.

  3. #3
    Senior Member
    Join Date
    Mar 2011
    Posts
    156
    yes, you've said it -> trackstat.

    It is/was trackstat. Completely disable this plugin and the CPU load from 25% to 2%.
    But! The usual, enable debugging on plugin doesn't help here. As trackstat according to the log, does nothing. The plugin is activated, but doing nothing (according to logs)
    Doesn't matter if i use the original version of trackstat from Erland or the modified one by myself which prevents duplicate musicbrainz_id.
    But as i said. the plugin is according to logs doing nothing.
    But still LMS slimserver.pl is running with 25% so "something" is acting weird. Can you tell me which server specific debug log would help to see, why slimserver.pl is on this high CPU level?

  4. #4
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    20,303
    Quote Originally Posted by mamema View Post
    yes, you've said it -> trackstat.

    It is/was trackstat. Completely disable this plugin and the CPU load from 25% to 2%.
    But! The usual, enable debugging on plugin doesn't help here. As trackstat according to the log, does nothing. The plugin is activated, but doing nothing (according to logs)
    Doesn't matter if i use the original version of trackstat from Erland or the modified one by myself which prevents duplicate musicbrainz_id.
    But as i said. the plugin is according to logs doing nothing.
    But still LMS slimserver.pl is running with 25% so "something" is acting weird. Can you tell me which server specific debug log would help to see, why slimserver.pl is on this high CPU level?
    Can you clarify the CPU load figure and how many cores on the system.

    On some systems with 4 cores if LMS took 100% of a core it could show 25% overall but detailed CPU display would show 100% on one core.

    Is the 25% on a single core or overall ?

  5. #5
    Senior Member
    Join Date
    Mar 2011
    Posts
    156
    Quote Originally Posted by bpa View Post
    Can you clarify the CPU load figure and how many cores on the system.

    On some systems with 4 cores if LMS took 100% of a core it could show 25% overall but detailed CPU display would show 100% on one core.

    Is the 25% on a single core or overall ?
    the system has 4 cores, the docker container uses 25% of one core. It's not much, but as described, it's for "nothing"

  6. #6
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,530

    25% CPU slimserver.pl in 8.2docker while idle

    > Doesn't matter if i use the original version of trackstat from Erland or
    > the modified one by myself which prevents duplicate musicbrainz_id.
    > But as i said. the plugin is according to logs doing nothing.


    As you know how to edit the plugin (and you've done so), just add log
    statements wherever you want (assuming you've already enabled debug
    logging for plugin.trackstat or whatever it is).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •