Home of the Squeezebox™ & Transporter® network music players.
Page 4 of 8 FirstFirst ... 23456 ... LastLast
Results 31 to 40 of 73
  1. #31
    Senior Member
    Join Date
    May 2009
    Location
    Clacton-on-Sea, Essex. UK
    Posts
    658
    Quote Originally Posted by bobertuk View Post
    Still the same. I noticed that C:\ProgramData\Squeezebox\Cache\InstalledPlugins\P lugins\LMSdbopt/install.xml contains <version>0.0.1</version>

    Could that be the problem? Could the cache at your end contain the wrong version?
    I just stopped LMS, edited <version>0.0.1</version> to <version>0.0.2</version>, restarted LMS and that seems to have worked, although I now don't know which version is really running. Is it v0.0.1 or v0.0.2?
    2 x Touch
    2 x Radio
    2 x Boom
    1 x Intel-NUC server/squeezelite running LMS 8.20 (from nightlies) on Windows 10
    1 X Odroid-XU4 server/squeezelite running LMS 7.91 on Ubuntu 16.04
    1 x iMac server running macOS Big Sur
    WaveIO USB into Lavry DA-10 DAC
    Starfish Pre-amp : Based on NAIM NAC 72
    Heavily modified NAIM NAP 250 Power-amp
    Focal Electra 1027 Be II Speakers

  2. #32
    Senior Member
    Join Date
    Aug 2012
    Location
    Austria
    Posts
    1,197
    Quote Originally Posted by bobertuk View Post
    Still the same. I noticed that C:\ProgramData\Squeezebox\Cache\InstalledPlugins\P lugins\LMSdbopt/install.xml contains <version>0.0.1</version>
    Could that be the problem?
    Could very well be - it's certainly incorrect, even though my local installation didn't complain.
    Anyway, I've uploaded a new .zip
    Various SW: Web Interface | TUI | Playlist Editor / Generator | Music Classification | Similar Music | Announce | EventTrigger | DB Optimizer | Chiptunes | LMSlib2go | ...
    Various HowTos: build a self-contained LMS | Bluetooth/ALSA | Control LMS with any device | ...

  3. #33
    Junior Member
    Join Date
    Nov 2020
    Location
    Ireland
    Posts
    16
    last version working for me at least, on debian buster. many thanks for this

    edit: just for clarity, previous versions of 0.0.2 were not updating
    Last edited by manx; 2021-03-03 at 07:33.

  4. #34
    Senior Member
    Join Date
    May 2009
    Location
    Clacton-on-Sea, Essex. UK
    Posts
    658
    Quote Originally Posted by Roland0 View Post
    Could very well be - it's certainly incorrect, even though my local installation didn't complain.
    Anyway, I've uploaded a new .zip
    That seems to have worked. I guess it was a cache problem.

    Thank you
    2 x Touch
    2 x Radio
    2 x Boom
    1 x Intel-NUC server/squeezelite running LMS 8.20 (from nightlies) on Windows 10
    1 X Odroid-XU4 server/squeezelite running LMS 7.91 on Ubuntu 16.04
    1 x iMac server running macOS Big Sur
    WaveIO USB into Lavry DA-10 DAC
    Starfish Pre-amp : Based on NAIM NAC 72
    Heavily modified NAIM NAP 250 Power-amp
    Focal Electra 1027 Be II Speakers

  5. #35
    Senior Member
    Join Date
    Mar 2011
    Posts
    166
    Quote Originally Posted by Roland0 View Post
    gotop or bottom have binaries for most platforms. You could add one of them to your container.
    neither of both are working on Synology with the provided binaries. So i've installed htop in the container.

    I do not see more than one core used. 25% overall and the container is at 100% if i check within the container itself.

    ...and for whatever reason without changing anything else i'm back at my long running trackstst cycles, runs again now for about 1.5 hours and still is running
    Last edited by mamema; 2021-03-03 at 10:00.

  6. #36
    Senior Member philchillbill's Avatar
    Join Date
    Jan 2019
    Location
    The Netherlands
    Posts
    631
    I just updated LMS on my Ubuntu NUC to 8.2 and also added your plugin. The UI feels much snappier, especially in iPeng with loading thumbnails for cover art in the New Music view. Nice work !

    A new and changed rescan of a DB with 70K tracks took 42 seconds. The system has an SSD but the music files are on an 8TB HDD.

  7. #37
    Senior Member
    Join Date
    Aug 2012
    Location
    Austria
    Posts
    1,197
    Quote Originally Posted by philchillbill View Post
    I just updated LMS on my Ubuntu NUC to 8.2 and also added your plugin. The UI feels much snappier, especially in iPeng with loading thumbnails for cover art in the New Music view. Nice work !

    A new and changed rescan of a DB with 70K tracks took 42 seconds. The system has an SSD but the music files are on an 8TB HDD.
    Thanks for the feedback.

    I'm still fiddling with some of the parameters (cache sizes, mainly). Currently, they should be fine for ~1-2GB free memory.
    However, if enough people with different requirements use this (probably unlikely...), it might make sense to add some kind of configuration mechanism.
    Another idea would be to add an auto max config, which simply sets the caches to the sizes of the databases (although my artwork db currently has 1,2GB, so for a small system this may not be such a great idea)
    Various SW: Web Interface | TUI | Playlist Editor / Generator | Music Classification | Similar Music | Announce | EventTrigger | DB Optimizer | Chiptunes | LMSlib2go | ...
    Various HowTos: build a self-contained LMS | Bluetooth/ALSA | Control LMS with any device | ...

  8. #38
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,530

    [Announce] Database Optimizer plugin

    > I'm still fiddling with some of the parameters (cache sizes, mainly).
    > Currently, they should be fine for ~1-2GB free memory.


    I'll have to play with this, in particular with the imageproxy.db, too:
    MAI makes heavy use of it to cache artist artwork etc... Are you using MAI?

  9. #39
    Senior Member
    Join Date
    Jan 2013
    Posts
    313
    Hi

    Only SQLite is supported, don't install this if your LMS uses MySQL.
    I am running LMS 8.1.1 on Windows 10. How do I ascertain if I am using MySQL or SQLite? There are folders for both within Squeezebox\server.

    Thanks.

    Steve

  10. #40
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,530

    [Announce] Database Optimizer plugin

    > I am running LMS 8.1.1 on Windows 10. How do I ascertain if I am using
    > MySQL or SQLite? There are folders for both within Squeezebox\server.


    If you don't know what you're using, you're using SQLite :-)

    MySQL really only is there for legacy reason. There might be some users
    of it, but it requires manual configuration. Therefore you'd know about it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •