Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 2 of 2
  1. #1
    Junior Member
    Join Date
    Jan 2021
    Posts
    20

    Cannot allocate FULL 4GB Buffer Size in Squeezelite on RPi 8GB

    Hey Guys,

    This is just a memory buffer size question. Please leave SQ discussion or opinions for another thread. Just trying to troubleshoot. I'm out if their is a hint of someone injecting their SQ opinion.

    I haven't messed around with my RPi 8GB for about four months. I'm finally going to get around to working on the RPi 8GB audio project in March.

    When I played around with the squeezelite buffer settings at that time I remembered I couldn't allocate the full 4GB. Maybe got up to 3.9GB.

    I forget why sometimes this happens. Is it because of TinyCoreLinux? A 32-bit, 64-bit thing?

    I'm just trying to prepare when I have to tackle this issue again. If it's something that cannot be resolved, that would be helpful too.

    I tried the following and hit a roadblock at "-b 2097152:2097152". I entered around 3.8 - 3.9GB and it worked fine. Forget but something like -b 199xxxx:199xxxx.

    1. default, no setting
    2. -b 1048576:1048576
    3. -b 1572864:1572864
    4. -b 2097152:2097152

    https://audiophilestyle.com/forums/t...comment-897936

    Thanks for your understanding. It's hard to troubleshoot and resolve if one starts sidetracking with their SQ opinion. I won't be able to troubleshoot until mid-March, but just trying to gather where I can start researching or if it is just not possible with TCL.
    Last edited by LiFePO4; 2021-02-26 at 20:52.

  2. #2
    Junior Member
    Join Date
    Jan 2021
    Posts
    20

    Resolved!

    I recently noticed there was a 64-bit version of PcP.

    I believe it fixed this issue. I was able to enter the full 4GB and it restarted.

    Unfortunately, my audio system is in flux and I only tested for less than a minute. No listening tests.

    I have moved on to a 12V low latency realtime kernel i9 PC build and re-purposed the 8GB RPi to non-audio.

    Many thanks.
    Last edited by LiFePO4; 2021-04-22 at 16:03.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •