Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 8 of 8
  1. #1
    Junior Member
    Join Date
    Mar 2015
    Posts
    8

    PiCorePlayer 7 and Bluetooth

    Today i installed PiCorPlayer 7 on my RPI3+ to play music from my LMS to my new bluetooth speaker (JBL BoomBox).

    The install went smooth and also the pairing/connection to my BT-speaker is okay. Squeezelite is running and visible in LMS as a player.
    I would expect to see the BT-speaker under Squeezelite Settings > Audio output device settings but i don't see it in the list.
    I guess this is the reason i do not get any music output from my speakers.

    I'm afraid i missed something in the configuration but cannot figure out what...

    Any help would be appreciated.

  2. #2
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    4,357
    You probably have two instances of Squeezelite running now.
    From ssh session try:

    ps -ef | grep squeezelite
    Paul Webster
    http://dabdig.blogspot.com
    Author of "Now Playing" plugins covering Radio France (FIP etc), PlanetRadio (Bauer - Kiss, Absolute, Scala, JazzFM etc), KCRW, Supla Finland, ABC Australia, CBC/Radio-Canada and RTE Ireland

  3. #3
    Junior Member
    Join Date
    Mar 2015
    Posts
    8
    Quote Originally Posted by Paul Webster View Post
    You probably have two instances of Squeezelite running now.
    From ssh session try:

    ps -ef | grep squeezelite
    Hi Paul, thanks for your swift reply. I see this output:

    Code:
    tc@piCorePlayer:~$ ps -ef | grep squeezelite
    10468 root      0:45 /usr/local/bin/squeezelite -o bt_JBL_BoomBox -n JBL BoomBox                  -m 98 52 3D BE BE F9 -a 80   1 -M SqueezeLiteBT -f /dev/null
    12313 root      1:01 /usr/local/bin/squeezelite -n piCorePlayer -a      -C 5
    15091 tc        0:00 grep squeezelite
    tc@piCorePlayer:~$
    Look indeed like a second proces is running. How do i proceed now to get music out of my BoomBox?

  4. #4
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    4,110
    You should see a player named ôJBL BoomBoxö in LMS t9 play to.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  5. #5
    Junior Member
    Join Date
    Mar 2015
    Posts
    8
    Find myself so stupid that i did not look for an other player in LMS. Indeed it works like a charm now.
    Paul, you're a real lifesaver Thanks so much!

  6. #6
    Junior Member
    Join Date
    Sep 2012
    Posts
    5

    picoreplayer on a rpi4b with pidisplay and bluetooth speaker

    Hi all,

    I've been trying out the picoreplayer on a rpi4b with a pidisplay and a bluetoothspeaker (megaboom3)
    It all connects even the bluetooth seems to connect on poweron.

    Via lms I can play music on the bt speaker.

    However the bluetoothspeaker can only be managed via lms and not via the jivelite.

    Is there a way to configure jivelite/picoreplayer so that jivelite connects to the bluetoothspeaker instance ?

    currently the pidisplay is kinda useless when using bluetooth speakers.

    Tjako

  7. #7
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    4,110
    Once the speaker is connected, you can select it from the jivelite interface. Jivelite works best with devices that are always connected.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  8. #8
    Junior Member
    Join Date
    Sep 2012
    Posts
    5
    Ok...

    I found the option to select the device, somehow managed to miss that one.

    My setup is working properly now.


    Thanx.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •