Home of the Squeezebox™ & Transporter® network music players.
Page 3 of 7 FirstFirst 12345 ... LastLast
Results 21 to 30 of 68
  1. #21
    Senior Member
    Join Date
    May 2007
    Posts
    136
    Or you looking on https://sourceforge.net/projects/lms.../files/DSM6.x/
    There is LMS 8.1.1 available.
    __________________________________________________ _______________________________________
    Logitech Media Server Versie: 8.1.1 - 1610364019 @ Thu Jan 14 06:27:19 CET 2021
    Platform: Synology DSM 6.2.3
    Plug-ins: Spotty v4.4.7 (M. Herger)
    3x Squeezebox Classic, 1x Touch, 1x Boom
    Spotify Premium Account (NL)

  2. #22
    Junior Member
    Join Date
    Mar 2021
    Posts
    8
    My DS918+ is running DSM 6.2.4 with PHP 7.0. A week ago the LMS server stopped and could not be restarted. I tried to reinstall it but found the LMS package is no longer available from Synology after uninstall.

    I know LMS is not supported by Synology now and so go for this one from pinkdot: LogitechMediaServer-x86_64-8.1.1-1610364019.spk

    However, I got the following error at LMS start-up:
    PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/modules/json.so' - /usr/lib/php/modules/json.so: cannot open shared object file: No such file or directory in Unknown on line 0

    Seems LMS 8.1.1 requires PHP-json but I don't know how to get & install it. Before I go for the docker option, is there any solution for the above error? Thx.

  3. #23
    Senior Member
    Join Date
    Mar 2011
    Posts
    177
    perhaps you have:
    "extension=json.so" in /etc/php/php.ini

    remove the entry and try again

  4. #24
    Junior Member
    Join Date
    Mar 2021
    Posts
    8
    Quote Originally Posted by mamema View Post
    perhaps you have:
    "extension=json.so" in /etc/php/php.ini

    remove the entry and try again
    Nope. There is no such entry in /etc/php/php.ini

    ...
    extension = bcmath.so
    extension = bz2.so
    extension = curl.so
    extension = iconv.so
    extension = ldap.so
    extension = mcrypt.so
    extension = openssl.so
    extension = pdo_sqlite.so
    extension = posix.so
    extension = phar.so
    extension = shmop.so
    extension = sockets.so
    extension = sqlite3.so
    extension = zip.so

    extension = syno_compiler.so
    ...

  5. #25
    Senior Member
    Join Date
    Mar 2011
    Posts
    177
    then add it and try again......

  6. #26
    Junior Member
    Join Date
    Mar 2021
    Posts
    8
    Quote Originally Posted by mamema View Post
    then add it and try again......
    Tried already and got the same error. There is no "json.so" under /usr/lib/php/modules/

  7. #27
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,540

    Request for Synology to upgradeLMS package to version (8.x)

    > However, I got the following error at LMS start-up:
    > PHP Warning: PHP Startup: Unable to load dynamic library


    I don't think the package uses PHP at all. This might be a red herring.
    Or there's something bigger wrong with your system, which makes LMS fail
    as well as PHP.

  8. #28
    Senior Member
    Join Date
    Mar 2011
    Posts
    177
    in DSM the packages Web Station and WebDAV are using this extension, perhaps installing those packages might help. Or and other possibility could be to install PHP 7.0,7,1,7,3,7,4 (everything whats offered).

  9. #29
    Junior Member
    Join Date
    Mar 2015
    Posts
    27
    I was in the same situation and went the Raspberry Pi/piCoreplayer route. Very happy with this set-up (and grateful to the support on these forums). Easy enough to link to music stored on the Synology NAS

  10. #30
    Senior Member
    Join Date
    Nov 2012
    Location
    UK, Nottinghamshire
    Posts
    409
    With DS918+ why wouldn't you run LMS in docker?
    3x Squeezebox Touch, 4x Squeezebox Radio, Squeezelite (RPi 3B with HiFiBerry DAC+Pro on OSMC), Material Skin Apk, Squeeze Commander, Logitech Media Server Version: 8.2.0 with Material Skin (Docker in DS218+)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •