Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 5 of 5
  1. #1
    Junior Member
    Join Date
    Jan 2021
    Posts
    2

    Squeezelite and Sample Rate problem

    Hello,

    I hope someone can help me. I have a Raspberry Pi 4 and a Allo Digione DAC HAT, it works fine but its only outputting to 44 Khz. No matter what source I play on it.

    Pretty sure its a setting i need to apply but I'm a bit lost!

    How do I set it to output different sample rates please?

    Any help greatly appreciated!

    T1b

  2. #2
    Senior Member
    Join Date
    Jan 2011
    Location
    Staffordshire. UK
    Posts
    4,433
    Quote Originally Posted by T1berious View Post
    Hello,

    I hope someone can help me. I have a Raspberry Pi 4 and a Allo Digione DAC HAT, it works fine but its only outputting to 44 Khz. No matter what source I play on it.

    Pretty sure its a setting i need to apply but I'm a bit lost!

    How do I set it to output different sample rates please?

    Any help greatly appreciated!

    T1b

    More info would maybe help

    Which pi OS

    Which LMS version

    Which Squeezelite version

    Which IO::Socket::SSL

    How did you install LMS and Squeezelite?

    ronnie

    Give an example of the problem

  3. #3
    Junior Member
    Join Date
    Jan 2021
    Posts
    2
    Quote Originally Posted by Man in a van View Post
    More info would maybe help

    Which pi OS

    Which LMS version

    Which Squeezelite version

    Which IO::Socket::SSL

    How did you install LMS and Squeezelite?

    ronnie

    Give an example of the problem
    Here's the version info

    piCorePlayer v7.0.0 | www v00011 | linux 5.4.83-pcpCore-v7l | piCore v12.0pCP | Squeezelite v1.9.8-1287-pCP

    So I've been playing Tidal Master streams and they play as 44.1 same with a high res local album at 24/192 plays at 44.1 as displayed on the DAC.

    Tested the DAC seperately and it''s working fine and displaying the correct sample rate. So it looks like the Pi is only putting out at 44.1.

    Cheers for getting back to me

  4. #4
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    20,637
    Quote Originally Posted by T1berious View Post
    Here's the version info

    piCorePlayer v7.0.0 | www v00011 | linux 5.4.83-pcpCore-v7l | piCore v12.0pCP | Squeezelite v1.9.8-1287-pCP

    So I've been playing Tidal Master streams and they play as 44.1 same with a high res local album at 24/192 plays at 44.1 as displayed on the DAC.

    Tested the DAC seperately and it''s working fine and displaying the correct sample rate. So it looks like the Pi is only putting out at 44.1.

    Cheers for getting back to me
    I know nothing specific about PCP so this is general advice.

    1. It looks like pcp is using the DAC as a generic device rather then specifically your Allo DAC - did you select the Allo Digione DAC (or similar) setting in the PCP setup
    2. What is the output device you have chosen for output (e.g. default, sysdefault, plughw:0,0 , hw:CARD=1,DEVICE=4)
    3. Do not use Tidal as a test reference - you need to have a lot of other setup right to be sure of its output - it could eb leading you astray. TO sort this issue - only test with a files of known sample rates.

  5. #5
    Senior Member
    Join Date
    Jan 2011
    Location
    Staffordshire. UK
    Posts
    4,433
    What display do you get if you stream a 48Khz internet radio (BBC radio if in the UK) or

    http://icecast.radiofrance.fr/fip-hifi.aac

    does the display change from 44.1 to 48 ?

    Which dac are you using and what setting do you have for the Audio output ?

    Name:  digione.png
Views: 69
Size:  70.9 KB

    This is on a rpi3b+ but with the same pCP

    Digione | piCorePlayer v7.0.0 | www v00011 | linux 5.4.83-pcpCore-v7 | piCore v12.0pCP | Squeezelite v1.9.8-1287-pCP
    ronnie

    Bye the way LMS does not play MQA

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •