Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 2 12 LastLast
Results 1 to 10 of 20
  1. #1

    Tidal integration not loading tracks

    Hi all -

    I am using LMS with the Tidal and Online Music Library Integration plugins, intending to stream from Tidal. I have two Raspberry Pi's running this setup. One of them refuses to scan and load the favorites from Tidal, while the other works as intended. Both can play back Tidal tracks without issue, so it's only the library integration that is a problem.

    The problem Pi exhibited this behavior:

    1. After I set it up, it started scanning Tidal favorites and they appeared in my library, with artwork, but it halted at 28 albums out of 106 for some unknown reason. It would not budge from there.
    2. I let it sit for a good long time and also tried various refresh buttons that seemed potentially like they might cause it to rescan. No luck.
    3. Out of frustration, I disabled both of the relevant plugins (Tidal and Online Music Library Integration), restarted LMS, then turned them back on again.
    4. What then happened is that the 28 albums disappeared and the library is now empty, but it's not rescanning.

    The preferences for Online Music Library Integration I have set to Tidal: Integrate Online Library and Automatically Check for Changes

    I love this setup when it works, as it does on the other Pi!

    Any tips about how to reinitialize the library integration?

  2. #2
    Logitech Media Server Status

    Logitech Media Server Version: 8.1.0 - 1608700893 @ Wed Dec 23 12:16:44 CET 2020

    Operating system: piCore - EN - utf8
    Platform Architecture: armv8l-linux
    Perl Version: 5.28.2 - arm-linux-gnueabihf-thread-multi-64int
    Audio::Scan: 1.02
    IO::Socket::SSL: 2.066
    Database Version: DBD::SQLite 1.58 (sqlite 3.22.0)

  3. #3
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    7,497
    Quote Originally Posted by Merrill Aldrich View Post
    Logitech Media Server Status

    Logitech Media Server Version: 8.1.0 - 1608700893 @ Wed Dec 23 12:16:44 CET 2020

    Operating system: piCore - EN - utf8
    Platform Architecture: armv8l-linux
    Perl Version: 5.28.2 - arm-linux-gnueabihf-thread-multi-64int
    Audio::Scan: 1.02
    IO::Socket::SSL: 2.066
    Database Version: DBD::SQLite 1.58 (sqlite 3.22.0)
    Latest stable version is 8.1.1
    LMS 8.2 on Odroid-C4 - SqueezeAMP!, 5xRadio, 5xBoom, 2xDuet, 1xTouch, 1xSB3. Sonos PLAY:3, PLAY:5, Marantz NR1603, Foobar2000, ShairPortW, 2xChromecast Audio, Chromecast v1 and v2, Squeezelite on Pi, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5, RivaArena 1 & 3

  4. #4
    Thanks

    Here's another clue - the log shows

    [21-01-22 21:51:21.0035] Slim::Plugin::OnlineLibrary::Plugin::__ANON__ (176) Disabling polling for Slim::Plugin::WiMP::Plugin lack of account information

    and then the integration setting in the Online Library plugin has changed to turn off integration, by itself. I can log in myself to https://www.mysqueezebox.com/, and I have a working account.

    So perhaps the local preferences are not storing my credentials?

  5. #5
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,592

    Tidal integration not loadingtracks

    > 1. After I set it up, it started scanning Tidal favorites and they
    > appeared in my library, with artwork, but it halted at 28 albums out of
    > 106 for some unknown reason. It would not budge from there.


    Enable logging for plugin.tidal, re-run a scan. Anything in the
    scanner.log (or server.log in general, fwiw)?

    --

    Michael

  6. #6
    The end of the server log:

    Code:
    [21-01-22 21:58:22.9530] main::init (388) Starting Logitech Media Server (v8.1.0, 1608700893, Wed Dec 23 12:16:44 CET 2020) perl 5.028002 - arm-linux-gnueabihf-thread-multi-64int
    [21-01-22 21:58:23.2736] Slim::Utils::SQLiteHelper::postConnect (377) Optimizing DB because of missing or empty sqlite_stat1 table
    [21-01-22 21:58:23.3256] Slim::Schema::forceCommit (2171) Warning: Trying to commit transactions before DB is initialized!
    [21-01-22 21:58:23.5624] Slim::Utils::SQLiteHelper::postConnect (377) Optimizing DB because of missing or empty sqlite_stat1 table
    [21-01-22 21:58:23.5959] Slim::Schema::forceCommit (2171) Warning: Trying to commit transactions before DB is initialized!
    [21-01-22 21:58:24.3654] Slim::Utils::SQLiteHelper::postConnect (377) Optimizing DB because of missing or empty sqlite_stat1 table
    [21-01-22 21:58:24.4076] Slim::Schema::forceCommit (2171) Warning: Trying to commit transactions before DB is initialized!
    [21-01-22 21:58:24.6907] main::checkDataSource (1108) Warning: Schema updated or no media found in the database, initiating scan.
    [21-01-22 21:58:27.1084] Slim::Utils::SQLiteHelper::postConnect (377) Optimizing DB because of missing or empty sqlite_stat1 table
    [21-01-22 21:58:27.1464] Slim::Schema::forceCommit (2171) Warning: Trying to commit transactions before DB is initialized!
    [21-01-22 22:07:17.7857] Slim::Utils::SQLiteHelper::postConnect (377) Optimizing DB because of missing or empty sqlite_stat1 table
    [21-01-22 22:07:17.8231] Slim::Schema::forceCommit (2171) Warning: Trying to commit transactions before DB is initialized!
    [21-01-22 22:11:36.0039] Slim::Plugin::OnlineLibrary::Plugin::__ANON__ (176) Disabling polling for Slim::Plugin::WiMP::Plugin lack of account information
    Last edited by Merrill Aldrich; 2021-01-22 at 21:18.

  7. #7
    The scanner log (Note: I don't have any local music files on this machine at all, so that's not an issue :-) )

    Code:
    [21-01-22 22:07:16.5695] main::main (206) Starting Logitech Media Server scanner (v8.1.0, 1608700893, Wed Dec 23 12:16:44 CET 2020) perl 5.028002
    [21-01-22 22:07:16.8263] Slim::Schema::forceCommit (2171) Warning: Trying to commit transactions before DB is initialized!
    [21-01-22 22:07:17.4820] Slim::Music::Import::runImporter (577) Starting Slim::Media::MediaFolderScan scan
    [21-01-22 22:07:17.4825] Slim::Utils::Scanner::Local::rescan (179) Discovering audio files in /home/tc/music
    [21-01-22 22:07:17.5009] Slim::Utils::Scanner::Local::__ANON__ (191) Start processing found tracks
    [21-01-22 22:07:17.5012] Slim::Utils::Scanner::Local::__ANON__ (199) Connect do DB
    [21-01-22 22:07:17.5015] Slim::Utils::Scanner::Local::__ANON__ (202) Get latest ID
    [21-01-22 22:07:17.5020] Slim::Utils::Scanner::Local::__ANON__ (224) Delete temporary table if exists
    [21-01-22 22:07:17.5022] Slim::Utils::Scanner::Local::__ANON__ (227) Re-build temporary table
    [21-01-22 22:07:17.5030] Slim::Utils::Scanner::Local::__ANON__ (276) Get deleted tracks count
    [21-01-22 22:07:17.5033] Slim::Utils::Scanner::Local::__ANON__ (283) Get new tracks count
    [21-01-22 22:07:17.5036] Slim::Utils::Scanner::Local::__ANON__ (288) Get changed tracks count
    [21-01-22 22:07:17.5039] Slim::Utils::Scanner::Local::deleteTracks (519) Removing deleted audio files (0)
    [21-01-22 22:07:17.5041] Slim::Utils::Scanner::Local::__ANON__ (301) Scanning new audio files (0)
    [21-01-22 22:07:17.5043] Slim::Utils::Scanner::Local::__ANON__ (381) Rescanning changed audio files (0)
    [21-01-22 22:07:17.5047] Slim::Music::Import::endImporter (710) Completed Slim::Media::MediaFolderScan Scan in 0 seconds.
    [21-01-22 22:07:17.5064] Slim::Music::Import::runImporter (577) Starting Slim::Music::PlaylistFolderScan scan
    [21-01-22 22:07:17.5069] Slim::Utils::Scanner::Local::rescan (179) Discovering audio files in /home/tc/playlists
    [21-01-22 22:07:17.5222] Slim::Utils::Scanner::Local::__ANON__ (191) Start processing found tracks
    [21-01-22 22:07:17.5225] Slim::Utils::Scanner::Local::__ANON__ (199) Connect do DB
    [21-01-22 22:07:17.5229] Slim::Utils::Scanner::Local::__ANON__ (202) Get latest ID
    [21-01-22 22:07:17.5234] Slim::Utils::Scanner::Local::__ANON__ (224) Delete temporary table if exists
    [21-01-22 22:07:17.5239] Slim::Utils::Scanner::Local::__ANON__ (227) Re-build temporary table
    [21-01-22 22:07:17.5246] Slim::Utils::Scanner::Local::__ANON__ (276) Get deleted tracks count
    [21-01-22 22:07:17.5249] Slim::Utils::Scanner::Local::__ANON__ (283) Get new tracks count
    [21-01-22 22:07:17.5252] Slim::Utils::Scanner::Local::__ANON__ (288) Get changed tracks count
    [21-01-22 22:07:17.5255] Slim::Utils::Scanner::Local::deleteTracks (519) Removing deleted audio files (0)
    [21-01-22 22:07:17.5258] Slim::Utils::Scanner::Local::__ANON__ (301) Scanning new audio files (0)
    [21-01-22 22:07:17.5260] Slim::Utils::Scanner::Local::__ANON__ (381) Rescanning changed audio files (0)
    [21-01-22 22:07:17.5264] Slim::Music::Import::endImporter (710) Completed Slim::Music::PlaylistFolderScan Scan in 0 seconds.
    [21-01-22 22:07:17.5275] Slim::Music::Import::runImporter (577) Starting Slim::Plugin::FullTextSearch::Plugin scan
    [21-01-22 22:07:17.5285] Slim::Plugin::FullTextSearch::Plugin::_rebuildIndex (453) Starting fulltext index build
    [21-01-22 22:07:17.5288] Slim::Plugin::FullTextSearch::Plugin::_rebuildIndex (457) Initialize fulltext table
    [21-01-22 22:07:17.5302] Slim::Plugin::FullTextSearch::Plugin::_rebuildIndex (470) Create fulltext index for tracks
    [21-01-22 22:07:17.5379] Slim::Plugin::FullTextSearch::Plugin::_rebuildIndex (480) Create fulltext index for albums
    [21-01-22 22:07:17.5391] Slim::Plugin::FullTextSearch::Plugin::_rebuildIndex (489) Create fulltext index for contributors
    [21-01-22 22:07:17.5399] Slim::Plugin::FullTextSearch::Plugin::_rebuildIndex (499) Create fulltext index for playlists
    [21-01-22 22:07:17.5444] Slim::Plugin::FullTextSearch::Plugin::_rebuildIndex (514) Optimize fulltext index
    [21-01-22 22:07:17.5526] Slim::Plugin::FullTextSearch::Plugin::_rebuildIndex (529) Fulltext index build done!
    [21-01-22 22:07:17.5530] Slim::Music::Import::endImporter (710) Completed Slim::Plugin::FullTextSearch::Plugin Scan in 0 seconds.
    [21-01-22 22:07:17.5534] Slim::Music::Import::runImporter (577) Starting Slim::Plugin::ExtendedBrowseModes::Libraries scan
    [21-01-22 22:07:17.5537] Slim::Music::Import::runImporter (577) Starting Slim::Plugin::OnlineLibrary::Importer::VirtualLibrariesCleanup scan
    [21-01-22 22:07:17.5548] Slim::Music::Import::endImporter (710) Completed Slim::Plugin::OnlineLibrary::Importer::VirtualLibrariesCleanup Scan in 0 seconds.
    [21-01-22 22:07:17.5562] Slim::Music::Artwork::precacheAllArtwork (659) Starting precacheArtwork for 0 albums
    [21-01-22 22:07:17.5565] Slim::Music::Import::endImporter (710) Completed precacheArtwork Scan in 0 seconds.
    [21-01-22 22:07:17.5570] Slim::Music::Import::runScanPostProcessing (479) Starting Database optimization.
    [21-01-22 22:07:17.7300] Slim::Music::Import::endImporter (710) Completed dbOptimize Scan in 0 seconds.

  8. #8
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,592

    Tidal integration not loadingtracks

    > The scanner log (Note: I don't have any local music files on this
    > machine at all, so that's not an issue :-) )


    Did you re-enable TIDAL import? There's no sign of it.

    --

    Michael

  9. #9
    OK, this is really odd. Happy odd, but odd.

    I did two things -

    • I set the logging for plugin.tidal to debug (from error)
      I removed and reentered my (unchanged) credentials for Tidal on mysqueezebox.com


    Then I triggered a rescan of "only online music library" (for like the 11teenth time)

    and just like that it started working!

    I guess maybe it just needed a stern look and some superstition :-D

    Thanks for the suggestions. I think I'm back in business.

  10. #10
    Junior Member
    Join Date
    May 2010
    Posts
    24

    Also having trouble with TIDAL integegration

    Hi there. I'm not sure if this helps with this issue...

    I have also been having trouble with TIDAL integration recently, ie the LMS index build not picking up my TIDAL faves and playlists and listing TIDAL content under "New Music" in the web interface.

    I reset all my passwords and uninstalled/reinstalled LMS (v 8.1.2) on my Windows 10 PC and did a re-scan and still no joy. I then tried temporarily disabling Windows Defender Firewall and re-scanned again, and this time the scan did pick up my TIDAL content. I then enabled the firewall and everything is fine.

    It had previously all been working fine - up until a few days ago.

    -Graeme

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •