Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 5 of 5
  1. #1

    Squeezelite changes volume and start playing ALONE !!!

    I'm using LMS and squeezelite on Raspbian for few years. Very happy !
    I recently made a fresh install in an other house. With this new install, I have a very uncomfortable issue : sometimes (1 or 2 per month, different hours), squeezelite changes volume to 100 and starts to play alone ! (without any human action !!) Of course, it is not very convenient to be awake in the middle of the night with the music at full volume... Especially the cats do not appreciate :-)

    The fresh install :
    Logitech Media Server
    Logitech Media Server Version : 7.9.3 - 1597753178 @ Sun Aug 23 19:23:14 CEST 2020
    Nom d'hôte : RASPFOZSALON
    Adresse IP du serveur : 192.168.1.20
    Port HTTP du serveur : 9000
    Système d'exploitation : Debian - FR - utf8
    Architecture de la plate-forme : armv7l-linux
    Version de Perl : 5.28.1 - arm-linux-gnueabihf-thread-multi-64int
    Audio::Scan : 1.02
    IO::Socket::SSL : 2.060
    Version de la base de données : DBD::SQLite 1.58 (sqlite 3.22.0)
    Platines identifiées : 1
    Squeezelite :
    Modèle platine : SqueezeLite
    Type platine : squeezelite
    Micrologiciel : v1.8
    Adresse IP platine : 192.168.1.20
    Adresse MAC platine : dc:a6:32:84:9a:6c
    LMS and Squeezelite are on the same Raspberry PI 4, with external hard drive. A crontab updates and reboots the system every day at 18:00.

    Server.log is posted in attachment. The issue begins in line 32496 (19:30:11)

    I don't understand what happens but a thing looks strange : when I send a command to squeezelite (via Squeeze Ctrl on Android), the command line looks like :
    Slim::Control::Request::dump (2339) Request: Query [dc:a6:32:84:9a:6c->myapps items] cb+ from /9a8b0135/slim/request/7|16||9a8b0135 (Done)
    I mean cb + from ..... and with my issue there is no "from ..." I suppose that means it's the system who send the command but WHY ???

    I see many lines in the server.log with ip adresses which are not mine. But I don't make a relationship between these "attacks" and my issue...

    If anybody could help me before I make an heart attack....

    Thanks a lot !server.zip

  2. #2
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    4,161
    Quick answer - stop forwarding ports from the internet
    https://forums.slimdevices.com/showt...o-the-internet
    Paul Webster
    http://dabdig.blogspot.com
    Author of "Now Playing" plugins covering Radio France (FIP etc), PlanetRadio (Bauer - Kiss, Absolute, Scala, JazzFM etc), KCRW, Supla Finland, ABC Australia, CBC/Radio-Canada and RTE Ireland

  3. #3
    Quote Originally Posted by Paul Webster View Post
    Quick answer - stop forwarding ports from the internet
    https://forums.slimdevices.com/showt...o-the-internet
    Thanks Paul for your very fast answer.
    Could be OK if I limit the IP adresses authorized to my LMS ?

  4. #4
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    4,161
    Your logs show accesses from IP addresses in China and OVH hosting - so locking things down would be a good move.
    Don't rely on LMS doing that for you (although it is blocking access to the settings pages).
    If you can block via your router or some other firewall then OK ... but I suggest trying to work out a way that does not require your forwarding LMS ports at all.

    If you need access from another location then consider putting a VPN in front - with certificated authentication.
    Paul Webster
    http://dabdig.blogspot.com
    Author of "Now Playing" plugins covering Radio France (FIP etc), PlanetRadio (Bauer - Kiss, Absolute, Scala, JazzFM etc), KCRW, Supla Finland, ABC Australia, CBC/Radio-Canada and RTE Ireland

  5. #5
    Quote Originally Posted by Paul Webster View Post
    Your logs show accesses from IP addresses in China and OVH hosting - so locking things down would be a good move.
    Don't rely on LMS doing that for you (although it is blocking access to the settings pages).
    If you can block via your router or some other firewall then OK ... but I suggest trying to work out a way that does not require your forwarding LMS ports at all.

    If you need access from another location then consider putting a VPN in front - with certificated authentication.
    Many thanks ! I will make what you suggest.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •