Home of the Squeezebox™ & Transporter® network music players.
Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15
  1. #11
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    20,091
    Quote Originally Posted by socialxray View Post
    Code:
    flc flc * <MAC goes here>
    	# FT:{START=--skip=%t}U:{END=--until=%v}
        	[flac] -dcs $START$ $END$ -- $FILE$  |  [sox] -q -t wav - -t flac -e signed -C 0 -b 24 - rate -v -b 98 -L -a 96000
    
    mp3 flc * <MAC goes here>
    	[lame] --mp3input --decode -t --silent $FILE$ - |  [sox] -q -t wav - -t flac -e signed -C 0 -b 24 - rate -v -b 98 -L -a 96000
    
    aac flc * <MAC goes here>
    	# IF
    	[faad] -q -w -f 2 $FILE$  |  [sox] -q -t wav - -t flac -e signed -C 0 -b 24 - rate -v -b 98 -L -a 96000
    Main problem is the conversion rules have problems and so are breaking the conversion and so it fails.

    If you are going modify convert.conf rules - you really need to study the options.

    In the MP3 flc. Lame by default decodes to WAV. The "-t" option tells lame to output PCM and not WAV. In the sox part receiving - the first "-t wav" tell sox to expect WAV format. So immediately there is a mismatch.

    After fixing that then sox complained that "-e signed" is not a supported encode option.

    So a MP3 FLC command that should work would be
    Code:
    	[lame] --mp3input --decode --silent $FILE$ - |  [sox] -q -t wav - -t flac -C 0 -b 24 - rate -v -b 98 -L -a 96000
    sox can process MP3 directly so there is no need for lame so in theory the following could work but I think you may lose the jump to offset capability
    Code:
    [sox] -q -t mp3 - -t flac -C 0 -b 24 - rate -v -b 98 -L -a 96000
    However - depending on what you play (e.g. files, podcasts, stream, spotty, etc.) I think there maybe potential problems with your choice of "# FT" and "# IF" and missing "#" options.

    I think you have the same issues with the faad lines . The "-f 2" (raw PCM) should be "-f 1" (WAV) and there should be no "-e signed"

  2. #12
    BPA you totally RAWK!!!

    MP3 is squared away and working beautifully!!!

    AAC setting in custom-convert.conf is still being ignored. The file plays but the sample rate is still 44.1k. So I though about what you said about MP4 and disabled the MPEG-4 to AAC added this to my custom-convert.conf.

    mp4 flc * <MAC goes here>
    # IF
    [faad] -q -w -f 1 $START$ $END$ $FILE$ | [sox] -q -t wav - -t flac -C 0 -b 24 - rate -v -b 98 -L -a 96000

    I know I am on the right track because the test file no longer plays. Same error as before on the Transporter display.
    PROBLEM: CAN"T OPEN FILE:
    All That We Are

    I uploaded the server log.

    Also what '#' options would you recommend? I not not very sure what these options mean. I am really just going through the convert.conf and copying and pasting into custom-convert.conf wiht the addition of the sox command.

    THANKS AGAIN!@
    Attached Files Attached Files

  3. #13
    Oh snap! I got it working!!!

  4. #14
    SO I messed with the custom-convert.conf and came up with this.

    mp4 flc * *
    # FT:{START=-j %s}U:{END=-e %u}
    [faad] -q -w -f 1 $START$ $END$ $FILE$ | [sox] -q -t wav - -t flac -C 0 -b 24 - rate -v -b 98 -L -a 96000

    Adding those '#' options from the "mp4x flc" entry from convert.conf worked. Honestly it was just guessing; I don't really know what I am doing.

    But thank you BPA!!!

    I would have never gotten this far without your help. Do you have a donation page?
    Also I would like to get your advice on the '#' options. I am not sure if I have them correct and it seems they can make or break the up-sampling.

    My current custom-convert.conf looks like this.

    flc flc * <MAC goes here>
    # FT:{START=--skip=%t}U:{END=--until=%v}
    [flac] -dcs $START$ $END$ -- $FILE$ | [sox] -q -t wav - -t flac -C 0 -b 24 - rate -v -b 98 -L -a 96000

    mp3 flc * <MAC goes here>
    [lame] --mp3input --decode --silent $FILE$ - | [sox] -q -t wav - -t flac -C 0 -b 24 - rate -v -b 98 -L -a 96000

    mp4 flc * <MAC goes here>
    # FT:{START=-j %s}U:{END=-e %u}
    [faad] -q -w -f 1 $START$ $END$ $FILE$ | [sox] -q -t wav - -t flac -C 0 -b 24 - rate -v -b 98 -L -a 96000

    aac flc * <MAC goes here>
    # IF
    [faad] -q -w -f 1 $FILE$ | [sox] -q -t wav - -t flac -C 0 -b 24 - rate -v -b 98 -L -a 96000

  5. #15
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    20,091
    Quote Originally Posted by socialxray View Post
    Also I would like to get your advice on the '#' options. I am not sure if I have them correct and it seems they can make or break the up-sampling.
    Not using "native" playing will result in compromises.

    LMS expects every player to be able to play MP3 natively - so disabling native MP3 may mean going into unknown territory and probably reduced functionality.

    All LMS rules should have a "#" line. MP3 rules seem to not have them because MP3 was expected to be always available.

    You need to spend time to understand what is happening and not just cut & paste lines in the vague hope they might work.

    From the convert.conf file header
    Code:
    # Capabilities
    # I - can transcode from stdin
    # F - can transcode from a named file
    # R - can transcode from a remote URL (URL types unspecified)
    #
    # E - extensions syntax E:{<key>=<value>,<key>=<value>}
    #		NOSTART=I/F/R : no $START$ field when transcoding from I/F/R
    #		NOHEADER=I/F/R : strip out header when transcoding from I/F/R (waf/aif only)
    #
    # O - can seek to a byte offset in the source stream (not yet implemented)
    # T - can seek to a start time offset
    # U - can seek to start time offset and finish at end time offset
    #
    # D - can downsample
    # B - can limit bitrate
    For your requirement F,I,R and T are probably main one of interest.

    "R" may not be of interest as you should get bitrate change within a remote stream/services but I don't know internet streams/services you are using.

    For MP3 - all input usually from "I" (i.e. stdin) so I think current setting may be OK although not sure without "T" (or "U") whether you'll be able to skip to a time offset in a file (i.e. maybe no ffwd or rew)

    For AAC - current "#" lines in convert.conf for AAC, MP4, MP4x to FLC should be duplicated in your custom-convert.conf as you are trasncoding to FLC just like in main

    for Flac files - like MP3 not sure without "T" (or "U") whether you'll be able to skip to a time offset in a file (i.e. maybe no ffwd or rew)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •