Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1
    Senior Member
    Join Date
    Feb 2011
    Location
    Cheshire, UK
    Posts
    5,728

    A conundrum - how to troubleshoot

    2 installations of LMS
    One on Linux box and one a Pi
    Both use the same media files - on a NAS and identically mounted via NFS

    In the following screenshot you will see that there is a difference of 1 album but 40 files

    There are also differences in the Perl and Audio::Scan versions

    The question is how can I compare the 2 libraries to find where the difference lies i.e. has anyone any magic ideas?
    Export the album tables into excel and compare side by side?

    Name:  2021-01-18 15_49_30-Window.jpg
Views: 400
Size:  81.0 KB
    VB2.4 storage QNAP TS419p (NFS)
    Living Room Joggler & Pi4/Khadas -> Onkyo TXNR686 -> Celestion F20s
    Office Joggler & Pi3 -> Denon RCD N8 -> Celestion F10s
    Dining Room SB Boom
    Kitchen UE Radio (upgraded to SB Radio)
    Bedroom (Bedside) Pi Zero+DAC ->ToppingTP21 ->AKG Headphones
    Bedroom (TV) & Bathroom SB Touch ->Denon AVR ->Mordaunt Short M10s + Kef ceiling speakers
    Guest Room Joggler > Topping Amp -> Wharfedale Modus Cubes
    Everything controlled by iPeng & Material on iOS

  2. #2
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    4,012
    I would think you could open the database in a sql workbench. And write a query to do it.

    But likely the issue is the Audio::Scan version.

    Here is the change log.... https://metacpan.org/changes/distribution/Audio-Scan
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  3. #3
    Senior Member
    Join Date
    Feb 2011
    Location
    Cheshire, UK
    Posts
    5,728
    Quote Originally Posted by paul- View Post
    I would think you could open the database in a sql workbench. And write a query to do it.

    But likely the issue is the Audio::Scan version.

    Here is the change log.... https://metacpan.org/changes/distribution/Audio-Scan
    Thanks Paul
    VB2.4 storage QNAP TS419p (NFS)
    Living Room Joggler & Pi4/Khadas -> Onkyo TXNR686 -> Celestion F20s
    Office Joggler & Pi3 -> Denon RCD N8 -> Celestion F10s
    Dining Room SB Boom
    Kitchen UE Radio (upgraded to SB Radio)
    Bedroom (Bedside) Pi Zero+DAC ->ToppingTP21 ->AKG Headphones
    Bedroom (TV) & Bathroom SB Touch ->Denon AVR ->Mordaunt Short M10s + Kef ceiling speakers
    Guest Room Joggler > Topping Amp -> Wharfedale Modus Cubes
    Everything controlled by iPeng & Material on iOS

  4. #4
    Senior Member
    Join Date
    Feb 2011
    Location
    Cheshire, UK
    Posts
    5,728
    I found it - by pure chance.

    A Qobuz album - Crossroads Revisited , 40 tracks. As it is Qobuz that won't be anything to do with the Audio:Scan version difference.

    I did a clear and rescan on both LMS before posting so .....
    VB2.4 storage QNAP TS419p (NFS)
    Living Room Joggler & Pi4/Khadas -> Onkyo TXNR686 -> Celestion F20s
    Office Joggler & Pi3 -> Denon RCD N8 -> Celestion F10s
    Dining Room SB Boom
    Kitchen UE Radio (upgraded to SB Radio)
    Bedroom (Bedside) Pi Zero+DAC ->ToppingTP21 ->AKG Headphones
    Bedroom (TV) & Bathroom SB Touch ->Denon AVR ->Mordaunt Short M10s + Kef ceiling speakers
    Guest Room Joggler > Topping Amp -> Wharfedale Modus Cubes
    Everything controlled by iPeng & Material on iOS

  5. #5
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    6,624
    Quote Originally Posted by d6jg View Post
    I found it - by pure chance.

    A Qobuz album - Crossroads Revisited , 40 tracks. As it is Qobuz that won't be anything to do with the Audio:Scan version difference.

    I did a clear and rescan on both LMS before posting so .....
    Do other Qobuz albums appear on both machines?

    Sent from my Pixel 3a using Tapatalk

  6. #6
    Senior Member
    Join Date
    Feb 2011
    Location
    Cheshire, UK
    Posts
    5,728
    Quote Originally Posted by slartibartfast View Post
    Do other Qobuz albums appear on both machines?

    Sent from my Pixel 3a using Tapatalk
    Yes. Qobuz is otherwise complete on both instances of LMS
    VB2.4 storage QNAP TS419p (NFS)
    Living Room Joggler & Pi4/Khadas -> Onkyo TXNR686 -> Celestion F20s
    Office Joggler & Pi3 -> Denon RCD N8 -> Celestion F10s
    Dining Room SB Boom
    Kitchen UE Radio (upgraded to SB Radio)
    Bedroom (Bedside) Pi Zero+DAC ->ToppingTP21 ->AKG Headphones
    Bedroom (TV) & Bathroom SB Touch ->Denon AVR ->Mordaunt Short M10s + Kef ceiling speakers
    Guest Room Joggler > Topping Amp -> Wharfedale Modus Cubes
    Everything controlled by iPeng & Material on iOS

  7. #7
    Senior Member
    Join Date
    Feb 2011
    Location
    Cheshire, UK
    Posts
    5,728
    Done some more digging.
    It is a problem with this one album on Qobuz alone in conjunction with the older version of Audio::Scan on the Linux server vs Pi server.
    It’s OK on a third server also Pi but running a version of 8.1
    Basically the scanner doesn’t add it to my library.

    @michael - if you think this is worth investigating for others (I’m not bothered as moving fully to Pi shortly) then I will switch on scanner log and do a clear & rescan and submit results.

    It’s this particular album
    http://open.qobuz.com/album/0603497883530
    VB2.4 storage QNAP TS419p (NFS)
    Living Room Joggler & Pi4/Khadas -> Onkyo TXNR686 -> Celestion F20s
    Office Joggler & Pi3 -> Denon RCD N8 -> Celestion F10s
    Dining Room SB Boom
    Kitchen UE Radio (upgraded to SB Radio)
    Bedroom (Bedside) Pi Zero+DAC ->ToppingTP21 ->AKG Headphones
    Bedroom (TV) & Bathroom SB Touch ->Denon AVR ->Mordaunt Short M10s + Kef ceiling speakers
    Guest Room Joggler > Topping Amp -> Wharfedale Modus Cubes
    Everything controlled by iPeng & Material on iOS

  8. #8
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,530

    A conundrum - how to troubleshoot

    > @michael - if you think this is worth investigating for others (I’m not
    > bothered as moving fully to Pi shortly) then I will switch on scanner
    > log and do a clear & rescan and submit results.

    Please enable Qobuz logging instead. And upload the scanner.log to
    https://www.dropbox.com/request/T3RctyzGgNg0oFDubq6a

    --

  9. #9
    Senior Member
    Join Date
    Feb 2011
    Location
    Cheshire, UK
    Posts
    5,728
    Quote Originally Posted by mherger View Post
    > @michael - if you think this is worth investigating for others (I’m not
    > bothered as moving fully to Pi shortly) then I will switch on scanner
    > log and do a clear & rescan and submit results.

    Please enable Qobuz logging instead. And upload the scanner.log to
    https://www.dropbox.com/request/T3RctyzGgNg0oFDubq6a

    --

    Uploaded scanner.log zip
    I had a quick look and the album is found by the scanner but not put into library as far as I can see. Nothing in full text search.
    VB2.4 storage QNAP TS419p (NFS)
    Living Room Joggler & Pi4/Khadas -> Onkyo TXNR686 -> Celestion F20s
    Office Joggler & Pi3 -> Denon RCD N8 -> Celestion F10s
    Dining Room SB Boom
    Kitchen UE Radio (upgraded to SB Radio)
    Bedroom (Bedside) Pi Zero+DAC ->ToppingTP21 ->AKG Headphones
    Bedroom (TV) & Bathroom SB Touch ->Denon AVR ->Mordaunt Short M10s + Kef ceiling speakers
    Guest Room Joggler > Topping Amp -> Wharfedale Modus Cubes
    Everything controlled by iPeng & Material on iOS

  10. #10
    Senior Member
    Join Date
    Feb 2011
    Location
    Cheshire, UK
    Posts
    5,728
    Today I had occasion to re-look at this as the 2 servers became slightly more out of line than they were before - now 2 missing Qobuz albums

    I stumbled across the cause - it was the following "Play samples" setting in the Qobuz plugin.

    One of the two servers had it checked the other did not. I checked it ON on the server with 2 missing albums and rescanned and hey presto we now have the same numbers in both libraries BUT .....

    I already knew that one of the missing albums was "Crossroads Revisited by Eric Clapton" - having looked more carefully it doesn't have Samples but Qobuz state that the FLAC version is only available for purchase/download so its given me MP3 versions in my Library instead. I still don't know what the other missing album was.

    This suggests that the "Play samples" switch doesn't quite work as intended ????

    Name:  2021-02-24 15_56_30-Window.jpg
Views: 53
Size:  30.7 KB
    VB2.4 storage QNAP TS419p (NFS)
    Living Room Joggler & Pi4/Khadas -> Onkyo TXNR686 -> Celestion F20s
    Office Joggler & Pi3 -> Denon RCD N8 -> Celestion F10s
    Dining Room SB Boom
    Kitchen UE Radio (upgraded to SB Radio)
    Bedroom (Bedside) Pi Zero+DAC ->ToppingTP21 ->AKG Headphones
    Bedroom (TV) & Bathroom SB Touch ->Denon AVR ->Mordaunt Short M10s + Kef ceiling speakers
    Guest Room Joggler > Topping Amp -> Wharfedale Modus Cubes
    Everything controlled by iPeng & Material on iOS

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •