Home of the Squeezebox™ & Transporter® network music players.
Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15

Thread: phish.in plugin

  1. #11
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    3,994
    Phillipe,

    He mentions pCP7 in his prior posts, pCP is not using static binaries. OpenSSL on pCP7 is OpenSSL 1.1.1h.

    Paul.
    Last edited by paul-; 2021-01-16 at 17:45.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  2. #12
    Senior Member ralphy's Avatar
    Join Date
    Jan 2006
    Location
    Canada
    Posts
    2,835
    Quote Originally Posted by mherger View Post
    > I updated squeezelite to v1.9.8-1323-pCP and LMS to Logitech Media
    > Server Version: 8.1.2 - 1610697261 @ Fri Jan 15 10:43:41 CET 2021
    >
    > Tried again, same SSL error.


    Ok, you should probably ping Ralphy in a squeezelite specific thread then.

    In the meantime you could try to enable proxied streaming for the player
    (Settings/Player/Audio). That should work.

    --

    Michael
    Quote Originally Posted by jpm112 View Post
    I'm not entirely certain what the exact url is when playing tracks through the phish.in plugin - I tried looking in the squeezelite log and don't see anything. If you can guide me where to look, happy to try and provide more details.

    I can essentially reproduce very similar behavior when using the tune-in url to play tracks directly from the phish.in site.

    So using this as my test: https://phish.in/audio/000/017/386/17386.mp3


    With Player/Audio/Streaming Method = Direct Streaming, the track does not play, I get the SSL error. Log has:
    [12:17:42.344205] connect_socket:164 connecting to 104.21.64.233:443
    [12:17:42.374214] connect_socket:201 unable to open SSL socket -1 (1)

    With Player/Audio/Streaming Method = Proxied Streaming, the track plays fine.
    There's no way to disable SSL other than recompile squeezelite without it.

    It appears to be a specific phish.in server error as I can't download the mp3 using wget on pcp7 either using the resolved ip address the OP listed.

    ralphy@pcp7:~$ wget https://104.21.64.233/audio/000/017/386/17386.mp3
    Connecting to 104.21.64.233 (104.21.64.233:443)
    wget: error getting response: Connection reset by peer

    $ wget https://phish.in/audio/000/017/386/17386.mp3
    --2021-01-16 13:11:44-- https://phish.in/audio/000/017/386/17386.mp3
    Resolving phish.in... 172.64.90.2, 2606:4700:139:e765:71b2:585f:668f:c897
    Connecting to phish.in|172.64.90.2|:443... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 5246675 (5.0M) [audio/mpeg]
    Saving to: '17386.mp3'

    17386.mp3 100%[================================================== ================================================== ===>] 5.00M 526KB/s in 9.9s
    Ralphy

    1-Touch, 5-Classics, 3-Booms, 2-UE Radio
    Squeezebox client builds donations always appreciated.

  3. #13
    Senior Member ralphy's Avatar
    Join Date
    Jan 2006
    Location
    Canada
    Posts
    2,835
    Quote Originally Posted by philippe_44 View Post
    I think (not sure as @ralphy is controlling these and that option was not in my original SSL PR) that this build is with SSL static link. I've experienced some sites that now are very picky wrt TLS version and refuse anything a bit old and want the latest crypto suite. I don't know what SSL version the static build is linked against. Maybe there is something there.
    The picoreplayer build of squeezelite uses the pcp openssl library, it is not linked static.

    My other squeezelite builds have either openssl 1.1.1[ghi] included.
    Ralphy

    1-Touch, 5-Classics, 3-Booms, 2-UE Radio
    Squeezebox client builds donations always appreciated.

  4. #14
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    6,580
    Quote Originally Posted by ralphy View Post
    There's no way to disable SSL other than recompile squeezelite without it.

    It appears to be a specific phish.in server error as I can't download the mp3 using wget on pcp7 either using the resolved ip address the OP listed.

    ralphy@pcp7:~$ wget https://104.21.64.233/audio/000/017/386/17386.mp3
    Connecting to 104.21.64.233 (104.21.64.233:443)
    wget: error getting response: Connection reset by peer

    $ wget https://phish.in/audio/000/017/386/17386.mp3
    --2021-01-16 13:11:44-- https://phish.in/audio/000/017/386/17386.mp3
    Resolving phish.in... 172.64.90.2, 2606:4700:139:e765:71b2:585f:668f:c897
    Connecting to phish.in|172.64.90.2|:443... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 5246675 (5.0M) [audio/mpeg]
    Saving to: '17386.mp3'

    17386.mp3 100%[================================================== ================================================== ===>] 5.00M 526KB/s in 9.9s
    This probably isn't relevant but I can open that URL on my phone and also play from the Phish.in plugin with LMS on Raspbian.

    Sent from my Pixel 3a using Tapatalk

  5. #15
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    3,994
    You cannot open an ssl connection by IP address only. You need the host name for certificate validation.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •