Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1
    Junior Member
    Join Date
    Dec 2011
    Posts
    6

    Custom Clock Helper applet missing after factory reset

    I recently had to do a Factory Reset on my radio. In doing that I have lost the Custom Clock Helper applet and the screensaver configurations which I spent so much time creating. The radio's Applet Installer no longer offers the Custom Clock Helper nor is it listed on the LMS Plugins tab.

    The Custom Clock Helper applet is available on Erland's website; I downloaded it but have no idea how to manually install it, and his Wiki link fails to connect, so I don't know how to fix this.

    Any help will be greatly appreciated!

  2. #2
    Senior Member erland's Avatar
    Join Date
    Dec 2005
    Location
    Sweden
    Posts
    11,243
    Guess you are using LMS 8.0 or later ?
    In that case thatís the problem because my plugins arenít supported on 8.0 and later. See this post for more information about the current state and the options available: https://forums.slimdevices.com/showt...l=1#post998836

    They might still work if you are lucky but can break at any time. In LMS 8.1 itís possible to install Custom Clock Helper by activating the ďUse unsupported extensionĒ option in LMS Settings/Plugins, the alternative if you canít upgrade to 8.1 is to download and unzip the plugin in LMS Plugins directory but thatís not something I would recommend unless you know what you are doing.

    I think the Custom Clock applet should still be possible to install through Applet Installer as normal even if LMS 8.0 or later is used.
    Erland Isaksson (My homepage)
    Developer of many plugins/applets
    Starting with LMS 8.0 I no longer support my plugins/applets (see here for more information )

  3. #3
    Junior Member
    Join Date
    Dec 2011
    Posts
    6

    Thanks!

    Erland,

    Thanks for your reply and assistance. You were right that the problem happened with LMS 8. Shortly after posting this question, I reviewed the thread " Announce: New versions of erlands plugins" which was earlier of little interest since it was dated 2008-07-03. I also reviewed the thread "Installing plugins without regard to max version". Much too late, I learned of the LMS 8 vs LMS 7 problems with plugins.

    I have been able to download the Custom Clock Helper applet from the new "Unsupported" category and again have my screensavers back so I happy again. Thank you and Michael Herger for making them available.

    Regarding "They can break at any time". Is there anything specific about the Custom Clock Helper app vs the Custom Clock app that is subject to breaking? Would it remove or lessen the problem if I uninstalled the Helper app until I wanted to use it to make changes in my screensavers or create new ones?

    It seems to me that this kind of problem could be prevented by modifying the LMS Update notification to allow one to be informed about which version will be installed beforehand and aware of potential problems it might cause. I am posting a new topic under "LMS Update Notifications". I hope you will look it over.

    Thanks again.

  4. #4
    Senior Member erland's Avatar
    Join Date
    Dec 2005
    Location
    Sweden
    Posts
    11,243
    Quote Originally Posted by lsanders99 View Post
    Regarding "They can break at any time". Is there anything specific about the Custom Clock Helper app vs the Custom Clock app that is subject to breaking? Would it remove or lessen the problem if I uninstalled the Helper app until I wanted to use it to make changes in my screensavers or create new ones?
    There is no way to know what breaks them so I think your choices are:
    - Donít use any unsupported plugins/applets if you want to be safe.
    Or
    - Continue having unsupported plugins/applets installed until they break something

    Uninstalling the helper app will just make the situation worse because then you additionally also have the risk that it isnít available or canít easily be installed when you need it if you want to change something. The option to activate unsupported extensions works right now but there is no way to know if thatís going to be the case in the future.
    Erland Isaksson (My homepage)
    Developer of many plugins/applets
    Starting with LMS 8.0 I no longer support my plugins/applets (see here for more information )

  5. #5
    Junior Member
    Join Date
    Jan 2021
    Posts
    16
    Hello!
    I like very much Custom Clock Helper on my Radios, esp. 'Moon Clock (http://www.die.net/moon)'. Unfortunately this one not showing background http://static.die.net/moon/480.jpg
    While as I've checked - pic is av. online... Maybe someone knows how to bring back this moon phase background? FYI e.g 'Analog VU Meter' works great!
    I am on latest Logitech Media Server Version: 8.2.0 - 1610887865 + 8.0.1-r16824 Radio firmware...
    I know that this plugin isn't supported in LMS 8.0+ but maybe someone will have idea what may happened...
    Thanks in advance for your help!
    Last edited by L0O; 2021-01-17 at 16:45.

  6. #6
    Senior Member erland's Avatar
    Join Date
    Dec 2005
    Location
    Sweden
    Posts
    11,243
    Quote Originally Posted by L0O View Post
    Hello!
    I like very much Custom Clock Helper on my Radios, esp. 'Moon Clock (http://www.die.net/moon)'. Unfortunately this one not showing background http://static.die.net/moon/480.jpg
    While as I've checked - pic is av. online... Maybe someone knows how to bring back this moon phase background? FYI e.g 'Analog VU Meter' works great!
    I am on latest Logitech Media Server Version: 8.2.0 - 1610887865 + 8.0.1-r16824 Radio firmware...
    I know that this plugin isn't supported in LMS 8.0+ but maybe someone will have idea what may happened...
    Thanks in advance for your help!
    Unfortunately I think the die.net site have switched to only use https and Iím not sure this works with current version of Custom Clock applet. The url needs to be https://static.die.net/moon/480.jpg but I donít think that works with the current code since the http url seems to redirect to https already now so I suspect there is some limitation in the SqueezeOS/SqueezePlay code so it canít load a https url.

    Someone provided a fix for Daylight Clock applet in the following post for the same problem, not sure if that might give anyone some clue how to solve it. https://forums.slimdevices.com/showt...l=1#post979737

    Possibly there might be some http to https proxy site that could be used to read the url.
    Erland Isaksson (My homepage)
    Developer of many plugins/applets
    Starting with LMS 8.0 I no longer support my plugins/applets (see here for more information )

  7. #7
    Junior Member
    Join Date
    Jan 2021
    Posts
    16
    Thank you Erland for reply!
    I guessed too that it may be https. Thank you for link! Will try to re-make this hotfix for moon phases.

    edit:
    I guess it may be cloudflare service, moon pic is behind.
    Last edited by L0O; 2021-01-19 at 12:52. Reason: pic remove

  8. #8
    Junior Member
    Join Date
    Jan 2021
    Posts
    16
    Hello again
    I made more tests and http://static.die.net/moon/480.jpg works. (You can test it too in private browser window.)
    Unfortunately before page load there is smthng like that - picture below:

    Name:  check.jpg
Views: 53
Size:  33.2 KB

    Maybe someone have knowledge - can moon picture be used somehow if we know about this? Or it means rather it is not possible?

    Take care!
    LMS on RPi2 (OSMC) + SB3 + 3xRadio

  9. #9
    Senior Member erland's Avatar
    Join Date
    Dec 2005
    Location
    Sweden
    Posts
    11,243
    Quote Originally Posted by L0O View Post
    Hello again
    I made more tests and http://static.die.net/moon/480.jpg works. (You can test it too in private browser window.)
    Unfortunately before page load there is smthng like that - picture below:

    Name:  check.jpg
Views: 53
Size:  33.2 KB

    Maybe someone have knowledge - can moon picture be used somehow if we know about this? Or it means rather it is not possible?

    Take care!
    Hard to get passed it in a reliable way that works on longer terms but on shorter terms maybe something like this might work:
    https://stackoverflow.com/questions/...-by-cloudflare

    However, it might be possible to reach out to the site owner and see if itís possible to get permission to use it in an open source project. Maybe he/she is interested if he/she get credits for the work. If so, they can setup a rule so you get passed this page.
    Erland Isaksson (My homepage)
    Developer of many plugins/applets
    Starting with LMS 8.0 I no longer support my plugins/applets (see here for more information )

  10. #10
    Junior Member
    Join Date
    Jan 2021
    Posts
    16
    Hello erland!
    Thank you for answer, and sorry for bothering you with moon clock... :|

    I've found possibility to get this pic locally to my RPi (wget + browser cookie). Could be downloaded once per day, let's say at 12 AM (with cron).
    How to ask plugin to use this local picture instead of online one. Which file to edit to change this? (for Radio).

    Rgrds!
    Last edited by L0O; 2021-01-28 at 15:44.
    LMS on RPi2 (OSMC) + SB3 + 3xRadio

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •