Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 9 of 9
  1. #1
    Junior Member
    Join Date
    Apr 2021
    Posts
    19

    Nach nächtlichem Rescan Artworks der Mediendatenbank verschwunden.

    Hallo Community!

    Ich habe mit der aktuellen LMS-Version auf einem Rpi-4 folgendes Problem:

    Starte ich "Datenbank löschen und komplett neu durchsuchen", dann habe ich alle Covers meiner Musik sauber vorhanden.

    Läuft dann nachts ein Rescan über das Plugin "Autorescan" durch, mit Einstellung "Nach geänderten Dateien suchen", dann sind die Covers verschwunden...

    Ergänzende Infos:

    - Die Musik liegt auf einem Synology-Nas via SMB2/3.
    - Die Cover sind via ID3-Tag in die jeweiligen Tracks eingepflegt.
    - Es erscheint nach dem Rescan, anstatt des Covers, nur das graue Schallplattenbild.
    - Es sind vetschiedenste Alben betroffen (Kaufalben, als auch MP-3s mit händisch gepflegten ID3-Tags)

    Nach "komplett löschen und neu durchsuchen" sind die Cover zurück.

    Scheinbar zerlegt der Rescan "nach geänderten Dateien suchen" irgendwie die Cover-Arts. Wenn ich auf der LMS-Seite den jeweiligen Track anklicke, (im Player), so ist da in den Infos im ID3-Tag der Dateiname mit Auflösung zu sehen...

    Ist das ein bekannter Bug?

    Viele Grüße!

    Gesendet von meinem SM-A530F mit Tapatalk
    Last edited by torbes; 2021-11-25 at 06:53.

  2. #2
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,719

    =?utf-8?q?Nach_n=C3=A4chtlichem_Rescan_Artworks_d?==?utf-8?q?er_Mediendatenbank_verschwunden=2E?=

    > Ist das ein bekannter Bug?

    Nein. Überprüfe doch mal deine scanner.log und server.log Dateien.

  3. #3
    Junior Member
    Join Date
    Apr 2021
    Posts
    19
    Ups, die obligatorischen Schritte... Hätte ich auch selber draufkommen können :-/

    Werde ich machen und mich umgehend zurückmelden

    Danke derweil!

    Grüße, Tob

    Gesendet von meinem SM-A530F mit Tapatalk

  4. #4
    Junior Member
    Join Date
    Apr 2021
    Posts
    19
    So, da bin ich wieder ;-)

    Leider zeigt sich in den Logfiles nichts aussergewöhnliches, ich konnte keinerlei Fehlermeldungen in der Server.log und der Scanner.log finden, die auf mein Problem hindeuten.


    Nach einem vollständigen Rescan mit vorherigem Löschen der Datenbank sieht es so aus:

    Name:  Covers-vorhanden.png
Views: 48
Size:  133.9 KB

    Hier das zugehörige Scanergebnis:

    Name:  Full_Scan.png
Views: 48
Size:  75.2 KB


    Nachdem ich einen Scan nach geänderten oder neuen Dateien durchgeführt habe:

    Name:  After-Rescan.png
Views: 48
Size:  100.6 KB

    Das zugehörige Scanergebnis:

    Name:  Rescan.png
Views: 48
Size:  68.7 KB

    Im Anhang noch die Scanner.log und die Server.log

    Es hat also wohl nichts mit dem automatischen Rescan via Plugin Nachts zu tun, sondern generell mit einem Scan nach geänderten oder neuen Dateien.

    Das ganze bezieht sich auch auf andere Ordner, bis auf wenige Artworks ist nach dem Rescan alles verschwunden, um nach einem Vollständigen Scan und Neuaufbau der Datenbank wieder vorhanden zu sein...

    Ich bin etwas ratlos

    MFG

    Tob
    Attached Files Attached Files

  5. #5
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,719

    =?utf-8?q?Nach_n=C3=A4chtlichem_Rescan_Artworks_d?==?utf-8?q?er_Mediendatenbank_verschwunden=2E?=

    Die server.log fehlt leider (oder eher die server.log.zip).

    Haben denn die Dateien Album Informationen? Auf dem ersten Screenshot
    ist kein Album ersichtlich. Das könnte dazu führen, dass alle Dateien,
    die keine Albuminfos haben als ein und dasselbe Album gelten. Und dann
    wird von irgend einer Datei das Titelbild genommen.

  6. #6
    Junior Member
    Join Date
    Apr 2021
    Posts
    19
    Leider hat mir die 5-Dateien-Regelung des Forums die Server.log abgezwickt :-(

    Jetzt aber:

    ;-)

    Richtig, die Tracks haben allesamt keine Album-Namen, da es sich um Mixsammlungen handelt, die ich händisch einst selbst "zusammenkopiert" habe...

    Kann das wirklich die Ursache sein? Und wieso klappt es dann beim kompletten Rescan?

    Danke dir Michael für deine flotte und umkomplizierte Hilfe....

    Wenn das wirklich die Ursache ist, muss ich wohl mal nen Urlaub zum Nachpflegen opfern ;-)
    Attached Files Attached Files

  7. #7
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,719

    =?utf-8?q?Nach_n=C3=A4chtlichem_Rescan_Artworks_d?==?utf-8?q?er_Mediendatenbank_verschwunden=2E?=

    > Richtig, die Tracks haben allesamt keine Album-Namen, da es sich um
    > Mixsammlungen handelt, die ich h�ndisch einst selbst "zusammenkopiert"
    > habe...


    Das ist grundsätzlich ein Problem, weil dann LMS die Infos fehlen, wie
    es Alben zusammenfassen soll. Es versucht dies dann auf Grund des
    Ordnernamens oder so zu machen, ist aber problematisch.

    Im log sehe ich zahlreiche dieser Einträge:

    [21-11-24 18:06:45.1034] Slim::Utils::Misc::msg (1341) Warning:
    [18:06:45.1030] Could not open
    /media/Mediaserver/Server-Media/Audio/Trance/Nifra - Rebel Radio/Rebel
    Radio - 034 with Nifra - DI.FM.mp3 for reading: Stale file handle
    [21-11-24 18:08:27.4522] Slim::Utils::Misc::msg (1341) Warning:
    [18:08:27.4514] Could not open
    /media/Mediaserver/Server-Media/Audio/Trance/Nifra - Rebel Radio/Rebel
    Radio - 034 with Nifra - DI.FM.mp3 for reading: Stale file handle

    Werden die Dateien im Betriebe überschrieben? Entfernt? Oder falls es
    sich um eine Netzwerkverbindung handelt: bestehen hin und wieder
    Netzwerkunterbrüche? Z.B. geht das NAS nachts schlafen, wenn der Scan
    läuft, aber tagsüber, wenn du denn Vollscan manuell startest, ist es online?

    --

  8. #8
    Junior Member
    Join Date
    Apr 2021
    Posts
    19
    Hallo Michael

    Die Einträge kann ich erklären, da hat der Player wohl versucht, diese Dateien aus der Playlist abzuspielen, während ich sie temporär vom NAS auf den PC verschoben habe, um die Cover nochmal neu reinzubasteln... Das war also ein Userfehler...

    Ok, dann werde ich mal sämtlichen Ordnern ein Album verpassen und Rückmeldung geben ;-)

    Danke derweil für die Hilfe!

    Gesendet von meinem SM-A530F mit Tapatalk

  9. #9
    Junior Member
    Join Date
    Apr 2021
    Posts
    19
    So, wie zu erwarten war Michaels Vermutung korrekt:

    Nachdem ich meinen Mix-Dateien in den Ordnern einen Albumeintrag in den ID3-Tags verpasst habe, bleiben auch die Cover-Arts nach einem Rescan problemlos erhalten.

    Es bleibt also die alte Regel:

    Das A und O sind gut gepflegte ID3-Tags :-)

    Danke nochmal für die flotte und unkomplizierte Hilfe :-)

    Viele Grüße,

    Tob!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •