Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 3 of 3
  1. #1
    Junior Member
    Join Date
    Feb 2020
    Posts
    3

    picorePlayer LMS CLI issue

    Hello,

    According to picorePlayer docs https://docs.picoreplayer.org/information/pcp_cli/ I can use CLI commands to do some basic stuff like play and pause the music or backup stuff.

    If I run pcp bu which sends a backup command to picore itself it works
    But if I run pcp play which sends the command to LMS I get wget: server returned error: HTTP/1.1 401 Unauthorized

    What am I doing wrong? From PicorePlayer's web interface I can see it has access to the LMS CLI (on page Main Page > Extra > LMS CLI) so I don't understand why I'm not authorized from the CLI.

    Any help would be really appreciated.

    Thank you.

    piCorePlayer version: 7.0.1

  2. #2
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    4,499
    Check your security setting in LMS. Likely have it set to high to allow.

    We are using the http/json interfaceůů. Not the cli
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  3. #3
    Junior Member
    Join Date
    Feb 2020
    Posts
    3
    Thank you for pointing me in the right direction. I should have guessed

    I did set up a password but I was assuming pcp had a way to grab it and use it as needed. After checking I can see that with a password, pcp player commands on the web interface also don't work so I guess that gives it away.

    Thank you again.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •