Home of the Squeezebox™ & Transporter® network music players.
Page 96 of 107 FirstFirst ... 46869495969798106 ... LastLast
Results 951 to 960 of 1070
  1. #951
    Junior Member
    Join Date
    Apr 2021
    Posts
    5
    Thank you. This would be great.

    I am immensely impressed about the enthusiasts working on this great project.

    Best regards,

    Roland.

  2. #952
    Senior Member
    Join Date
    Jan 2006
    Location
    South Coast, NSW, Australia
    Posts
    1,288
    Quote Originally Posted by paul- View Post
    You can, but none of the dependencies are met with python2 on pCP. I just had a conversation with their dev team last week. Python2 is over a year past EOL, quit using it. They have made the updates for python3. They are doing a bit more testing before releasing the python3 version of thier OLED scripts.

    The dependencies are heavy.....about 25MB of Programs and libraries.

    python3.8-Pillow.tcz
    python3.8-smbus.tcz
    python3.8-rpi-gpio.tcz

    I would watch their github for when it gets posted.
    Allo have released their OLED display scripts for their Boss2 player and they work on pCP 7 32bit, but do not work on the 64bit pCP 7.
    A camel is a racehorse designed by a committee.

    Seen sprayed on the outside wall of the local library -
    Three things I hate in life :
    1. Vandalism
    2. Irony
    3. Lists

  3. #953
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    4,062
    I know, I was working on it this weekend. My power was out for a few hours on Sunday, and didn't get to find the library issue on x64 yet. When I get the opportunity, I'm going to package up application and automate the install a bit.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  4. #954
    Senior Member
    Join Date
    Jan 2006
    Location
    South Coast, NSW, Australia
    Posts
    1,288
    Quote Originally Posted by paul- View Post
    I know, I was working on it this weekend. My power was out for a few hours on Sunday, and didn't get to find the library issue on x64 yet. When I get the opportunity, I'm going to package up application and automate the install a bit.
    Thanks for that info Paul.

    Have you got a Boss2 ? If so, what are your Squeezelite settings ? I have -
    Output Setting - plughw:CARD=Boss2,DEV=0
    Unmute ALSA control - Master

    the rest are default.
    A camel is a racehorse designed by a committee.

    Seen sprayed on the outside wall of the local library -
    Three things I hate in life :
    1. Vandalism
    2. Irony
    3. Lists

  5. #955
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    4,062
    No I do not, which make software developing even more fun.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  6. #956
    Senior Member
    Join Date
    Jan 2006
    Location
    South Coast, NSW, Australia
    Posts
    1,288
    Quote Originally Posted by paul- View Post
    No I do not, which make software developing even more fun.
    If it would help, I could send my Boss 2 to Greg Erskine.

    I waited 3 weeks after ordering before my one arrived, it spent 15 days at Mumbai waiting to be put on a plane to Australia and I have read that things are pretty grim over there now with flights in and out even more restricted.

    Otherwise if you want me to try out a script either pm me or post in this thread or a new Allo Boss2 thread.
    A camel is a racehorse designed by a committee.

    Seen sprayed on the outside wall of the local library -
    Three things I hate in life :
    1. Vandalism
    2. Irony
    3. Lists

  7. #957
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    4,185
    I have seen that some MP4 streams were not playing - LMS 8.1.2 to variety of players.

    The issue might well disappear with LMS 8.2 and its internal MP4 support - but with LMS 8.1.2 I think it can be solved by a rebuild of ffmpeg.

    I tried a stream URL from command line on pCP and the error from ffmpeg is
    https protocol not found, recompile FFmpeg with openssl, gnutls or securetransport enabled.

    Is it feasible to rebuild ffmpeg or does it become too large?
    Paul Webster
    http://dabdig.blogspot.com
    Author of "Now Playing" plugins covering Radio France (FIP etc), PlanetRadio (Bauer - Kiss, Absolute, Scala, JazzFM etc), KCRW, Supla Finland, ABC Australia, CBC/Radio-Canada and RTE Ireland

  8. #958
    Senior Member ralphy's Avatar
    Join Date
    Jan 2006
    Location
    Canada
    Posts
    2,856
    Quote Originally Posted by Paul Webster View Post
    I have seen that some MP4 streams were not playing - LMS 8.1.2 to variety of players.

    The issue might well disappear with LMS 8.2 and its internal MP4 support - but with LMS 8.1.2 I think it can be solved by a rebuild of ffmpeg.

    I tried a stream URL from command line on pCP and the error from ffmpeg is
    https protocol not found, recompile FFmpeg with openssl, gnutls or securetransport enabled.

    Is it feasible to rebuild ffmpeg or does it become too large?
    It shouldn't increase the size much as we already have the openssl shared libraries.

    I'll try building ffmpeg with openssl support and report back.
    Last edited by ralphy; 2021-04-14 at 05:37.
    Ralphy

    1-Touch, 5-Classics, 3-Booms, 2-UE Radio
    Squeezebox client builds donations always appreciated.

  9. #959
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    20,424
    Quote Originally Posted by Paul Webster View Post
    I have seen that some MP4 streams were not playing - LMS 8.1.2 to variety of players.
    Can you give examples. There are lots of options/aternatives within MP4 and the more that are documented - the more that canbe made playable.

  10. #960
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    4,185
    Resolved - see post from today ... it was ffmpeg on pCP cannot handle https because it was not built with the libraries - so ffmpeg did not even get as far as trying to play it.
    Paul Webster
    http://dabdig.blogspot.com
    Author of "Now Playing" plugins covering Radio France (FIP etc), PlanetRadio (Bauer - Kiss, Absolute, Scala, JazzFM etc), KCRW, Supla Finland, ABC Australia, CBC/Radio-Canada and RTE Ireland

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •