Home of the Squeezebox™ & Transporter® network music players.
Page 80 of 99 FirstFirst ... 3070787980818290 ... LastLast
Results 791 to 800 of 990
  1. #791
    Senior Member ralphy's Avatar
    Join Date
    Jan 2006
    Location
    Canada
    Posts
    2,841
    Quote Originally Posted by pgf View Post
    I have a program that I've been running for years on various systems which, when built on picoreplayer, surprised me with a segfault. I went looking for gdb, and ... was surprised again. :-) Is gdb hidden in some unexpected extension?

    My system version is: piCorePlayer v7.0.0 | www v00011 | linux 5.4.83-pcpCore-v7 | piCore v12.0pCP | Squeezelite v1.9.8-1287-pCP

    Also -- in case the fault is toolchain-related, I assume that "compiletc.tcz" is the right toolchain, for this version of the system, right?

    I'll find the fault with successive printf's eventually, but a debugger would be convenient.
    Yes, that is the right toolchain.

    I built a gdb extention for pcp 6 last year as there wasn't one available from the tinycore 10.x repository, but it seems to work okay on pcp 7 32bit only.
    If you don't find gdb in the tinycore 12.x repository you can try mine. It's not in our picoreplayer repository, so you'll need to install it manually.

    Login as the tc user and run the commands in bold.

    Code:
    tc@pcp7:~$ ceo
    
    tc@pcp7:/mnt/sda2/tce/optional$ wget -q http://ralph-irving.users.sourceforge.net/pico/gdb.tcz.md5.txt
    
    tc@pcp7:/mnt/sda2/tce/optional$ wget -q http://ralph-irving.users.sourceforge.net/pico/gdb.tcz
    
    tc@pcp7:/mnt/sda2/tce/optional$ md5sum -c gdb.tcz.md5.txt
    gdb.tcz: OK
    
    tc@pcp7:/mnt/sda2/tce/optional$ tce-load -i gdb.tcz
    gdb installed!
    
    tc@pcp7:~$ gdb
    GNU gdb (GDB) 9.2
    Copyright (C) 2020 Free Software Foundation, Inc.
    License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
    This is free software: you are free to change and redistribute it.
    There is NO WARRANTY, to the extent permitted by law.
    Type "show copying" and "show warranty" for details.
    This GDB was configured as "armv7l-unknown-linux-gnueabihf".
    Type "show configuration" for configuration details.
    For bug reporting instructions, please see:
    <http://www.gnu.org/software/gdb/bugs/>.
    Find the GDB manual and other documentation resources online at:
        <http://www.gnu.org/software/gdb/documentation/>.
    
    For help, type "help".
    Type "apropos word" to search for commands related to "word".
    (gdb)
    Last edited by ralphy; 2021-02-27 at 07:58.
    Ralphy

    1-Touch, 5-Classics, 3-Booms, 2-UE Radio
    Squeezebox client builds donations always appreciated.

  2. #792
    Thanks -- last time I tried to get something from the tinycore repo I had trouble finding a download link. I think I was successful eventually, though -- oh, I remember, I had to go to a mirror -- I'll try that. Thanks!

    paul (a different one.)

  3. #793
    Senior Member ralphy's Avatar
    Join Date
    Jan 2006
    Location
    Canada
    Posts
    2,841
    The squeezelite extension has been updated to v1.9.9.1364 to support the new Balance control.

    The new feature requires LMS 8.2.0-1614413430 from February 27th 2021 or newer then in the middle of the LMS Player Audio Settings adjust the Balance slider and click Apply.

    Name:  balance.jpg
Views: 346
Size:  12.1 KB

    Thanks to philippe44 for both the LMS feature and squeezelite change.
    Ralphy

    1-Touch, 5-Classics, 3-Booms, 2-UE Radio
    Squeezebox client builds donations always appreciated.

  4. #794
    Senior Member Tony T's Avatar
    Join Date
    Nov 2009
    Posts
    1,147
    I have a very minor issue that may have started with 7.0, but may also be a pi4 issue.
    If I have a power failure, when power is restored pCp does not start up. I need to manually reboot the pi4 (by unplugging / replugging the power) to get pCp to start again.
    Anyone else have this occur?
    Tony
     SBTouch ♪ SBRadio ♬

  5. #795
    Senior Member Greg Erskine's Avatar
    Join Date
    Sep 2006
    Location
    Sydney, Australia
    Posts
    2,211
    I don't think its normal.

    What's different with your setup?

  6. #796
    Senior Member Tony T's Avatar
    Join Date
    Nov 2009
    Posts
    1,147
    Quote Originally Posted by Greg Erskine View Post
    I don't think its normal.

    What's different with your setup?
    System is a Pi4, Ethernet, WiFi disabled, attached HD with the FLAC files, powered by the Pi.
    Tony
     SBTouch ♪ SBRadio ♬

  7. #797
    Senior Member Greg Erskine's Avatar
    Join Date
    Sep 2006
    Location
    Sydney, Australia
    Posts
    2,211
    I *think* this may be an issue that your router is not up before LMS tries to start.

    LMS needs to set the time using ntpd. This has been discussed a few times before.

    https://forums.slimdevices.com/showt...ull=1#post924=[-4768

  8. #798
    Senior Member Tony T's Avatar
    Join Date
    Nov 2009
    Posts
    1,147
    Quote Originally Posted by Greg Erskine View Post
    I *think* this may be an issue that your router is not up before LMS tries to start.

    LMS needs to set the time using ntpd. This has been discussed a few times before.

    https://forums.slimdevices.com/showt...ull=1#post924=[-4768
    Yes, could be the router not being up before the Pi is up as I have the Pi on Ethernet with WiFi off.
    (And it’s not just LMS not being up, tc is not assessable via ssh either.)
    Shouldn’t be nfpd though, as the only effect with that would be the date/time not being set (I’ve had that happen a few times).
    Last edited by Tony T; 2021-02-28 at 18:24.
    Tony
     SBTouch ♪ SBRadio ♬

  9. #799
    Senior Member
    Join Date
    May 2009
    Posts
    100

    RPI4 won't boot after power off

    Currently I use rpi4b as Player/Server and twice yesterday I was unable to boot up after power off.

    This is a different pi to the one that had a dodgy sd receptacle. This has been rock steady until I powered it in my husband's office.

    I realize now he has been switching it off at the mains, and it may happen again. I completely reinstalled once yesterday, can I avoid it by using the backup?

    How can I see the backup file using Windows when only the boot folder is visible? How do I recover a working system?

    Since posting I have installed the Windows Subsystem for Linux, so I'll probably install ubuntu via console
    Last edited by Patricia P; 2021-03-01 at 04:09.
    SB Touch (Community firmware v8.01) UE Radio, CA DacMagic, Talk Electronic stereo. LMS 8.2 Snakeoil OS, HP t520 thin client.
    BBCiPlayer, BBC Sounds, Shairtunes2 plugins, edo applet

  10. #800
    Senior Member
    Join Date
    Jan 2011
    Location
    Staffordshire. UK
    Posts
    4,261
    Quote Originally Posted by Patricia P View Post
    Currently I use rpi4b as Player/Server and twice yesterday I was unable to boot up after power off.

    This is a different pi to the one that had a dodgy sd receptacle. This has been rock steady until I powered it in my husband's office.

    I realize now he has been switching it off at the mains, and it may happen again. I completely reinstalled once yesterday, can I avoid it by using the backup?

    How can I see the backup file using Windows when only the boot folder is visible? How do I recover a working system?

    Since posting I have installed the Windows Subsystem for Linux, so I'll probably install ubuntu via console
    You can now make an image (Main Page > Additional functions > SDCard Image)

    https://forums.slimdevices.com/showt...=1#post1008731

    and copy it to a Windows folder using WINSCP

    Name:  winscp.png
Views: 167
Size:  91.9 KB

    ronnie
    Last edited by Man in a van; 2021-03-01 at 04:36.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •