Home of the Squeezebox™ & Transporter® network music players.
Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14
  1. #11
    Senior Member
    Join Date
    Mar 2011
    Posts
    179
    Quote Originally Posted by Stone Free View Post
    Hi, I found Stuart's Github page https://github.com/hickinbottoms/lazysearch and it seems to show on its Releases page that there is a reference to version 3.6.7 that says "Bump compatibility for LMS 8.1", I've also checked the repo.xml referenced at the beginning of this thread and it now lists Version 3.6.7, however I still can't see Stuart's plugin.

    Please can someone make the relevant changes to make this appear again in the list of plugins. Stuart does seem to be supporting it, so I imagine it needs to go on a different list as it does indeed seem to be supported.
    i was fiddeling around with it, i've forked it......
    My problem was, i only discover the name and thought, oh sounds interesting and just didn't understand what exactly this "lazysearch" was doing. So i had it running in 8.2 but wasn't able to check the functionality. Can you explain, then i can look again if i'm able to get it going.

  2. #12
    Senior Member kidstypike's Avatar
    Join Date
    Feb 2007
    Location
    Brindle
    Posts
    4,518
    Quote Originally Posted by mamema View Post
    i was fiddeling around with it, i've forked it......
    My problem was, i only discover the name and thought, oh sounds interesting and just didn't understand what exactly this "lazysearch" was doing. So i had it running in 8.2 but wasn't able to check the functionality. Can you explain, then i can look again if i'm able to get it going.
    Plugin is only for Squeezeboxen with a VDU display - Boom, Classic, Transporter, etc. On the IR remote the number/letter keys act like on old mobile phones, pressing "A" 3 times the menu will jump to ABBA etc..
    Server - LMS 8.2.0 Pi4B 4GB/Argon one case/pCP v7.0.1 - 75K library, playlists & LMS cache on SSD (ntfs)
    Study - Pi4/pCP 7.0.1/Topping E30 DAC/Ruark MR1 Mk2
    Lounge - Pi2/pCP 6.0.0 > HiFiBerry DIGI+ > AudioEngine DAC1 > AVI DM5
    Dining Room - Pi3B/pCP/Bluetooth/Echo Show 8
    Garage - DAC32 > Edifier speakers

    Spares - 2xTouch, 1xSB Radio. 1xSB3, 6xRPi

  3. #13
    Quote Originally Posted by mamema View Post
    i was fiddeling around with it, i've forked it......
    My problem was, i only discover the name and thought, oh sounds interesting and just didn't understand what exactly this "lazysearch" was doing. So i had it running in 8.2 but wasn't able to check the functionality. Can you explain, then i can look again if i'm able to get it going.
    What did you do to get it installed?

    I see AutoRescan showing up in the list of plugins which is also one of stuarts. I had a look in stuart's XML file, and so that if I on windows I ran
    Code:
    certutil -hashfile filename SHA1
    and the result is
    Code:
    c4dbae85151895d8ff47544b35d7f4de4f76690f
    which is the value in the sba tag in the xml for AutoRescan.

    I then tried the same on the LazySearch2-7-3.6.7.zip which resulted in
    Code:
    c4dbae85151895d8ff47544b35d7f4de4f76690
    . It also matches the sba tag in the same repo xml.

    However even if I remove the repo.xml from the additional repositories AutoRescan shows up regardless, so I don't think the XML repo file is helping at all

  4. #14
    Quote Originally Posted by erland View Post
    If original developer don’t plan to update it someone would have to manually download install it in “Plugins” directory and possibly modify the install.xml bundled in the plugin to say maxVersion=* and after this verify that it works in latest LMS version. After this a pull request can be created to add it to the list of unsupported plugins:
    https://github.com/LMS-Community/lms...nsupported.xml
    When this has been done it can be installed in 8.1 and later if usage of unsupported extensions has been activated.

    If the person verifying it don’t know how to create a pull request you can probably just mention in this thread that you have verified that it works and someone else might be able to help creating the pull request.

    Before creating the pull request make sure to check with the original developer if he plans to provide a supported version for 8.1
    Can anyone do this for me? I can't really understand why its not showing up seeing as the repo.xml has been updated appropriately. I don't know how to get any further on my own.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •