Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 9 of 9
  1. #1

    Lazy Search 2 Not showing in list of plugins

    Hi, I've seen that this needs to be updated to work with Logitech Media Server Version: 8.1.0. The old one is showing as not compatible, however when I add the repo
    Code:
    http://www.hickinbottom.com/sc-plugins/repo.xml
    nothing extra shows up, so I can't see it for installation.

    Please can someone tell me how to get the correct version, as the squeezebox is pretty unusable without the plugin

  2. #2
    Senior Member kidstypike's Avatar
    Join Date
    Feb 2007
    Location
    Brindle
    Posts
    4,277
    Quote Originally Posted by Stone Free View Post
    Hi, I've seen that this needs to be updated to work with Logitech Media Server Version: 8.1.0. The old one is showing as not compatible, however when I add the repo
    Code:
    http://www.hickinbottom.com/sc-plugins/repo.xml
    nothing extra shows up, so I can't see it for installation.

    Please can someone tell me how to get the correct version, as the squeezebox is pretty unusable without the plugin
    Using LMS 8.0.1 here, LazySearch2 is showing for me under 3rd party plugins, no repository needed.

    Do you need to be using LMS 8.1.0?
    Server - LMS 8.2.0 Pi4B 4GB/Argon one case/pCP v7.0.1 - 75K library, playlists & LMS cache on SSD (ntfs)
    Study - Pi3B/pCP 7.0.1/pi screen/Hifiberry DAC HAT Ruark MR1 Mk2
    Lounge - Pi2/pCP 6.0.0 > HiFiBerry DIGI+ > AudioEngine DAC1 > AVI DM5
    Garage - Squeezebox Boom + Fostex sub
    Dining Room - Pi3B/Bluetooth/Echo Show 8

    Spares - 2xTouch, 1xSB Radio. 1xSB3, 6xRPi

  3. #3
    Hi this is the version I'm on I can't see it anywhere.
    Code:
    Logitech Media Server Version: 8.1.0 - 1608617210 @ Tue Dec 22 08:12:15 CET 2020
    Hostname: PetersNAS
    Server IP Address: 192.168.1.6
    Server HTTP Port Number: 9001
    Operating system: QLMS 2.X (QNAP TurboStation) [Debian 9 stretch] - EN - utf8
    Platform Architecture: armv5tel-linux
    Perl Version: 5.20.3 - arm-linux-gnueabi-thread-multi-64int
    Audio::Scan: 0.95
    IO::Socket::SSL: 2.060
    Database Version: DBD::SQLite 1.34_01 (sqlite 3.7.7.1)
    Total Players Recognized: 1

  4. #4
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    6,174
    Quote Originally Posted by kidstypike View Post
    Using LMS 8.0.1 here, LazySearch2 is showing for me under 3rd party plugins, no repository needed.

    Do you need to be using LMS 8.1.0?
    Max target for the plugin is
    maxTarget="8.0+"
    Does that include 8.1?

    Sent from my Pixel 3a using Tapatalk

  5. #5
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,521

    Lazy Search 2 Not showing in listof plugins

    > maxTarget="8.0+"
    > Does that include 8.1?


    I believe 8.0+ would only accept 8.0.x, but not 8.1.x. A "max = 8 and
    later" doesn't make sense.

    --

    Michael

  6. #6
    Senior Member kidstypike's Avatar
    Join Date
    Feb 2007
    Location
    Brindle
    Posts
    4,277
    Quote Originally Posted by slartibartfast View Post
    Max target for the plugin is
    maxTarget="8.0+"
    Does that include 8.1?

    Sent from my Pixel 3a using Tapatalk
    LazySearch2 plugin doesn't show in the list when running LMS v8.1.0.
    Server - LMS 8.2.0 Pi4B 4GB/Argon one case/pCP v7.0.1 - 75K library, playlists & LMS cache on SSD (ntfs)
    Study - Pi3B/pCP 7.0.1/pi screen/Hifiberry DAC HAT Ruark MR1 Mk2
    Lounge - Pi2/pCP 6.0.0 > HiFiBerry DIGI+ > AudioEngine DAC1 > AVI DM5
    Garage - Squeezebox Boom + Fostex sub
    Dining Room - Pi3B/Bluetooth/Echo Show 8

    Spares - 2xTouch, 1xSB Radio. 1xSB3, 6xRPi

  7. #7
    Junior Member
    Join Date
    Aug 2009
    Location
    Scotland
    Posts
    26
    Quote Originally Posted by kidstypike View Post
    LazySearch2 plugin doesn't show in the list when running LMS v8.1.0.
    And if it was installed when you upgraded to 8.1, you get a: "Plugin in incompatible with this version of Logitech Media server. Please update." in the description field on the Plugins page.

  8. #8
    So is there any way to get it to work with version 8.1?

  9. #9
    Senior Member erland's Avatar
    Join Date
    Dec 2005
    Location
    Sweden
    Posts
    11,229
    Quote Originally Posted by Stone Free View Post
    So is there any way to get it to work with version 8.1?
    If original developer don’t plan to update it someone would have to manually download install it in “Plugins” directory and possibly modify the install.xml bundled in the plugin to say maxVersion=* and after this verify that it works in latest LMS version. After this a pull request can be created to add it to the list of unsupported plugins:
    https://github.com/LMS-Community/lms...nsupported.xml
    When this has been done it can be installed in 8.1 and later if usage of unsupported extensions has been activated.

    If the person verifying it don’t know how to create a pull request you can probably just mention in this thread that you have verified that it works and someone else might be able to help creating the pull request.

    Before creating the pull request make sure to check with the original developer if he plans to provide a supported version for 8.1
    Erland Isaksson (My homepage)
    Developer of many plugins/applets
    Starting with LMS 8.0 I no longer support my plugins/applets (see here for more information )

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •