Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 5 123 ... LastLast
Results 1 to 10 of 44
  1. #1
    Member
    Join Date
    Aug 2015
    Location
    Germany
    Posts
    33

    LMS 8.0.0 running, but does not play files

    I have a problem with my music files on my Synology DS218+ NAS, Version: 8.0.0 - 1605892076 @ Fri Nov 20 18:28:44 CET 2020,

    All my music files are shown completely in disorder, some are shown two times.

    When I try to play files I get the followin[I]g error message comes up
    [20-12-02 21:32:57.1729] Slim::Formats::loadTagFormatForType (120) Error: Couldn't load module: (cur) : [syntax error at (eval 1468) line 1, at EOF][/I]
    and I cannot play any file.

    The only thing I have changed was that I added a ripped CD to my files and rescanned my library. Then I got these problems. Does anybody have a clue what is wrong?

  2. #2
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    19,923
    Quote Originally Posted by Tapaballou View Post
    I have a problem with my music files on my Synology DS218+ NAS, Version: 8.0.0 - 1605892076 @ Fri Nov 20 18:28:44 CET 2020,

    All my music files are shown completely in disorder, some are shown two times.

    When I try to play files I get the followin[I]g error message comes up
    [20-12-02 21:32:57.1729] Slim::Formats::loadTagFormatForType (120) Error: Couldn't load module: (cur) : [syntax error at (eval 1468) line 1, at EOF][/I]
    and I cannot play any file.

    The only thing I have changed was that I added a ripped CD to my files and rescanned my library. Then I got these problems. Does anybody have a clue what is wrong?
    I htink this is a Castbridge plugin problems not a LMS one.

    Show the rest of the entries in server.log

  3. #3
    Member
    Join Date
    Aug 2015
    Location
    Germany
    Posts
    33
    Quote Originally Posted by bpa View Post
    I htink this is a Castbridge plugin problems not a LMS one.

    Show the rest of the entries in server.log
    I have tried today again and get the following server.log

    [20-12-03 09:19:34.0097] Slim::Formats::loadTagFormatForType (120) Backtrace:

    frame 0: Slim::Utils::Log::logBacktrace (/volume1/@appstore/SqueezeCenter/Slim/Formats.pm line 120)
    frame 1: Slim::Formats::loadTagFormatForType (/volume1/@appstore/SqueezeCenter/Slim/Player/Protocols/File.pm line 409)
    frame 2: Slim::Player::Protocols::File::canSeek (/volume1/@appstore/SqueezeCenter/Slim/Player/Song.pm line 821)
    frame 3: Slim::Player::Song::canDoSeek (/volume1/@appstore/SqueezeCenter/Slim/Player/Song.pm line 791)
    frame 4: Slim::Player::Song::canSeek (/volume1/@appstore/SqueezeCenter/Slim/Player/Song.pm line 391)
    frame 5: Slim::Player::Song:pen (/volume1/@appstore/SqueezeCenter/Slim/Player/StreamingController.pm line 1228)
    frame 6: Slim::Player::StreamingController::_Stream (/volume1/@appstore/SqueezeCenter/Slim/Player/StreamingController.pm line 287)
    frame 7: Slim::Player::StreamingController::_eventAction (/volume1/@appstore/SqueezeCenter/Slim/Player/StreamingController.pm line 746)
    frame 8: Slim::Player::StreamingController::_nextTrackReady (/volume1/@appstore/SqueezeCenter/Slim/Player/StreamingController.pm line 700)
    frame 9: Slim::Player::StreamingController::__ANON__ (/volume1/@appstore/SqueezeCenter/Slim/Player/Song.pm line 341)
    frame 10: Slim::Player::Song::getNextSong (/volume1/@appstore/SqueezeCenter/Slim/Player/StreamingController.pm line 705)
    frame 11: Slim::Player::StreamingController::_getNextTrack (/volume1/@appstore/SqueezeCenter/Slim/Player/StreamingController.pm line 960)
    frame 12: Slim::Player::StreamingController::_StopGetNext (/volume1/@appstore/SqueezeCenter/Slim/Player/StreamingController.pm line 287)
    frame 13: Slim::Player::StreamingController::_eventAction (/volume1/@appstore/SqueezeCenter/Slim/Player/StreamingController.pm line 2123)
    frame 14: Slim::Player::StreamingController:lay (/volume1/@appstore/SqueezeCenter/Slim/Control/Commands.pm line 1060)
    frame 15: Slim::Control::Commands:laylistJumpCommand (/volume1/@appstore/SqueezeCenter/Slim/Control/Request.pm line 1883)
    frame 16: (eval) (/volume1/@appstore/SqueezeCenter/Slim/Control/Request.pm line 1883)
    frame 17: Slim::Control::Request::execute (/volume1/@appstore/SqueezeCenter/Slim/Control/Request.pm line 880)
    frame 18: Slim::Control::Request::executeRequest (/volume1/@appstore/SqueezeCenter/Slim/Player/Client.pm line 642)
    frame 19: Slim::Player::Client::execute (/volume1/@appstore/SqueezeCenter/Slim/Control/Commands.pm line 1779)
    frame 20: Slim::Control::Commands:laylistXtracksCommand (/volume1/@appstore/SqueezeCenter/Slim/Control/Request.pm line 1883)
    frame 21: (eval) (/volume1/@appstore/SqueezeCenter/Slim/Control/Request.pm line 1883)
    frame 22: Slim::Control::Request::execute (/volume1/@appstore/SqueezeCenter/Slim/Control/Request.pm line 880)
    frame 23: Slim::Control::Request::executeRequest (/volume1/@appstore/SqueezeCenter/Slim/Control/Commands.pm line 2096)
    frame 24: Slim::Control::Commands:laylistcontrolCommand (/volume1/@appstore/SqueezeCenter/Slim/Control/Request.pm line 1883)
    frame 25: (eval) (/volume1/@appstore/SqueezeCenter/Slim/Control/Request.pm line 1883)
    frame 26: Slim::Control::Request::execute (/volume1/@appstore/SqueezeCenter/Slim/Web/JSONRPC.pm line 450)
    frame 27: Slim::Web::JSONRPC::requestMethod (/volume1/@appstore/SqueezeCenter/Slim/Web/JSONRPC.pm line 254)
    frame 28: (eval) (/volume1/@appstore/SqueezeCenter/Slim/Web/JSONRPC.pm line 254)
    frame 29: Slim::Web::JSONRPC::handleURI (/volume1/@appstore/SqueezeCenter/Slim/Web/HTTP.pm line 478)
    frame 30: Slim::Web::HTTP:rocessHTTP (/volume1/@appstore/SqueezeCenter/Slim/Networking/IO/Select.pm line 122)
    frame 31: (eval) (/volume1/@appstore/SqueezeCenter/Slim/Networking/IO/Select.pm line 118)
    frame 32: Slim::Networking::IO::Select::__ANON__ (/volume1/@appstore/SqueezeCenter/Slim/Networking/IO/Select.pm line 167)
    frame 33: (eval) (/volume1/@appstore/SqueezeCenter/Slim/Networking/IO/Select.pm line 167)
    frame 34: Slim::Networking::IO::Select::loop (/volume1/@appstore/SqueezeCenter/slimserver.pl line 728)
    frame 35: main::idle (/volume1/@appstore/SqueezeCenter/slimserver.pl line 678)
    frame 36: main::main (/volume1/@appstore/SqueezeCenter/slimserver.pl line 1211)

    [20-12-03 09:19:34.0109] Slim::Player::Song:pen (413) Error: Couldn't create command line for cur playback for [file:///volume1/music/FLAC/10cc/[1997]%20The%20Very%20Best%20of%2010cc/04%20-%20The%20Wall%20Street%20Shuffle.flac]

    Should I re-install my LMS, I use the Erland plugins, then I have to start with 7.9.2 because they still do not work directly with 8.0?

  4. #4
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    19,923
    Quote Originally Posted by Tapaballou View Post
    I have tried today again and get the following server.log
    .
    .
    .
    Should I re-install my LMS, I use the Erland plugins, then I have to start with 7.9.2 because they still do not work directly with 8.0?
    A similar error was logged by another user and it seemed to come from Castbridge.

    What plugins do you have installed ?
    If you disable all 3rd party plugins - does the error recur ?

    Please give system information.
    What version of 8.0.0 - full details - build date . 8.0.0 is "old" there were bugs in 8.0.0 release so 8.0.1 is proper release. 8.1.0 is "bleeding" edge.
    What OS ? (is it a NAS ?)
    What is version of IO::Socket::SSL
    What is version of openSSL ?

    Erlands plugins do work with 8.0.0 but they need to be installed manually as Erland does not support them anymore and nobody else wants to take them over.
    If you use 7.9.2 you'll have problem with plugin repositories as 7.9.2 does not have sufficent https support.

    edit:

    Ignore OS request about OS - I see it in first post.
    Get LMS v8.0.1
    version of IO::Socket::SSL must be at least 2.06
    What is version of openSSL ? must be at least 1.1.*
    Last edited by bpa; 2020-12-03 at 01:53.

  5. #5
    Member
    Join Date
    Aug 2015
    Location
    Germany
    Posts
    33
    Quote Originally Posted by bpa View Post
    A similar error was logged by another user and it seemed to come from Castbridge.

    What plugins do you have installed ?
    If you disable all 3rd party plugins - does the error recur ?

    Please give system information.
    What version of 8.0.0 - full details - build date . 8.0.0 is "old" there were bugs in 8.0.0 release so 8.0.1 is proper release. 8.1.0 is "bleeding" edge.
    What OS ? (is it a NAS ?)
    What is version of IO::Socket::SSL
    What is version of openSSL ?

    Erlands plugins do work with 8.0.0 but they need to be installed manually as Erland does not support them anymore and nobody else wants to take them over.
    If you use 7.9.2 you'll have problem with plugin repositories as 7.9.2 does not have sufficent https support.

    edit:

    Ignore OS request about OS - I see it in first post.
    Get LMS v8.0.1
    version of IO::Socket::SSL must be at least 2.06
    What is version of openSSL ? must be at least 1.1.*
    Version: 8.0.0 - 1605892076 @ Fri Nov 20 18:28:44 CET 2020
    Betriebssystem: Synology DSM 6.2.3 - DE - utf8
    Plattformarchitektur: x86_64-linux
    Perl-Version: 5.24.0 - x86_64-linux
    Audio::Scan: 0.95
    IO::Socket::SSL: 2.037
    Datenbankversion: DBD::SQLite 1.34_01 (sqlite

    Where do I get a newer version of IO::Socket::SSL for my NAS?

    I have not installed Chromecast Bridge, but the following plugins:

    Amazon-CD-Store 1.0
    Bildbrowser 1.0
    Classical.com 1.0
    Datum und Zeit 1.0
    Datum/Zeit Bildschirmschoner (SuperDateTime) 5.11.4
    Deezer 1.0
    Digitale Eingńnge 1.0
    Drag & Drop Musikdateien zur Wiedergabe 0.1
    Entfernte Musiksammlungen 1.0
    Erweiterte Musik MenŘs 1.0
    Gerńt anpassen 1.0
    Info-Browser 1.0
    Last.fm Audioscrobbler 1.0
    License Manager 1.1.40
    Line-In 1.0
    Live Music Archive 1.0
    Material Skin 2.0.2
    MOG 1.0
    MP3tunes-Musiktruhe 1.0
    Musik- und Interpreten-Information 1.6.25
    Musiksammlung erneut durchsuchen 1.0
    Musikwiedergabe nie anhalten 1.0.0
    mysqueezebox.com-Service Handler 1.0
    Napster 1.0
    Netzwerktest 1.0
    Online Musiksammlungsintegration 1.0
    Orange Liveradio 1.0
    Pandora 3.0
    Presets bearbeiten 1.0
    Radio 1.0
    Radio Paradise 3.1.0
    RSS-Nachrichtenticker 1.0
    Slacker 1.0
    Song Lyrics 1.1.3856
    Titel-Scanner 2.0
    UPnP/DLNA Media Interface 1.0
    Visualisierungs-Bildschirmschoner 1.0
    Volltextsuche 1.0.0
    Wiedergabeliste speichern 1.0
    Zufallsmix 1.0

  6. #6
    Member
    Join Date
    Aug 2015
    Location
    Germany
    Posts
    33
    Have now started LMS witout any of thirdparty plugins activated (only Logitech), but I get the same errors.

  7. #7
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    19,923
    Quote Originally Posted by Tapaballou View Post
    Have now started LMS witout any of thirdparty plugins activated (only Logitech), but I get the same errors.
    Nov 20 LMS 8.0.0 is "old" and so you could be experiencing a bug that has already been fixed.
    I'd look at fixing IO::Socket:SSL and openssl first as otherwise you'll have problems.

    Post on this this thread as that is where Synology questions are best answered.
    https://forums.slimdevices.com/showt...packages/page7

  8. #8
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    19,923
    Do you use cue files ?

    I checked the "Cue" file changes which I thought might this problem were made in NOv 10 & 11 (changed, reverted and changed again) - so your Nov 20 version shoudl eb up to date.

    If you use cue file can you post one of the problem ".cue" files.

  9. #9
    Member
    Join Date
    Aug 2015
    Location
    Germany
    Posts
    33
    Yes, I am using Cue-Files. But I never had any problems because of them. I have now switched back to Version 7.9.2 and everything works fine.
    So you are right and there is bug in 8.0.0. I wait until Martin implements 8.0.1 to the Synology LMS Update Channel. Hopefully this will help.

  10. #10
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    19,923
    Quote Originally Posted by Tapaballou View Post
    Yes, I am using Cue-Files. But I never had any problems because of them. I have now switched back to Version 7.9.2 and everything works fine.
    So you are right and there is bug in 8.0.0. I wait until Martin implements 8.0.1 to the Synology LMS Update Channel. Hopefully this will help.
    MY feeling is that a change on 11 Nov may be the bug.

    Can attach to a post a cue file (may need to zip it) for one of the problem file . I have tested other cue files and they work OK. This bug seems to be a associated with a special sort of cue file given the "cur" type for "referenced cue" but I am not familiar with it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •