Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 4 of 4
  1. #1
    Junior Member
    Join Date
    Nov 2020
    Posts
    1

    Settings for USB audio to Klipsch R-51PM

    Hello. I'm trying to get a new picoreplayer/LMS installation working with Klipsch powered speakers. Everything seems to be working except I don't get any sound.

    Squeezelite apparently sees the speakers since clicking More by Output Setting shows me a list of possible strings specific to the R-51PM's. Depending on which I select I either get an error restarting message or it seems to work, but either way I'm not getting any sound. Whether it accepts the particular string or not varies so it may restart OK on hw:CARD=R51PM,DEV=0 one time and then error another. If it doesn't error out and I try to play something the player will look like it's playing a track sometimes, and sometimes it doesn't do anything. Regardless, silence.

    I have not touched any of the rest of the squeezelite settings and don't know if I'm supposed to. I'm using mp3 and flac files, but it's the same thing with radio stations.

    Appreciate any help.

  2. #2
    Senior Member kidstypike's Avatar
    Join Date
    Feb 2007
    Location
    Brindle
    Posts
    4,486
    Quote Originally Posted by alexdz57 View Post
    Hello. I'm trying to get a new picoreplayer/LMS installation working with Klipsch powered speakers. Everything seems to be working except I don't get any sound.

    Squeezelite apparently sees the speakers since clicking More by Output Setting shows me a list of possible strings specific to the R-51PM's. Depending on which I select I either get an error restarting message or it seems to work, but either way I'm not getting any sound. Whether it accepts the particular string or not varies so it may restart OK on hw:CARD=R51PM,DEV=0 one time and then error another. If it doesn't error out and I try to play something the player will look like it's playing a track sometimes, and sometimes it doesn't do anything. Regardless, silence.

    I have not touched any of the rest of the squeezelite settings and don't know if I'm supposed to. I'm using mp3 and flac files, but it's the same thing with radio stations.

    Appreciate any help.
    Turned your volume up to 100% in LMS?

    Name:  volume.jpg
Views: 83
Size:  18.2 KB
    Server - LMS 8.2.0 Pi4B 4GB/Argon one case/pCP v7.0.1 - 75K library, playlists & LMS cache on SSD (ntfs)
    Study - Pi3B/pCP 7.0.1/pi screen/AlloBoss DAC HAT/Ruark MR1 Mk2
    Lounge - Pi2/pCP 6.0.0 > HiFiBerry DIGI+ > AudioEngine DAC1 > AVI DM5
    Dining Room - Pi3B/pCP/Bluetooth/Echo Show 8
    Garage - DAC32 > Edifier speakers

    Spares - 2xTouch, 1xSB Radio. 1xSB3, 6xRPi

  3. #3
    Senior Member
    Join Date
    Jan 2011
    Location
    Staffordshire. UK
    Posts
    4,294
    @alexdz57

    Any message in the server log after youi try and play something, a radio station for example ?.

    Try
    Code:
     plughw:CARD=R51PM,DEV=0
    Did you save after changing the squeezelite setting ? (it sometimes help to reboot).

    Is there a volume setting on the control speaker?

    ronnie

  4. #4
    Junior Member firebelli's Avatar
    Join Date
    Jan 2015
    Location
    Tokyo, Japan
    Posts
    16
    @alexdz57
    My powered speakers needed additional unmute option during the past pcp updates to get sound.
    Might want to check 'more>' at 'Unmute ALSA control' and try suggested setting,
    e.g.
    Code:
    Card 1: R51PM - Control: PCM
    then set
    Code:
    PCM
    at 'Unmute ALSA control'. (I guess you are using hardware volume control.)

    firebelli
    LMS 8 on DS916+/918+/920+ as Prod/DR/Dev. Allo DigiOne sig+USBridge, coax to Onkyo DAC-1000S, Nmode X-PW1 mk2 power amps in dual mono, DIY folded horn speakers. Numerous PCPs and cards for tube amp, receiver, powered speakers, DAC or HPA. Semi-retiring TP SE, EDO'd Touch and original SB3.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •